none
Problema con Menú Asp RRS feed

  • Pregunta

  • Buenas noches

    Tengo un problema con el menú de mi master page. Lo que sucede es que cada vez que se carga, recarga o doy clic en algun submenú o elemento que recargue la página el menú se desacomoda por un instante. Con este quiero decir que el menú esta en horizontal y al dar clic en un submenú se recarga la página y se mueve el menú en forma vertical.

    Cuando doy clic en algún menú  o submenú queda por un momento de la siguiente manera:

    Cabe destacar que el proyecto lo cree desde el principio en visual studio 2010 y posteriormente segui trabajando con el mismo en visual studio 2013. En realidad no sé que causa el problema, espero me puedan ayudar. Saludos  y gracias de antemano.

    lunes, 25 de mayo de 2015 6:35

Respuestas

  • hola

    estos sucede con trodos los browsers ? o solo lo has probado con IE

    el tema parece ser que la pagina esta algo pesada, cargada de datos y el render al mostrarla demora un poco por eso el menu y el resto del sitio se distorciona, hasta que se completa el render del html

    valida la propiedad

    Menu.RenderingMode Property

    ---

    sino podrias aplicar este truco

    ASP .NET menu carga muy lento

    basicamente lo que hace es ocultar el menu hasta que termine de cargar la pagina

    saludos


    Leandro Tuttini

    Blog
    MVP Profile
    Buenos Aires
    Argentina

    lunes, 25 de mayo de 2015 8:01

Todas las respuestas

  • hola

    estos sucede con trodos los browsers ? o solo lo has probado con IE

    el tema parece ser que la pagina esta algo pesada, cargada de datos y el render al mostrarla demora un poco por eso el menu y el resto del sitio se distorciona, hasta que se completa el render del html

    valida la propiedad

    Menu.RenderingMode Property

    ---

    sino podrias aplicar este truco

    ASP .NET menu carga muy lento

    basicamente lo que hace es ocultar el menu hasta que termine de cargar la pagina

    saludos


    Leandro Tuttini

    Blog
    MVP Profile
    Buenos Aires
    Argentina

    lunes, 25 de mayo de 2015 8:01
  • Gracias por contestar Leandro, me sucede con Chrome y también con opera. Tengo entendido que usan el mismo motor de renderizado pero voy a aplicar lo que me comentas a ver que tal.
    miércoles, 27 de mayo de 2015 1:49