none
Error Microsoft.office.core al cambiar de ordenador RRS feed

  • Pregunta

  • Buenas tardes,

    A ver si alguien puede responderme por que llevo varios días desesperado.

    Resulta que me he cambiado de ordenador y he instalado el Visual Basic 2010 express pero ahora todos mis programas me salen con los siguientes mensajes de error que no me dejan compilar:

    Warning 1 Cannot find wrapper assembly for type library "Microsoft.Office.Core". Verify that (1) the COM component is registered correctly and (2) your target platform is the same as the bitness of the COM component. For example, if the COM component is 32-bit, your target platform must not be 64-bit.
    Warning 2 The referenced component 'Microsoft.Office.Core' could not be found.

    Creo que tiene que ver con el paquete office instalado en el ordenador pero no estoy seguro. ¿Alguien podría decirme como solucionarlo? Gracias.

    domingo, 15 de octubre de 2017 15:52

Todas las respuestas

  • Buenas tardes,

    A ver si alguien me puede ayudar por que estoy un poco desesperado.

    Resulta que he cambiado de ordenador y en el nuevo he vuelto a instalar visual basic 2010 express pero todos mis antiguo proyectos salen los siguientes warrnign que no me dejan compilar:

    Warning 1 Cannot find wrapper assembly for type library "Microsoft.Office.Core". Verify that (1) the COM component is registered correctly and (2) your target platform is the same as the bitness of the COM component. For example, if the COM component is 32-bit, your target platform must not be 64-bit. PILOTEV5

    Warning 2 The referenced component 'Microsoft.Office.Core' could not be found.

    Creo que tiene que ver con la versión de office instalada (en el nuevo ordenador es la 2013 y en el antiguo puede que fuera posterior o anterior, no se).

    Gracias de antemano.

    domingo, 15 de octubre de 2017 15:59
  • Pueden ser varias cosas desde la plataforma de compilación x86 x64 hasta que falten instalar paquetes al VB 2010

    Yo primero actulizaría vb, luego es necesario sabér bajo que plataforma ejecutaban tus proyectos, si esa es la dirferencia, tendras que reemplazar los componentes que tienes bajo 32 por los que tienes ahora en la pc ej: 64 para el caso elimina de referencias el componente y vuelve a cargar el componente que te ofrece la lista, también deberías eliminar los componentes de la carpeta Debug  (o eliminarla completa) para luego volver a generar con los nuevos componentes cargados a los proyectos

    Saludos

    domingo, 15 de octubre de 2017 17:54
  • Hola,

    Gracias por la respuesta pero Sigo con el mismo problema. Ambos ordenadores iban con x64 y por tanto ahí no está el problema.

    Sigo pensando que antes tenía el paquete office 207 y ahora el 2013 y por el error creo que puede estar ahí problema ¿Qué opinan de esto? Y si estuviera ahí el problema, ¿que puedo hacer?

    Saludos

    jueves, 19 de octubre de 2017 13:50
  • Hola

    Además de que pueda ser por los bits 32 o 64, las versiones pueden fallar. En el caso de tener ahora instalado 2013 y anterior 2007, puedes probar referenciando la librería de esta última versión. En el caso que sea 2003 tu versión anterior, ahí si es diferente la forma de trabajo, recuerda que desde esa versión cambia incluso el formato de salida de los documentos.

    Saludos


    Brayan De la Cruz
    Lima - Perú

    jueves, 19 de octubre de 2017 14:08