none
ayuda con validacion con la tecla Tab c# RRS feed

  • Pregunta

  • hace algunos dias formule una pregunta similar, de lo cual la respuesta fue optima. Pero resulta que me surgio otra problematica

    paso a detallar:

    Tengo el rut digitado

    Pero cuando pulso la tecla tab, el txtRutEmpresa lo envia en blanco siendo que txtRutEmpresa viene con el rut.

    Saludos

    LatinWater!

    viernes, 3 de junio de 2016 14:06

Respuestas

  • Hola LatinWater

    Gracias por consultar en los foros. Permíteme preguntarte, ¿al ingresar un valor en el campo, no estás recibiendo el texto del usuario? Si revisas el siguiente ejemplo, estoy recibiendo texto como string y enviando el valor a otro textbox, en tu caso, cual es el mensaje de error que recibes? Estoy atento a tus comentarios.

       public static string input1;
            public static string input2;
            public static string input3;
    
            public Form1()
            {
                InitializeComponent();
            }
    
            private void textBox1_TextChanged(object sender, EventArgs e)
            {
                input1 = textBox1.Text;
                textBox4.Text = input1;
            }
    
            private void textBox2_TextChanged(object sender, EventArgs e)
            {
                input2 = textBox2.Text;
                textBox5.Text = input2;
            }
    
            private void textBox3_TextChanged(object sender, EventArgs e)
            {
                input3 = textBox3.Text;
                textBox6.Text = input3;
            }
    Espero sea de utilidad, de ser posible comparte tu segmento de código o capturas de pantalla con el error.

    Saludos
    José
    __________________________________________________________________________________________
    Por favor, recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, hace que sea más fácil para los otros visitantes encontrar la solución más tarde. Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft. Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft.



    • Marcado como respuesta LatinWater jueves, 9 de junio de 2016 14:30
    lunes, 6 de junio de 2016 18:00
    Moderador

Todas las respuestas

  • Hola LatinWater

    Gracias por consultar en los foros. Permíteme preguntarte, ¿al ingresar un valor en el campo, no estás recibiendo el texto del usuario? Si revisas el siguiente ejemplo, estoy recibiendo texto como string y enviando el valor a otro textbox, en tu caso, cual es el mensaje de error que recibes? Estoy atento a tus comentarios.

       public static string input1;
            public static string input2;
            public static string input3;
    
            public Form1()
            {
                InitializeComponent();
            }
    
            private void textBox1_TextChanged(object sender, EventArgs e)
            {
                input1 = textBox1.Text;
                textBox4.Text = input1;
            }
    
            private void textBox2_TextChanged(object sender, EventArgs e)
            {
                input2 = textBox2.Text;
                textBox5.Text = input2;
            }
    
            private void textBox3_TextChanged(object sender, EventArgs e)
            {
                input3 = textBox3.Text;
                textBox6.Text = input3;
            }
    Espero sea de utilidad, de ser posible comparte tu segmento de código o capturas de pantalla con el error.

    Saludos
    José
    __________________________________________________________________________________________
    Por favor, recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, hace que sea más fácil para los otros visitantes encontrar la solución más tarde. Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft. Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft.



    • Marcado como respuesta LatinWater jueves, 9 de junio de 2016 14:30
    lunes, 6 de junio de 2016 18:00
    Moderador
  • Tal vez estés inicializando (poniendo blancos) en el load de la página. Para ello deberías establecer

    If Not IsPostBack Then 
    
    'Tu código inicialización
    
    End if
    Puedes ponernos el codigo de dicho manejador de evento? Gracias



    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó, vótala como útil. Saludos

    martes, 7 de junio de 2016 8:18
    Moderador
  • Gracias por la respuesta las revisare y les comento

    Saludos

    LatinWater!

    martes, 7 de junio de 2016 13:40
  • Hola,

    nos puedes comentar algo mas? gracias


    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó, vótala como útil. Saludos

    jueves, 9 de junio de 2016 11:04
    Moderador
  • Gracias de atemano por la ayuda, ahi me resulto.

    LatinWater!

    jueves, 9 de junio de 2016 14:31