none
ERROR AL INICIAR SESION EN IIS RRS feed

  • Pregunta

  • Saludos a todos... haber si me ayudan... la aplicación en la que estoy trabajando cuando la lanzo desde el microsoft visual studio 2010 funciona todo bien... el inicio de sesión y demás... pero cuando la lanzo desde el IIS no me inicia sesión me muestra el siguiente error...

    Login failed for user "USERDEB"

    este es mi web.config

    <?xml version="1.0"?>
    <configuration>
      <appSettings/>
      <connectionStrings>
        <!--add name="SGFidecDBConnectionString" connectionString="data source=CARLOSFRANCESCH\SQLEXPRESS;integrated security=SSPI;initial catalog=SGFidecDB;" providerName="System.Data.SqlClient"/-->
     <!--add name="SGFidec" connectionString="Data Source=W7-PC\SQLEXPRESS;Initial Catalog=SGFidecDB;User Id=fidec;password=12345;" providerName="System.Data.SqlClient" /-->
     <add name="SGFidecDBConnectionString" connectionString="Data Source=CARLOSFRANCESCH\SQLEXPRESS;Initial Catalog=SGFidecDB;User Id=fidec;password=12345;" providerName="System.Data.SqlClient" />
      </connectionStrings>
    <system.web>

    <!--compilation debug="true" strict="false" explicit="true" targetFramework="4.0" /-->
    <compilation debug="true" strict="false" explicit="true" targetFramework="4.0">
    <assemblies>
    <add assembly="System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
    <add assembly="System.Web.Extensions.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
    <add assembly="System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
    </assemblies>
    </compilation>
    <pages controlRenderingCompatibilityVersion="3.5" clientIDMode="AutoID">
    <namespaces>
    <clear/>
    <add namespace="System"/>
    <add namespace="System.Collections"/>
    <add namespace="System.Collections.Generic"/>
    <add namespace="System.Collections.Specialized"/>
    <add namespace="System.Configuration"/>
    <add namespace="System.Text"/>
    <add namespace="System.Text.RegularExpressions"/>
    <add namespace="System.Linq"/>
    <add namespace="System.Xml.Linq"/>
    <add namespace="System.Web"/>
    <add namespace="System.Web.Caching"/>
    <add namespace="System.Web.SessionState"/>
    <add namespace="System.Web.Security"/>
    <add namespace="System.Web.Profile"/>
    <add namespace="System.Web.UI"/>
    <add namespace="System.Web.UI.WebControls"/>
    <add namespace="System.Web.UI.WebControls.WebParts"/>
    <add namespace="System.Web.UI.HtmlControls"/>
    </namespaces>
    </pages>
    <authentication mode="None"/>

    <!--customErrors mode="Off" /-->
    <globalization uiCulture="es" culture="es-MX"/>
    </system.web>
    </configuration>

    <add name="SGFidecDBConnectionString" connectionString="Data Source=W7\SQLEXPRESS;Initial Catalog=SGFidecDB;User Id=fidecdb;password=12345;" providerName="System.Data.SqlClient" />

    haber si me ayudan ...


    • Editado webcarlosf lunes, 17 de septiembre de 2012 17:34
    lunes, 17 de septiembre de 2012 15:10

Todas las respuestas

  • Pero cual cadena de conexión es la que estas usando para acceder a la base de datos ?

    Esta:

     <add name="SGFidecDBConnectionString" connectionString="Data Source=CARLOSFRANCESCH\SQLEXPRESS;Initial Catalog=SGFidecDB;User Id=fidec;password=12345;" providerName="System.Data.SqlClient" />

    O esta:

    <add name="SGFidecDBConnectionString" connectionString="Data Source=W7\SQLEXPRESS;Initial Catalog=SGFidecDB;User Id=fidecdb;password=12345;" providerName="System.Data.SqlClient" />

    Ademas, trata de poner todo el código de tu capa de presentación en bloques try catch, ya que eso es un error no controlado y no esta bien.


    Un saludo, Cristian Pérez

    lunes, 17 de septiembre de 2012 19:02
  • Pero cual cadena de conexión es la que estas usando para acceder a la base de datos ?

    Esta:

     <add name="SGFidecDBConnectionString" connectionString="Data Source=CARLOSFRANCESCH\SQLEXPRESS;Initial Catalog=SGFidecDB;User Id=fidec;password=12345;" providerName="System.Data.SqlClient" />

    O esta:

    <add name="SGFidecDBConnectionString" connectionString="Data Source=W7\SQLEXPRESS;Initial Catalog=SGFidecDB;User Id=fidecdb;password=12345;" providerName="System.Data.SqlClient" />

    Ademas, trata de poner todo el código de tu capa de presentación en bloques try catch, ya que eso es un error no controlado y no esta bien.


    Un saludo, Cristian Pérez

    con ninguna de esas cdanedas de conexcion se conecta cuando utilizo el IIS
    lunes, 17 de septiembre de 2012 21:43