none
Problema para utilizar el Provedor Microsoft.Jet.OLEDB.4.0 en IIS RRS feed

  • Pregunta

  • Que tal compañeros, estoy desarrollando una aplicación web en ASP.NET que se conecta a una base de OficceAccess (base.mdb). Tengo instalada la suite de Office Profesional 2010 en mi equipo, tengo agregada la connectiostring en mi webconfig y me corre bien desde Visual studio 2012.(Mi equipo es Windows 8 x64). El problema viene cuando lo mosto al IIS;solo corre el sitio mientras no invoke coneccion a la base Acces, me arroja que el Provedor  Microsoft.Jet.OLEDB.4.0 no està registrado en el equipo local.

    <?xml version="1.0" encoding="UTF-8"?>
    
    <configuration>
      <appSettings>
       
      </appSettings>
      <connectionStrings>
        <add name="tiendaConnectionString" connectionString="Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\directorio\tienda.mdb;Jet OLEDB:Database Password=dc1885" providerName="System.Data.OleDb" />
        <add name="cajaConnectionString" connectionString="Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\directorio\caja.mdb;Jet OLEDB:Database Password=dc1885" providerName="System.Data.OleDb" />
        <add name="gestorFacturasConnectionString" connectionString="Data Source=Servidor\WIN8R2;Initial Catalog=gestorFacturas;Integrated Security=True" providerName="System.Data.SqlClient" />
      </connectionStrings>
    	<system.webServer>
    		<defaultDocument>
    			<files>
    				<clear />
    				<add value="default.aspx" />
    				<add value="Default.htm" />
    				<add value="Default.asp" />
    				<add value="index.htm" />
    				<add value="index.html" />
    				<add value="iisstart.htm" />
    			</files>
    		</defaultDocument>
    	</system.webServer>
      <system.web>
        <!-- <sessionState mode ="SQLServer" sqlConnectionString ="Data Source=Servidor\WIN8R2;Initial Catalog=gestorFacturas;user id=MiUsuarioSQL; password=XXXXXXXXX" cookieless ="true" timeout ="20"></sessionState>-->
        <compilation debug="true" strict="false" explicit="true" targetFramework="4.0">
          
          <assemblies>
            <add assembly="System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
            <add assembly="System.Data.Linq, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
            <add assembly="mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
            
          </assemblies>
        </compilation>
    	      <authentication mode="Forms">
          <forms name="SESSION-GESTOR" loginUrl="~/Account/Login.aspx" timeout="5880" />
        </authentication>
    
        <membership>
          <providers>
            <clear />
            <add name="AspNetSqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider" connectionStringName="gestorFacturasConnectionString" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="false" requiresUniqueEmail="false" maxInvalidPasswordAttempts="5" minRequiredPasswordLength="6" minRequiredNonalphanumericCharacters="0" passwordAttemptWindow="10" applicationName="Web-Integracion" />
    		  <add name=".NET Framework Data Provider for OLE DB" type ="Microsoft.Jet.OLEDB.4.0" connectionStringName="tiendaConnectionString"/>
          </providers>
        </membership>
        <profile>
          <providers>
            <clear />
            <add name="AspNetSqlProfileProvider" type="System.Web.Profile.SqlProfileProvider" connectionStringName="ApplicationServices" applicationName="/" />
    		  <add name=".NET Framework Data Provider for OLE DB" type ="Microsoft.Jet.OLEDB.4.0" connectionStringName="tiendaConnectionString"/>
          </providers>
        </profile>
        <roleManager enabled="false">
          <providers>
            <clear />
            <add name="AspNetSqlRoleProvider" type="System.Web.Security.SqlRoleProvider" connectionStringName="ApplicationServices" applicationName="/" />
            <add name="AspNetWindowsTokenRoleProvider" type="System.Web.Security.WindowsTokenRoleProvider" applicationName="/" />
          </providers>
        </roleManager>
           
      </system.web>
     
    </configuration>

    Este es mi estructura de mi archivo,intentè agregar ese Provedor en la seccion de provedores  pero no me funciono


    La programacion en Microsoft cada ves se torna inalcanzable


    domingo, 11 de noviembre de 2018 2:09

Respuestas

  • Hola, deberías instalar Microsoft Access Database Engine 2010 Redistributable. Prueba y nos dices si todo ha ido bien

    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó, vótala como útil. Saludos

    Te agradesco sr. Parra, pero en este caso no fuè el motor de access, pues ya tengo instalado Access Office y aun asì  instale para provar y no resultò. Ya encontrè la respuesta en el sig link https://social.msdn.microsoft.com/Forums/es-ES/f06a5e23-46ef-4c83-ac86-f59c58c7b6d9/problema-oledb-aspnet?forum=netfxwebes  

    Le tuve que indicar al AplicationPool que active 32bits y va de lujo 


    La programacion en Microsoft cada ves se torna inalcanzable

    domingo, 11 de noviembre de 2018 3:06

Todas las respuestas