none
Reporting services puerto conflicto con glassfish (sql server 2005) RRS feed

  • Pregunta

  • Hola a todos.

    Mi problema es que actualmente tengo glassfish corriendo en el puerto 80 (a este servidor no puedo cambiarle por ningun motivo el puerto), al intentar cambiarle el puerto al IIS (al 8080) para que corra el reporting services, me da resultado ya que puedo ver la aplicación en http://localhost:8080/Reports, pero el problema es que no puedo entrar por sql server 2005 a la opcion tipo de servidor Reporting Services, (sin cambiar el puerto no tengo problemas para entrar).
    El error que me señala es que no encuentra la aplicacion en el puerto 80, no se si se puede resolver que acepte un puerto distinto cuando me conecto a sql server 2005 a traves de ese tipo de servidor.

    Espero me puedan ayudar. Muchas gracias.
    Pauly
    jueves, 2 de julio de 2009 17:05

Respuestas

Todas las respuestas

  • Hola.

    Si pones eso mismo (http://localhost:8080/Reports) en el Management Studio en lugar del nombre del servidor, deberías acceder. Si no es así, nos dices.

    Alberto López Grande.
    jueves, 2 de julio de 2009 19:50
    Moderador
  • Hola:

    Primero que nada te agradezco mucho que me hayas contestado.

    Lamentablemente sigo con el mismo problema, pero el error que ahora me envia es:

    No se puede conectar a http://localhost:8080/Reports (aunque si coloco eso en el browser me muestra la página correcta)
     - Información Adicional:
       --> Error al intentar conectar con el servidor de informes. Compruebe la información de conexión y que el servidor de informes sea una versión compatible. (Microsoft.SqlServer.Management.UI.RSClient)
       --> Error de la solicitud con el codigo de estado http 404: Not Found
            (Microsoft.SqlServer.Management.UI.RSClient)


    Muchas gracias.
    Pauly

    viernes, 3 de julio de 2009 20:14
  • Revisa estos links:

    Configuring Report Server Virtual Directories
    http://msdn.microsoft.com/en-us/library/ms159261(SQL.90).aspx


    Troubleshooting HTTP Errors
    http://msdn.microsoft.com/en-us/library/ms159778(SQL.90).aspx

    Saludos


    Ing. Jose Mariano Alvarez http://blog.josemarianoalvarez.com/ Microsoft MVP SQLTotal Consulting Mi.Correo.es.j0se.marian0.alvarez@gmail.c0m.Corregirl0 Este mensaje se proporciona tal como es, SIN GARANTIAS de ninguna clase
    • Marcado como respuesta PauV lunes, 13 de julio de 2009 22:47
    viernes, 3 de julio de 2009 21:06
  • Hola,

    Para entrar desde el Management Studio debes de poner solo: localhost(o nombre de la máquina):8080 o cambia los dos puntos (:) por una coma (,)

    Prueba y nos cuentas ;)

    Un Saludo


    Fran Díaz | {geeks.ms/blogs/fdiaz/} | {onobanet.com} | {secondnug.com}
    lunes, 6 de julio de 2009 8:38
    Moderador
  • Hola:

    Muchas gracias por sus respuestas, me han ayudado bastante.
    He logrado conectarme al management, el problema que me da ahora es que no puedo ingresar usuarios para otorgrales permisos de acceso, me sale el error "Error interno en el servidor de informes. Vea el registro de errores para obtener mas detalles. (rsInternalError) (Report Services SOAP Source)"

    Información Adcional: Error interno en el servidor de informes.... (Microsoft.ReportingServices.Authorization)

    Al revisar el Log me dice:

    "07/06/09 15:53:15, ERROR , SQLDUMPER_UNKNOWN_APP.EXE, AdjustTokenPrivileges () failed (00000514)
    07/06/09 15:53:15, ACTION, SQLDUMPER_UNKNOWN_APP.EXE, Input parameters: 4 supplied
    07/06/09 15:53:15, ACTION, SQLDUMPER_UNKNOWN_APP.EXE,     ProcessID = 4080
    07/06/09 15:53:15, ACTION, SQLDUMPER_UNKNOWN_APP.EXE,     ThreadId = 0
    07/06/09 15:53:15, ACTION, SQLDUMPER_UNKNOWN_APP.EXE,     Flags = 0x0
    07/06/09 15:53:15, ACTION, SQLDUMPER_UNKNOWN_APP.EXE,     MiniDumpFlags = 0x0
    07/06/09 15:53:15, ACTION, SQLDUMPER_UNKNOWN_APP.EXE,     SqlInfoPtr = 0x47405860
    07/06/09 15:53:15, ACTION, SQLDUMPER_UNKNOWN_APP.EXE,     DumpDir = <NULL>
    07/06/09 15:53:15, ACTION, SQLDUMPER_UNKNOWN_APP.EXE,     ExceptionRecordPtr = 0x00000000
    07/06/09 15:53:15, ACTION, SQLDUMPER_UNKNOWN_APP.EXE,     ContextPtr = 0x00000000
    07/06/09 15:53:15, ACTION, SQLDUMPER_UNKNOWN_APP.EXE,     ExtraFile = <NULL>
    07/06/09 15:53:15, ACTION, SQLDUMPER_UNKNOWN_APP.EXE,     InstanceName = <NULL>
    07/06/09 15:53:15, ACTION, SQLDUMPER_UNKNOWN_APP.EXE,     ServiceName = <NULL>
    07/06/09 15:53:15, ACTION, SQLDUMPER_UNKNOWN_APP.EXE, Callback type 11 not used
    07/06/09 15:53:19, ACTION, SQLDUMPER_UNKNOWN_APP.EXE, Callback type 7 not used
    07/06/09 15:53:19, ACTION, SQLDUMPER_UNKNOWN_APP.EXE, MiniDump completed: C:\Program Files\Microsoft SQL Server\MSSQL.2\Reporting Services\LogFiles\SQLDmpr0017.mdmp
    "
    y en el archivo SQLDmpr0017

    "
    ....
    w3wp!runningjobs!1!06-07-2009-15:52:51:: i INFO: Running Requests DB timer enabled: Next Event: 60 seconds.  Cycle: 60 seconds
    w3wp!runningjobs!1!06-07-2009-15:52:51:: i INFO: Memory stats update timer enabled: Next Event: 60 seconds.  Cycle: 60 seconds
    w3wp!library!1!07/06/2009-15:52:52:: i INFO: Call to GetSystemPermissions
    w3wp!library!1!07/06/2009-15:52:52:: i INFO: Catalog SQL Server Edition = Standard
    w3wp!library!1!07/06/2009-15:52:54:: i INFO: Call to GetSystemPermissions
    w3wp!library!1!07/06/2009-15:53:01:: i INFO: Call to GetSystemPermissions
    w3wp!library!1!07/06/2009-15:53:02:: i INFO: Call to GetSystemPolicies
    w3wp!library!5!07/06/2009-15:53:15:: i INFO: Call to SetSystemPolicies
    w3wp!library!5!07/06/2009-15:53:15:: e ERROR: Throwing Microsoft.ReportingServices.Diagnostics.Utilities.InternalCatalogException: Error interno en el servidor de informes. Vea el registro de errores para obtener más detalles., LookupAccountName: Win32 error:1789;
     Info: Microsoft.ReportingServices.Diagnostics.Utilities.InternalCatalogException: Error interno en el servidor de informes. Vea el registro de errores para obtener más detalles.
    "


    No se porqué me da problema ahora, ya que he trabajado con el reporting lo mas bien cuando no he tenido que cambiar el puerto eso si.

    Espero me puedan orientar, desde ya, muchas gracias por su ayuda.

    saludos,
    Pauly
    lunes, 6 de julio de 2009 20:35
  • Hola,

    ¿El problema es al hacerlo desde el Management Studio o desde el Report Manager (desde el web)?

    Lo digo, porque podríamos cerrar este hilo con una respuesta correcta y como la pregunta es diferente, volverla a hacer como nueva pregunta. Así contribuimos a que otras personas con tú primer problema vean este hilo marcado como correcto y puedan beneficiarse ;)

    Un Saludo


    Fran Díaz | {geeks.ms/blogs/fdiaz/} | {onobanet.com} | {secondnug.com}
    martes, 7 de julio de 2009 7:13
    Moderador
  • Hola,

    El problema es del  Management Studio, lo que he preguntado al comienzo, lo pude solucionar gracias a toda la ayuda que me han brinado, solo que ahora al entrar y querer darle permisos para que puedan acceder los usuarios me sale el error anterior. Si es mejor lo hacemos como dices y cerramos este hilo y pregunto nuevamente en otro.

    Muchas gracias.

    Saludos,
    Pauly

    martes, 7 de julio de 2009 14:58
  • Hola Pauly,

    ¿Qué pasó al final? ¿Abriste un nuevo hilo o lo solucionaste?

    De todas formas, marca aquí la respuesta que solucionó tú primer problema ;)

    Un Saludo


    Fran Díaz | {geeks.ms/blogs/fdiaz/} | {onobanet.com} | {secondnug.com}
    jueves, 9 de julio de 2009 6:28
    Moderador
  • Hola Pauly,

    ¿Qué pasó al final? ¿Abriste un nuevo hilo o lo solucionaste?

    De todas formas, marca aquí la respuesta que solucionó tú primer problema ;)

    Un Saludo

    Hola Fran,

    Solucioné el problema planteado al comienzo en este hilo, lo hice poniendo en Management Studio http://localhost:8080/reportserver gracias a sus respuestas. Eso me funcionó, pude entrar, pero el problema es otro ahora.

    Muchas gracias a todos los que me ayudaron. Se pasaron, muy agradecida.


    saludos,
    Pauly
    • Marcado como respuesta PauV lunes, 13 de julio de 2009 22:48
    viernes, 10 de julio de 2009 21:23
  • Me alegro que pudieras al final.

    Para terminar con el hilo, marca la/s respuesta/s correcta/s y cierro el hilo.

    Cualquier duda diferente abrimos un nuevo hilo ;)

    Un Saludo


    Fran Díaz | {geeks.ms/blogs/fdiaz/} | {onobanet.com} | {secondnug.com}
    lunes, 13 de julio de 2009 6:56
    Moderador