none
how to load into a reportviwer (vs2010) one rdl published in sharepoint2007 RRS feed

  • Pregunta

  • hi

    I have report published at sharepoint 2007, my problem is: how should I use that rdl report in my aspnet webapp ? Iwanna caal it and show it in a reportviwer,

    I am using vs2010, the sharepoint server is 2007 and sqlserver2005

    My  code:

     <rsweb:ReportViewer ID="ReportViewer1" runat="server" BorderColor="Red" 
            BorderStyle="Solid" Font-Names="Verdana" Font-Size="8pt" 
            InteractiveDeviceInfos="(Collection)" ProcessingMode="Remote" 
            WaitMessageFont-Names="Verdana" WaitMessageFont-Size="14pt">
            <ServerReport ReportPath="http://miportal/Reportes/XXX/ListaDeCosas.rdl" 
                ReportServerUrl="http://miportal/" 
             />
        </rsweb:ReportViewer>
    and When I run it I got this:

    The attempt to connect to the report server failed. Check your connection information and that the report server is a compatible version.
    Client found response content type of 'text/html; charset=utf-8', but expected 'text/xml'. The request failed with the error message: -- <HTML dir="ltr"> <HEAD><meta name="GENERATOR" content="Microsoft SharePoint" /><meta name="progid" content="SharePoint.WebPartPage.Document" /><meta HTTP-EQUIV="Content-Type" content="text/html; charset=utf-8" /><meta HTTP-EQUIV="Expires" content="0" /><meta name="ROBOTS" content="NOHTMLINDEX" /><title> Error </title><link rel="stylesheet" type="text/css" href="/_layouts/3082/styles/core.css?rev=tLJBk8aGDXac%2BaUQ4b1cJA%3D%3D"/> <script type="text/javascript" language="javascript" src="/_layouts/3082/init.js?rev=qQqJ%2B4wiXhp%2Bsi8xwuuM1A%3D%3D"></script> <script type="text/javascript" language="javascript" src="/_layouts/3082/core.js?rev=yxewtlu23Cg4w2%2FBk9EQiQ%3D%3D"></script> <meta name="Robots" content="NOINDEX " /> <meta name="SharePointError" content=""/> </HEAD> <BODY scroll="yes" onload="javascript:if (typeof(_spBodyOnLoadWrapper) != 'undefined') _spBodyOnLoadWrapper();"> <form name="aspnetForm" method="post" action="../../../_layouts/error.aspx" id="aspnetForm" onsubmit="return _spFormOnSubmitWrapper();"> <div> <input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value="/wEPDwUKLTU2NjkxODU3M2Rkuv2zA5vnQinS+xCMRO9ktp5tGjk=" /> </div> <TABLE class="ms-main" CELLPADDING=0 CELLSPACING=0 BORDER=0 WIDTH="100%" HEIGHT="100%"> <tr><td> <table CELLPADDING=0 CELLSPACING=0 BORDER=0 WIDTH="100%"> <tr> <td colspan=4 class="ms-globalbreadcrumb" align="right">  <a href="javascript:TopHelpButtonClick('NavBarHelpHome')" id="ctl00_PlaceHolderGlobalNavigation_TopHelpLink" AccessKey="6" title="Help (new window)"><img src="/_layouts/images/helpicon.gif" align="absmiddle" border="0" alt="Help (new window)" /></a> </td> </tr> </table> </td></tr> <tr> <td class="ms-globalTitleArea"> <table width=100% cellpadding=0 cellspacing=0 border=0> <tr> <td id="GlobalTitleAreaImage" class="ms-titleimagearea"><img id="onetidHeadbnnr0" src="/_layouts/images/titlegraphic.gif" alt="" /></td> <td class="ms-sitetitle" width=100%> </td> <td style="padding-top:8px;" valign=top> </td> </tr> </table> </td> </tr> <TR> <TD id="onetIdTopNavBarContainer" WIDTH=100% class="ms-bannerContainer"> </TD> </TR> <TR height="100%"><TD><TABLE width="100%" height="100%" cellspacing="0" cellpadding="0"> <tr> <td class="ms-titlearealeft" id="TitleAreaImageCell" valign="middle" nowrap><div style="height:100%" class="ms-titleareaframe"></div></td> <td class="ms-titleareaframe" id="TitleAreaFrameClass"> <table cellpadding=0 height=100% width=100% cellspacing=0> <tr><td class="ms-areaseparatorleft"><IMG SRC="/_layouts/images/blank.gif" width=1 height=1 alt=""></td></tr> </table> </td> <td valign=top id="onetidPageTitleAreaFrame" class='ms-areaseparator' nowrap width="100%"> <table id="onetidPageTitleAreaTable" cellpadding=0 cellspacing=0 width=100% border="0"> <tr> <td valign="top" class="ms-titlearea"> <a href="http://portalcre" id="ctl00_PlaceHolderTitleBreadcrumb_idSimpleGoBackToHome">Go back to site</a> </td> </tr> <tr> <td height=100% valign=top ID=onetidPageTitle class="ms-pagetitle"> <h2 class="ms-pagetitle"> Error </h2> </td> </tr> </table> </td> <td class="ms-titlearearight"> <div class='ms-areaseparatorright'><IMG SRC="/_layouts/images/blank.gif" width=8 height=100% alt=""></div> </td> </tr> <TR> <TD class="ms-leftareacell" valign=top height=100% id="LeftNavigationAreaCell"> <table class=ms-nav width=100% height=100% cellpadding=0 cellspacing=0> <tr> <td> <TABLE height="100%" class=ms-navframe CELLPADDING=0 CELLSPACING=0 border="0"> <tr valign="top"> <td width="4px"><IMG SRC="/_layouts/images/blank.gif" width=4 height=1 alt=""></td> <td valign="top" width="100%">   </td> </tr> <tr><td colspan=2><IMG SRC="/_layouts/images/blank.gif" width=138 height=1 alt=""></td></tr> </TABLE> </td> <td></td> </tr> </table> </TD> <td> <div class='ms-areaseparatorleft'><IMG SRC="/_layouts/images/blank.gif" width=8 height=100% alt=""></div> </td> <td class='ms-formareaframe' valign="top"> <TABLE width="100%" border="0" cellspacing="0" cellpadding="0" class="ms-propertysheet"> <TR valign="top" > <TD class="ms-descriptiontext" width="100%"> </TD> <TD ID=onetidYPadding width="10px"><IMG SRC="/_layouts/images/blank.gif" width=10 height=1 alt=""></TD> </TR> <TR > <TD ID=onetidMainBodyPadding height="8px"><IMG SRC="/_layouts/images/blank.gif" width=1 height=8 alt=""></TD> </TR> <tr> <td valign="top" height="100%"> <A name="mainContent"></A> <table width=100% border=0 class="ms-titleareaframe" cellpadding=0> <TR> <TD valign=top width="100%" style="padding-top: 10px" class="ms-descriptiontext"> <span id="ctl00_PlaceHolderMain_LabelMessage">Los administradores del servidor han bloqueado en este sitio Web el archivo que intenta guardar o recuperar.</span> <P><span class="ms-descriptiontext"> <span id="ctl00_PlaceHolderMain_helptopic_troubleshooting"><A Title="Troubleshoot issues with Windows SharePoint Services. - Opens in new window" HREF="javascript:HelpWindowKey('troubleshooting')">Troubleshoot issues with Windows SharePoint Services.</A></span> </span> </TD> </TR> </table> <script type="text/javascript" language="JavaScript"> var gearPage = document.getElementById('GearPage'); if(null != gearPage) { gearPage.parentNode.removeChild(gearPage); document.title = "Error"; } </script> </td> </tr> </table> </td> <td class="ms-rightareacell"> <div class='ms-areaseparatorright'><IMG SRC="/_layouts/images/blank.gif" width=8 height=100% alt=""></div> </td> </TR> <tr> <td class="ms-pagebottommarginleft"><IMG SRC="/_layouts/images/blank.gif" width=1 height=10 alt=""></td> <td class="ms-pagebottommargin"><IMG SRC="/_layouts/images/blank.gif" width=1 height=10 alt=""></td> <td class="ms-bodyareapagemargin"><IMG SRC="/_layouts/images/blank.gif" width=1 height=10 alt=""></td> <td class="ms-pagebottommarginright"><IMG SRC="/_layouts/images/blank.gif" width=1 height=10 alt=""></td> </tr> </TABLE></TD></TR> </TABLE> <input type="text" name="__spDummyText1" style="display:none;" size=1/> <input type="text" name="__spDummyText2" style="display:none;" size=1/> </form> </BODY> </HTML> --.
     
    LabelHyperLink 
    The attempt to connect to the report server failed.  Check your connection information and that the report server is a compatible version. Client found response content type of 'text/html; charset=utf-8', but expected 'text/xml'. The request failed with the error message: --< HTML dir="ltr">< HEAD><meta name="GENERATOR" content="Microsoft SharePoint" /><meta name="progid" content="SharePoint.WebPartPage.Document" /><meta HTTP-EQUIV="Content-Type" content="text/html; charset=utf-8" /><meta HTTP-EQUIV="Expires" content="0" /><meta name="ROBOTS" content="NOHTMLINDEX" /><title> Error< /title><link rel="stylesheet" type="text/css" href="/_layouts/3082/styles/core.css?rev=tLJBk8aGDXac%2BaUQ4b1cJA%3D%3D"/>< script type="text/javascript" language="javascript" src="/_layouts/3082/init.js?rev=qQqJ%2B4wiXhp%2Bsi8xwuuM1A%3D%3D"></script>< script type="text/javascript" language="javascript" src="/_layouts/3082/core.js?rev=yxewtlu23Cg4w2%2FBk9EQiQ%3D%3D"></script> <meta name="Robots" content="NOINDEX " /> <meta name="SharePointError" content=""/>< /HEAD>< BODY scroll="yes" onload="javascript:if (typeof(_spBodyOnLoadWrapper) != 'undefined') _spBodyOnLoadWrapper();">  <form name="aspnetForm" method="post" action="../../../_layouts/error.aspx" id="aspnetForm" onsubmit="return _spFormOnSubmitWrapper();">< div>< input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value="/wEPDwUKLTU2NjkxODU3M2Rkuv2zA5vnQinS+xCMRO9ktp5tGjk=" />< /div>  <TABLE class="ms-main" CELLPADDING=0 CELLSPACING=0 BORDER=0 WIDTH="100%" HEIGHT="100%"> <tr><td>    <table CELLPADDING=0 CELLSPACING=0 BORDER=0 WIDTH="100%"> <tr> <td colspan=4 class="ms-globalbreadcrumb" align="right">     <a href="javascript:TopHelpButtonClick('NavBarHelpHome')" id="ctl00_PlaceHolderGlobalNavigation_TopHelpLink" AccessKey="6" title="Help (new window)"><img src="/_layouts/images/helpicon.gif" align="absmiddle" border="0" alt="Help (new window)" /></a> </td> </tr>    </table>   </td></tr> <tr> <td class="ms-globalTitleArea">   <table width=100% cellpadding=0 cellspacing=0 border=0>    <tr> <td id="GlobalTitleAreaImage" class="ms-titleimagearea"><img id="onetidHeadbnnr0" src="/_layouts/images/titlegraphic.gif"  alt="" /></td> <td class="ms-sitetitle" width=100%>     </td> <td style="padding-" valign=top>     </td>    </tr>   </table> </td> </tr> <TR> <TD id="onetIdTopNavBarContainer" WIDTH=100% class="ms-bannerContainer"> </TD> </TR> <TR height="100%"><TD><TABLE width="100%" height="100%" cellspacing="0" cellpadding="0"> <tr> <td class="ms-titlearealeft" id="TitleAreaImageCell" valign="middle" nowrap><div style="height:100%" class="ms-titleareaframe"></div></td> <td class="ms-titleareaframe" id="TitleAreaFrameClass">   <table cellpadding=0 height=100% width=100% cellspacing=0>   <tr><td class="ms-areaseparatorleft"><IMG SRC="/_layouts/images/blank.gif" width=1 height=1 alt=""></td></tr> </table>   </td> <td valign=top  id="onetidPageTitleAreaFrame" class='ms-areaseparator' nowrap width="100%">   <table id="onetidPageTitleAreaTable" cellpadding=0 cellspacing=0 width=100% border="0">    <tr> <td valign="top" class="ms-titlearea">   <a href="http://portalcre" id="ctl00_PlaceHolderTitleBreadcrumb_idSimpleGoBackToHome">Go back to site</a> </td>    </tr>    <tr> <td height=100% valign=top ID=onetidPageTitle class="ms-pagetitle">   <h2 class="ms-pagetitle"> Error   </h2> </td>    </tr>   </table> </td> <td class="ms-titlearearight"> < div class='ms-areaseparatorright'><IMG SRC="/_layouts/images/blank.gif" width=8 height=100% alt=""></div>< /td> </tr> <TR>   <TD class="ms-leftareacell" valign=top height=100% id="LeftNavigationAreaCell">    <table class=ms-nav width=100% height=100% cellpadding=0 cellspacing=0> <tr> <td>   <TABLE height="100%" class=ms-navframe CELLPADDING=0 CELLSPACING=0 border="0">    <tr valign="top"> <td width="4px"><IMG SRC="/_layouts/images/blank.gif" width=4 height=1 alt=""></td> <td valign="top" width="100%">             </td>    </tr>    <tr><td colspan=2><IMG SRC="/_layouts/images/blank.gif" width=138 height=1 alt=""></td></tr>   </TABLE> </td> <td></td> </tr>    </table>   </TD>   <td>< div class='ms-areaseparatorleft'><IMG SRC="/_layouts/images/blank.gif" width=8 height=100% alt=""></div>< /td>   <td class='ms-formareaframe' valign="top"> <TABLE width="100%" border="0" cellspacing="0" cellpadding="0" class="ms-propertysheet"> <TR valign="top"  > <TD class="ms-descriptiontext" width="100%">   </TD>    <TD ID=onetidYPadding width="10px"><IMG SRC="/_layouts/images/blank.gif" width=10 height=1 alt=""></TD>   </TR>   <TR > <TD ID=onetidMainBodyPadding height="8px"><IMG SRC="/_layouts/images/blank.gif" width=1 height=8 alt=""></TD>   </TR>   <tr> <td valign="top" height="100%">    <A name="mainContent"></A> <table width=100% border=0 class="ms-titleareaframe" cellpadding=0> <TR> <TD valign=top width="100%" style="padding- class="ms-descriptiontext">    <span id="ctl00_PlaceHolderMain_LabelMessage">Los administradores del servidor han bloqueado en este sitio Web el archivo que intenta guardar o recuperar.</span>    <P><span class="ms-descriptiontext"> <span id="ctl00_PlaceHolderMain_helptopic_troubleshooting"><A Title="Troubleshoot issues with Windows SharePoint Services. - Opens in new window" HREF="javascript:HelpWindowKey('troubleshooting')">Troubleshoot issues with Windows SharePoint Services.</A></span> </span> </TD> </TR> </table>< script type="text/javascript" language="JavaScript"> var gearPage = document.getElementById('GearPage'); if(null != gearPage) { gearPage.parentNode.removeChild(gearPage); document.title = "Error"; }< /script> </td>   </tr> </table>   </td>   <td class="ms-rightareacell">< div class='ms-areaseparatorright'><IMG SRC="/_layouts/images/blank.gif" width=8 height=100% alt=""></div>< /td> </TR>< tr> <td class="ms-pagebottommarginleft"><IMG SRC="/_layouts/images/blank.gif" width=1 height=10 alt=""></td> <td class="ms-pagebottommargin"><IMG SRC="/_layouts/images/blank.gif" width=1 height=10 alt=""></td> <td class="ms-bodyareapagemargin"><IMG SRC="/_layouts/images/blank.gif" width=1 height=10 alt=""></td> <td class="ms-pagebottommarginright"><IMG SRC="/_layouts/images/blank.gif" width=1 height=10 alt=""></td>< /tr> </TABLE></TD></TR>  </TABLE>       <input type="text" name="__spDummyText1" style="display:none;" size=1/>   <input type="text" name="__spDummyText2" style="display:none;" size=1/>  </form>  < /BODY>< /HTML> --.
    
    


    thnks in advance


    Salu2 Sergio T

    viernes, 25 de mayo de 2012 12:30