none
No se muestran datos en Gridview al pasarlos desde un Datatable RRS feed

  • Pregunta

  • La situación es la siguiente:  Tengo unos datos en un Datatable que he tomado de un GV.  Esos datos necesito pasarlos a otro Gridview.  De acuerdo a lo que he probado, el Datatable tiene los datos que necesito, pero al pasarlos al Gridview, este se ve en blanco!!!

    Pensé que por tener columnas ocultas el Gridview original,  algo estaba fallando, pero las mostré todas y nada.

    El Datatable tiene los datos pues puse unos Textbox para comprobarlo:

    Además, las filas que se ven en el Gridview corresponde al contenido del Datatable.

    Debe ser una insignificancia, pero no la veo.  Si alguien me puede ayudar se lo agradezco.


    Carlos Mora, foro MSDN


    • Editado Liyos miércoles, 6 de julio de 2016 20:21 claridad
    miércoles, 6 de julio de 2016 20:20

Respuestas

  • hola

    defienes las columnas en tiempo de diseño?

    si es asi valida que valor pones en la propiedad DataField

    alli deberas definir el nombre de la columan del datatable que quieres visualizar

    podrias probarlo si defines la propiedad AutoGenerateColumns = true de esta forma ver con que nombre las visualizas

    saludos


    Leandro Tuttini

    Blog
    MVP Profile
    Buenos Aires
    Argentina

    • Marcado como respuesta Liyos miércoles, 6 de julio de 2016 21:00
    miércoles, 6 de julio de 2016 20:34

Todas las respuestas

  • hola

    defienes las columnas en tiempo de diseño?

    si es asi valida que valor pones en la propiedad DataField

    alli deberas definir el nombre de la columan del datatable que quieres visualizar

    podrias probarlo si defines la propiedad AutoGenerateColumns = true de esta forma ver con que nombre las visualizas

    saludos


    Leandro Tuttini

    Blog
    MVP Profile
    Buenos Aires
    Argentina

    • Marcado como respuesta Liyos miércoles, 6 de julio de 2016 21:00
    miércoles, 6 de julio de 2016 20:34
  • Pues era una insignificancia y lo encontré!!!

    Tenía desactivada la opción de "Generar campos automáticamente"

    Saludos


    Carlos Mora, foro MSDN

    miércoles, 6 de julio de 2016 20:49
  • Gracias Leandro, antes de ver tu respuesta vi que por ahi andaba la cosa.

    Saludos.


    Carlos Mora, foro MSDN

    miércoles, 6 de julio de 2016 21:00