none
error con NuGet.exe al hacer publish RRS feed

  • Pregunta

  • Que tal, al hacer un publish a mi proyecto, este lo hace exitosa mente, pero al momento de correr la aplicación desde mi localhost, me sale la pantalla de error de fondo amarillo con el siguiente error:

    Could not load file or assembly 'file:///C:\inetpub\wwwroot\Proyecto\NuGet.exe' or one of its dependencies. An attempt was made to load a program with an incorrect format.

    El proyecto cuando se corre desde el visual studio, corre perfectamente, pero no encuentro mucha ayuda por internet, alguien sabra por donde va el detalle ??

    Muchas gracias, saludos ¡¡

    jueves, 20 de noviembre de 2014 23:21

Todas las respuestas

  • hola

    a que llamas "correr la aplicación desde mi localhost" ? estas haciando el deploy del sitio en un sitio en el IIS local

    si es asi no veo que tiene que ver nuget, usas las opciones de "publish" del VS para llevar la publicacion al sitio web en el iis

    saludos


    Leandro Tuttini

    Blog
    MVP Profile
    Buenos Aires
    Argentina

    viernes, 21 de noviembre de 2014 4:09
  • Muchas gracias por tu respuesta,

    Si al decir localhost, me refiero a mi IIS.

    Ya encontre lo que esta ocasionando el problema cuando realizo el Publish desdee VS, en mi proyecto la segurida la esta controlando un tercero, se llama FluentSecurity esta DLL la instale por medio de nuget, y en el application_star se inicia liza toda la configuración. El error se provoca cuando se inicia liza la configuracion.

    Solo falla cuando se hace el publish desde VS, cuando lo corro desde VS funciona correctamente.

    Ahorita sigo revisando por que no quiere hacer el publish correctamente cuando se inicia liza la configuracion de seguridad.

    Muchas gracias, saludos ¡¡

    viernes, 21 de noviembre de 2014 17:41