none
The request failed with HTTP status 401: Unauthorized RRS feed

  • Pregunta

  • Buenos días

    Tengo un website que le estoy haciendo debug para revisar el error, cuando me logueo por autenticación integrada pasa ok, pero cuando entra al método que hace una consulta a la base de datos se cae y en el exception dice "The request failed with HTTP status 401: Unauthorized"

    A qué se puede deber?

    Gracias

    martes, 16 de enero de 2018 13:23

Respuestas

  • hola

    >>Tengo un website que le estoy haciendo debug para revisar el error

    que es este website? es un desarrollo en asp.net

    >>pero cuando entra al método que hace una consulta a la base de datos

    que metodo? te refieres a un evento que realiza algun boton de la pagina aspx

    >>se cae y en el exception dice

    puede que el usuario de autenticacion integrada no tenga acceso a la base de datos

    define en el connction string la autenticaicon por sql, que no sea de seguridad integrada

    saludos


    Leandro Tuttini

    Blog
    MVP Profile
    Buenos Aires
    Argentina

    martes, 16 de enero de 2018 14:02

Todas las respuestas

  • hola

    >>Tengo un website que le estoy haciendo debug para revisar el error

    que es este website? es un desarrollo en asp.net

    >>pero cuando entra al método que hace una consulta a la base de datos

    que metodo? te refieres a un evento que realiza algun boton de la pagina aspx

    >>se cae y en el exception dice

    puede que el usuario de autenticacion integrada no tenga acceso a la base de datos

    define en el connction string la autenticaicon por sql, que no sea de seguridad integrada

    saludos


    Leandro Tuttini

    Blog
    MVP Profile
    Buenos Aires
    Argentina

    martes, 16 de enero de 2018 14:02
  • que usuario estas utilizando para la conexion a la DB y que configuracion tienes en la DB.
    martes, 16 de enero de 2018 14:50
  • Sí es un desarrollo en .net

    Mi web utiliza webreferences, mediante asmx, hago una consulta a la base de datos.

    jperez ingresa con su usuario del active directory ok, ese usuario jperez están dentro de una cuenta grupal que tiene acceso de la base de datos.

    Cuando ejecuto solo mi webservice me ejecuta correctamente y me trae resultados.

    El problema es cuando corro mi web, allí se cae en el método, al acceder a la base de datos. 

    La conexión en mi webservice está como

       sCon = "Data Source=" + sServidor + ";Persist Security Info=False;Initial Catalog=" + sBD + ";Integrated Security=SSPI" + ";"; 

    martes, 16 de enero de 2018 15:11
  • sCon = "Data Source=" + sServidor + ";Persist Security Info=False;Initial Catalog=" + sBD + ";Integrated Security=SSPI" + ";";
    martes, 16 de enero de 2018 15:11