none
Problema al agregar un formulario

    Pregunta

  • Hola, cuando agrego un nuevo formulario a mi proyecto me ocurre que en la ventana del explorador de soluciones me muestra dos ficheros, uno el form.vb con el icono de formulario y otro el form.Designer.vb con el icono VB en azul como llevan los modulos. A partir de aqui nada es igual, cuando abro el formulario para codificar me muestra el  Private Sub InitializeComponent() y cuando quiero ejecutar la aplicacion me lanza este error "Error 1 'Private Sub InitializeComponent()' tiene varias definiciones con firmas idénticas." he pensado que se haya desconfigurado el  IDE y que tengo que volver a instalar el visual estudio 2012, agradeceria cualquier aporte

    miércoles, 5 de abril de 2017 20:27

Respuestas

  • Hola Brayan, no hubo maneras, al final he desinstalado. Lo que se me desconfiguró fue el IDE, he vuelto a instalar y el proyecto en sí funciono a la primera, ahora puedo añadir formularios sin tener el designer donde no debiera.

    Muchas gracias Brayan desde Sevilla (España).

    • Marcado como respuesta Joyce_ACModerator jueves, 6 de abril de 2017 17:50
    • Desmarcado como respuesta RDJA jueves, 6 de abril de 2017 18:11
    • Marcado como respuesta RDJA jueves, 6 de abril de 2017 18:11
    jueves, 6 de abril de 2017 15:30

Todas las respuestas

  • Hola RDJA,

    Revisa que solo en tu designer tengas la InitializeComponent, probablemente en tu Form.vb también tengas una o viceversa, revisa. El único lugar donde debe de estar es en el designer.

    Saludos.


    Si ayudé a resolver tu consulta, no olvides marcar como respuesta y/o votar como útil.


    miércoles, 5 de abril de 2017 20:45
  • Muchas gracias, lo he mirado y lo he quitado del form.vb pero se vuelve a crear de forma automatica, solo hay salir y volver a entrar en el codigo y vuelve a mostrar lo que quite, pero lo extraño es que al agregar el formulario, me agregue también el diseñador en la ventana del explorador de soluciones soluciones, es decir dos en vez de uno, el diseñador y el .rexs se crean en el momento que creas el form pero se quedan en el directorio del proyecto y no salen en el explorador.
    miércoles, 5 de abril de 2017 21:10
  • Hola RDJA,

    No desinstales por un caso así. Entra a la carpeta del proyecto y elimina los formularios, luego recompila y vuelve agregar formularios.

    Por otro lado, creaste otra solución y te ocurre lo mismo? 

    Saludos.


    Si ayudé a resolver tu consulta, no olvides marcar como respuesta y/o votar como útil.

    miércoles, 5 de abril de 2017 21:52
  • Hola Brayan, no hubo maneras, al final he desinstalado. Lo que se me desconfiguró fue el IDE, he vuelto a instalar y el proyecto en sí funciono a la primera, ahora puedo añadir formularios sin tener el designer donde no debiera.

    Muchas gracias Brayan desde Sevilla (España).

    • Marcado como respuesta Joyce_ACModerator jueves, 6 de abril de 2017 17:50
    • Desmarcado como respuesta RDJA jueves, 6 de abril de 2017 18:11
    • Marcado como respuesta RDJA jueves, 6 de abril de 2017 18:11
    jueves, 6 de abril de 2017 15:30
  • Era lo mas logico ya que has solucionado tu dudapor favor marca tu respuesta asi no quedan temas pendientes y a la ves ayudaras a otras personas que hayan tenido un problema similar a saber que opciones tomar de las mostradas aqui.
    jueves, 6 de abril de 2017 15:35