none
Error Crystal: No se puede enviar la solicitud para procesamiento de fondo RRS feed

  • Pregunta


  • Buenas a todos!

    tengo un problema con un informe de Crystal Reports, y es que cuando lo quiero enviar a la impresora directamente (sin verlo antes por pantalla) me da el error del título. He estado mirando por internet pero no encontré la solución... Ya probé a instalar el SP1 del Crystal (uso el Crystal Reports del Visual Studio 2008), quité las imágenes que tenía, etc... Incluso dicen que es un bug

    Lo raro es que no me pasa en todos los informes, el mismo código con algunos informes va y otros no. Esto es lo que tengo:

            Dim Informe As New CrystalDecisions.CrystalReports.Engine.ReportDocument()
            Informe.FileName = "F:\ProformaVenta.rpt"
            Informe.SetDatabaseLogon("SA", "1111")


            Dim SQL As String = ""
            SQL = "SELECT * FROM Clientes"
            DS.Reset()
            DA = New SqlDataAdapter(SQL, Conexion)
            DA.Fill(DS, "Cab")
            Informe.SetDataSource(DS.Tables("Cab"))


            Dim pd As New Printing.PrintDocument     
            Dim impresora As String = pd.PrinterSettings.PrinterName
            Informe.PrintOptions.PrinterName = impresora    'AQUI DA EL ERROR***********
            Informe.PrintToPrinter(1, False, 0, 0)


    Saludos y gracias de antemano!
    lunes, 20 de diciembre de 2010 15:38

Todas las respuestas

  • hola

    si este mismo reporte que ahora falla, lo visualizas en el Crystal Report Viewer funciona sin errores ?

    o en el viewer en pantalla tambien falla?

     

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    lunes, 20 de diciembre de 2010 15:46
  • Hola Leandro, gracias por la rápida respuesta

    Si lo mando a pantalla si que me funciona (cambiando el código que envía a la impresora por este otro):

            CrystalReportViewer1.ReportSource = Informe
            CrystalReportViewer1.Zoom(2)

     

    A priori las diferencias que veo entre uno y otro son dos, aunque entiendo en que no son el problema:

    -uno tiene un grupo y el otro no

    -la consulta que alimenta a uno es de una tabla y la del otro tiene tablas anidadas

     

    Saludos!


    lunes, 20 de diciembre de 2010 16:04
  • Buenos días sr. Leandro, en relación a la problemática que se le presento al caballero, a mi me pasa lo mismo, inclusive a nivel del Viewer, pero revisando y probando encontré una solución para salir del problema, solo bajando el peso de las imágenes. En realidad me gustaría saber si hay otra solución, en versiones anteriores de cristal report, inclusive las mas viejitas, no tenia este problema de tener que bajar el peso de la imagen, a partir de la vesion 11, es que tengo esta dificultar.

    Saludos, y le agradezco cualquier comentario al respecto.

    domingo, 22 de julio de 2018 12:27