none
Error al compilar projecto android xamarin forms PCL RRS feed

  • Pregunta

  • ERROR
    C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1397,2): error : Exception while loading assemblies: System.IO.FileNotFoundException: Could not load assembly 'Xamarin.Android.Support.Core.Utils, Version=1.0.0.0, Culture=neutral, PublicKeyToken='. Perhaps it doesn't exist in the Mono for Android profile?
    C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1397,2): error : File name: 'Xamarin.Android.Support.Core.Utils.dll'
    C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1397,2): error : at Java.Interop.Tools.Cecil.DirectoryAssemblyResolver.Resolve(AssemblyNameReference reference, ReaderParameters parameters)
    C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1397,2): error : at Xamarin.Android.Tasks.ResolveAssemblies.AddAssemblyReferences(DirectoryAssemblyResolver resolver, ICollection`1 assemblies, AssemblyDefinition assembly, Boolean topLevel)
    C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1397,2): error : at Xamarin.Android.Tasks.ResolveAssemblies.Execute(DirectoryAssemblyResolver resolver)

    <packages>
      <package id="ExifLib.PCL" version="1.0.1" targetFramework="monoandroid60" />
      <package id="Plugin.CurrentActivity" version="1.0.1" targetFramework="monoandroid60" />
      <package id="Plugin.Permissions" version="2.1.0" targetFramework="monoandroid60" />
      <package id="Plugins.Forms.ButtonCircle" version="1.0.78" targetFramework="monoandroid60" />
      <package id="SQLite.Net.Core-PCL" version="3.1.1" targetFramework="monoandroid60" />
      <package id="SQLite.Net-PCL" version="3.1.1" targetFramework="monoandroid60" />
      <package id="Xam.Plugin.Media" version="3.0.1" targetFramework="monoandroid60" />
      <package id="Xamarin.Android.Support.Animated.Vector.Drawable" version="23.3.0" targetFramework="monoandroid60" />
      <package id="Xamarin.Android.Support.Design" version="23.3.0" targetFramework="monoandroid60" />
      <package id="Xamarin.Android.Support.v4" version="23.3.0" targetFramework="monoandroid60" />
      <package id="Xamarin.Android.Support.v7.AppCompat" version="23.3.0" targetFramework="monoandroid60" />
      <package id="Xamarin.Android.Support.v7.CardView" version="23.3.0" targetFramework="monoandroid60" />
      <package id="Xamarin.Android.Support.v7.MediaRouter" version="23.3.0" targetFramework="monoandroid60" />
      <package id="Xamarin.Android.Support.v7.RecyclerView" version="23.3.0" targetFramework="monoandroid60" />
      <package id="Xamarin.Android.Support.Vector.Drawable" version="23.3.0" targetFramework="monoandroid60" />
      <package id="Xamarin.Forms" version="2.4.0.282" targetFramework="monoandroid60" />
    </packages>

    Ayuda para resolver esto


    Juan A. Reyes

    domingo, 15 de octubre de 2017 14:32

Todas las respuestas

  • Hola,

    actualiza el paquete nuget de xamarin forms, tanto como de tu pcl y tu proyecto android. Asimismo, encárgate de tener actualizados tus apis en el administrador de sdk, así utilices la api 19,20; es recomendable que tengas actualizada hasta la última vesrión. Por último, y no menos importante, en las propiedades de tu proyecto android indica la mínima versión que soportará.

    Saludos


    Brayan De la Cruz
    Lima - Perú

    martes, 17 de octubre de 2017 18:09