none
Problemas con Paquete de instalacion RRS feed

  • Pregunta

  • Hola a todos,

    antes de todo, agradecer la labor que realizáis que es una ayuda realmente práctica.

    Mi problema es el siguiente, he desarrollado una aplicación con VisualStudio2008 y estoy creando un proyecto de instalación para poder utilizarla. La aplicación utiliza .NET Framework 3.5 por lo que lo he incluido en requisitos. También he incluído el Windows Installer 3.1. . Asimismo, al utilizar una librería .dll creada por mi en el programa Matlab es necesario instalar también el Matlab Compiler Runtime del programa (MCR_Installer), correcto.

    Hasta ahi todo bien. La aplicación la estoy compilando para "Any CPU". He incluyendo en el proyecto de instalación los resultados (Debug x86) para preparar la instalación en un PC con x86. En concreto, en el origen utilizo Windows XP x86, y deseo instalarlo en un entorno similar para empezar. Una vez creada la instalación, la he probado en una máquina virtual (Windows XP) en el mismo ordenador y la instala correctamente y ejecuta sin problema. Sin embargo, al instalarla en una máquina virtual identica en un portatil que tiene Windows 7, la aplicación no ejecuta correctamente. 

    En la ejecución del programa realizo el acceso y escritura en una base de datos de access con funciones OleDB utilizando una conexion de "...JET 4.0..". Tal vez el problema vaya por ahi..pero no tengo ni idea.

    Espero la ayuda porque debo preparar el instalador y no contaba con este contratiempo.. Muchas gracias.

    Un cordial saludo,

    Miguel Alonso


    Miguel Alonso - Desarrollador

    jueves, 7 de febrero de 2013 11:43

Respuestas