none
no me carga el servidor local sql. RRS feed

  • Pregunta

  • Hola.

    Acabo de instalar una instacia SQL y management studio pero no me carga el servidor SQL local, he revisado el servicio de SQL y está corriendo, lo he reiniciado por si acaso pero sigue sin cargar el servidor. He probado a conectar desde una aplicacion realizada en Visual Studio y también me da el mismo error, que es este. 

    "Error relacionado con la red o específico de la instancia mientras se establecía una conexión con el servidor SQL Server. No se encontró el servidor o éste no estaba accesible. Compruebe que el nombre de la instancia es correcto y que SQL Server está configurado para admitir conexiones remotas. (provider: SQL Network Interfaces, error: 26 - Error al buscar el servidor o instancia especificado)"

    He reinstalado la instancia y nada, he creado una nueva y tampoco ha funcionado. Alguna idea?

    Muchas gracias

    jueves, 31 de mayo de 2018 19:30

Respuestas

  • Con el mensaje de error que te sale, seguro que hay algo en la cadena de conexión que no se está resolviendo correctamente.

    Prueba a conectar a "(local)\nombreDeInstancia" (sin las comillas). Lo de "(local)" con los paréntesis incluidos hace que se use el proveedor de memoria compartida, saltándose el stack TCP/IP. Cerciórate de que usas la contrabarra y de que el nombre de la instancia está bien (ojo si contiene caracteres especiales).

    viernes, 1 de junio de 2018 17:32

Todas las respuestas

  • Para intentar dar un comentario

    - ¿Version / Edicion de SQL Server?

    Con el CONFIGURATION MANAGER, revise que los protocolos TCP/IP estan activos

    jueves, 31 de mayo de 2018 19:33
  • ¿Estás conectando localmente a la instancia desde la misma máquina? En ese caso, debería funcionar sin ningún requisito adicional. El problema más típico en estos casos es que al conectar esté mal escrito el nombre de la instancia. Por ejemplo, en un caso que he visto en alguna ocasión, el problema era que estaban separando el nombre de instancia con una barra hacia la derecha en lugar de la contrabarra.
    jueves, 31 de mayo de 2018 19:34
  • He revisado las conexiones TCP/IP y esran habilitadas, la version es La 2008 Express 2008 con el SP 4
    jueves, 31 de mayo de 2018 20:29
  • He revisado y el nombre del host es correcto .
    jueves, 31 de mayo de 2018 20:29
  • He revisado y el nombre del host es correcto .

    OJO, no basta con el nombre del host. También es necesario que sea correcto el nombre de la instancia que se pone detrás del nombre del host.
    viernes, 1 de junio de 2018 5:46
  • He revisado las conexiones TCP/IP y esran habilitadas
    Pero, ¿no era una conexión local dentro de la misma máquina? Si es así, no se necesita que estén habilitadas las conexiones TCP/IP. En cambio, si es una conexión remota se necesitan más cosas (firewall, SQLBrowser, resolución de nombres...). Convendría que clarifiques si es local o remota.
    viernes, 1 de junio de 2018 5:48
  • Si, es una conexción dentro de la misma máquina, había probado en las TCP/IP habilitadas y deshabilitadas, el resultado es el mismo
    viernes, 1 de junio de 2018 8:25
  • El nombre de la instancia también es el correcto.

    Gracias.

    viernes, 1 de junio de 2018 8:28
  • Hola.

    Si es SQL Server Express, revisa este post en mi blog: SQL Server 2012 edición Express y su puerto TCP/IP, que de pronto te puede dar alguna ayuda para resolver el problema que tienes.

    Se que no es la versión, pero es probable que te apoye para lo que necesites...

    Saludos,


    Guillermo Taylor F.
    MVP Data Platform & IT Pro
    Mi Blog

    viernes, 1 de junio de 2018 12:56
  • Con el mensaje de error que te sale, seguro que hay algo en la cadena de conexión que no se está resolviendo correctamente.

    Prueba a conectar a "(local)\nombreDeInstancia" (sin las comillas). Lo de "(local)" con los paréntesis incluidos hace que se use el proveedor de memoria compartida, saltándose el stack TCP/IP. Cerciórate de que usas la contrabarra y de que el nombre de la instancia está bien (ojo si contiene caracteres especiales).

    viernes, 1 de junio de 2018 17:32
  • Hola que tal deberías revisar el nombre de la instancia si esta bien colocado y los protocolos TCP/IP, por lo general para conectarse a una Instancia en express es así NOMBREMAQUINA\MSSQLEXPRESS, cualquier cosa nos comentas.

    Saludos,

    Jorge Muchaypiña G.


    Business Intelligence Analyst

    viernes, 1 de junio de 2018 18:08
  • Con el mensaje de error que te sale, seguro que hay algo en la cadena de conexión que no se está resolviendo correctamente.

    Prueba a conectar a "(local)\nombreDeInstancia" (sin las comillas). Lo de "(local)" con los paréntesis incluidos hace que se use el proveedor de memoria compartida, saltándose el stack TCP/IP. Cerciórate de que usas la contrabarra y de que el nombre de la instancia está bien (ojo si contiene caracteres especiales).

    Muchas gracias !! Poniendo (local) el problema se ha resuelto. Todo un acierto.

    Saludos.

    viernes, 1 de junio de 2018 19:35