none
No Me Permite Realizar la Depuración RRS feed

  • Pregunta

  • Actualmente empece a trabajar Visual Studio 2013, en las horas de la mañana todo iba muy bien sin embargo realice la actualización 4 de Visual Studio 2013 y a partir de ahí no me deja depurar el proyecto que estoy desarrollando.

    Pongo un punto de interrupción y cuando quiero evaluar determinada variable me muestra un mensaje que dice "Codigo que no se ejecuta - El subproceso actual no está ejecutando código en este momento o no se pudo obtener la pila de llamadas"

    Muchas gracias por la colaboración que me puedas brindar con el fin de solucionar este aspecto.

    

    • Cambiado Karen Malagón jueves, 12 de febrero de 2015 17:26 Windows Forms issue
    miércoles, 11 de febrero de 2015 5:41

Respuestas

Todas las respuestas

  • lo primero que haría seria borrar las carpetas bin yb obj de tu proyecto. Lo siguiente realizar un Rebuild(volver a generar). Y por ultimo y antes de depurar, verificar que estas compilando en modo Debug.

    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó vótala como útil. Saludos

    miércoles, 11 de febrero de 2015 6:45
  • Sergio buenos días, seguí tus instrucciones y no funcionó. Ayer probé creando un proyecto nuevo desde cero y tampoco me dejó depurarlo. Espero me pueda seguir colaborando con este tema. Muchas gracias
    miércoles, 11 de febrero de 2015 11:52
  • ¿Qué tipo de proyecto es? Windows Form, ASP.NET, Consola...
    miércoles, 11 de febrero de 2015 13:00
  • El tipo de proyecto es Windows Form

    miércoles, 11 de febrero de 2015 16:10
  • Yo también tengo este problema con el Visual Studio 2013.

    Si la contestación te ha servido de ayuda márcala como respuesta. Si lo que publico no funciona, no tengo la culpa, SOY HUMANO, no una máquina.

    miércoles, 11 de febrero de 2015 17:35
  • Con el fin de solucionar este inconveniente reparé la instalación del Visual Studio 2013; inicialmente realizada la reparación permitió abrir el Visual Studio, sin embargo antes de abrir el proyecto Windows Form con el que tengo el problema abrí las notificaciones y aplique la actualización relacionada con Office.  Una vez realiza esta actualización no me pertmitió volver a abrir el Visual Studio, cada vez que intento el proceso me dice que "El paquete 'Microsoft.VisualStudio.Services.UserNotification.UserNotificationsPackage' no se cargó correctamente ó 'Microsoft.VisualStudio.Shell.Connected.Packages.OnlineLicensing.OnlineLicensingManagerPackage' no se cargó correctamente".  Me pide revisar un archivo ActivityLog.xml (el cual abrí pero no lo entiendí).

    Tengo imágenes de los errores arrojados y el archivo por si alguien lo desea verificar, los puedo enviar a algún correo electrónico.  

    Finalmente lo que estoy haciendo es eliminando la instalación y volviendo a instalar para ver que pasa, cuando termine les contaré; sinceramente este tema es frustrante. 


    miércoles, 11 de febrero de 2015 17:53
  • Desinstalé el Visual Studio y lo volví a instalar y siguen los problemas; necesito saber como  se quita absolutamente todo lo relacionado con el Visual Studio (información del registro, proyectos recientes) y tratar de hacer una instalación limpia para no tener que formatear mi computador.

    Gracias

    jueves, 12 de febrero de 2015 15:24
  • En  tu proyecto empleas algún componente de terceros? como Telerik o DevExpress. Probaste en hacer una aplicación de consola sencilla y realizar la depuración?


    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó vótala como útil. Saludos

    jueves, 12 de febrero de 2015 15:49
  • O tambien si usas algún addin de VS. Trata de deshabilitarlos o incluso desinstalarlos 

    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó vótala como útil. Saludos

    jueves, 12 de febrero de 2015 15:53
  • Sergio no uso componentes de terceros, ni addin y si realice una prueba con una aplicación sencilla de consola y con una aplicación Windows Form completamente nueva y en ningún caso permite realizar la depuración.

    Gracias por tu colaboración

    jueves, 12 de febrero de 2015 16:09
  • Finalmente me toco formatear, no se pudo reparar y al reinstalar no funciona.
    viernes, 13 de febrero de 2015 3:38