none
Asignar permisos para mover reportes RRS feed

  • Pregunta

  • Buenas tardes foro, tengo un usuario de windows que es miembro del grupo "usuarios" de windows y tiene todos los permisos asignados en una carpeta de reporting services donde accede para ver sus reportes, pero cuando quiero usar la opción para mover un reporte con este usuario recibo el mensaje:

    Los permisos otorgados al usuario 'nombreServidor\nombreUsuario' son insuficientes para realizar esta operación. (rsAccessDenied)

    Estoy usando windows server 2003 r2 con sql server 2008 r2.

    Debo asignarlo a algún grupo en particular de windows para poder darle permisos? Sucede porque no tiene permisos para ver la carpeta de inicio de reporting services? Como podría resolverlo (no quiero que vea la carpeta de inicio)?

    Desde ya gracias por la ayuda, saludos.

    lunes, 3 de noviembre de 2014 19:26

Respuestas

  • Buenas DaviT,

    Tienes roles en RS, si tu usuario solo debe ver y mover dentro de una carpeta, puedes darle permisos del rol Report Builder a una carpeta y todo lo que haga dentro podrá gestionarlo.

    Otro Rol es Content Manager, si este usuario debe administrar todas las carpetas del servidor.

    Estos permisos son a nivel de objeto y va en jerarquía por lo que a menos que lo especifiques de otra forma, lo que des a un nivel lo heredará el resto.

    Espero que esto te aclare un poco más.

    Un Saludo


    Fran Diaz | twitter: @frandiaz_ | Blog: {geeks.ms/blogs/fdiaz/}

    martes, 4 de noviembre de 2014 11:26
    Moderador
  • Hola,

    La respuesta sigue siendo muy corta. Si agregas a una carpeta y luego un grupo de usuarios al que le das permisos de Content Manager (esto en reporting Services) debe dejarte funcionar. Este grupo también tiene que estar a nivel de raíz del sitio (nada más entrar en RS en configuración de carpetas en seguridad) para que pueda ver el sitio.

    Por lo demás, si sigue sin funcionar, dinos que permisos tienes puesto en RS (que es donde tienes el problema) para ver si te falta algo más.

    Un Saludo


    Fran Diaz | twitter: @frandiaz_ | Blog: {geeks.ms/blogs/fdiaz/}

    martes, 4 de noviembre de 2014 15:27
    Moderador

Todas las respuestas

  • Buenas DaviT,

    Tienes roles en RS, si tu usuario solo debe ver y mover dentro de una carpeta, puedes darle permisos del rol Report Builder a una carpeta y todo lo que haga dentro podrá gestionarlo.

    Otro Rol es Content Manager, si este usuario debe administrar todas las carpetas del servidor.

    Estos permisos son a nivel de objeto y va en jerarquía por lo que a menos que lo especifiques de otra forma, lo que des a un nivel lo heredará el resto.

    Espero que esto te aclare un poco más.

    Un Saludo


    Fran Diaz | twitter: @frandiaz_ | Blog: {geeks.ms/blogs/fdiaz/}

    martes, 4 de noviembre de 2014 11:26
    Moderador
  • Hola Fran, como comentaba, le asigné todos los permisos que tiene reporting services y sigue dando error. Saludos.
    martes, 4 de noviembre de 2014 12:41
  • Hola,

    Prueba dos cosas:

    1. Prueba a entrar en el IE como administrador y luego entra las credenciales.

    2. Si no puedes con el paso 1, especifica un poco más que permisos le has otorgado dentro del servidor de reports a este usuario o manda un pantallazo.

    Un Saludo


    Fran Diaz | twitter: @frandiaz_ | Blog: {geeks.ms/blogs/fdiaz/}

    martes, 4 de noviembre de 2014 14:30
    Moderador
  • A IE estoy entrando como administrador. En el server donde esta el reporting services el usuario está solamente en el grupo usuarios, también había probado agregarlo al grupo de reporting services, pero no se resolvió.
    martes, 4 de noviembre de 2014 15:09
  • Hola,

    La respuesta sigue siendo muy corta. Si agregas a una carpeta y luego un grupo de usuarios al que le das permisos de Content Manager (esto en reporting Services) debe dejarte funcionar. Este grupo también tiene que estar a nivel de raíz del sitio (nada más entrar en RS en configuración de carpetas en seguridad) para que pueda ver el sitio.

    Por lo demás, si sigue sin funcionar, dinos que permisos tienes puesto en RS (que es donde tienes el problema) para ver si te falta algo más.

    Un Saludo


    Fran Diaz | twitter: @frandiaz_ | Blog: {geeks.ms/blogs/fdiaz/}

    martes, 4 de noviembre de 2014 15:27
    Moderador