none
No carga el reporte RRS feed

  • Pregunta

  • Tengo un problema con un reporte, ya que el formulario ni siquiera se abre y por lo tanto no se muestran los datos. Ya logre hacer mi reporte de otra manera y si me salio, pero no me quiero quedar con la duda de cual es la razón por la que usando el siguiente método no funciona.

    Imports System.Data
    Imports System.Data.SqlClient
    Imports System.Configuration
    Imports CrystalDecisions.CrystalReports.Engine

    Private Function GetData() As datasetPersonal Using con As New SqlConnection(ConfigurationManager.ConnectionStrings("Conexion").ToString()) Using cmd As New SqlCommand("SELECT IDEmpleado, Estatus, Nombre, APaterno, AMaterno, Departamento, Categoria, Tipo, FechaAlta, FechaBaja From Personal Where Tipo='Administrativo' And Estado=0") Using sda As New SqlDataAdapter() cmd.Connection = con sda.SelectCommand = cmd Using dsPersonal As New datasetPersonal() sda.Fill(dsPersonal, "Personal") Return dsPersonal End Using End Using End Using End Using End Function Private Sub FrmReporteAdmon_Load(sender As Object, e As EventArgs) Handles MyBase.Load Dim crystalReport As New PersonalAdmon Dim dsPersonal As datasetPersonal = GetData() crystalReport.SetDataSource(dsPersonal) Me.CrystalReportViewer1.ReportSource = crystalReport Me.CrystalReportViewer1.RefreshReport() End Sub

    El problema aquí es que no me marca algún error que me de indicio de cual sea el problema, el ejemplo lo saque de esta pagina:

    Basic Crystal Report Tutorial

    De antemano muchas gracias


    • Editado FranNovato domingo, 9 de agosto de 2015 10:18
    domingo, 9 de agosto de 2015 10:17

Respuestas

  • Saludos:

    Pudiera ser una o las dos de las siguientes:

    1) El SELECT no retorna datos.

    2) Las columnas del reporte NO se llaman igual que los campos del SELECT.

    Espero ayude.

    JOSE LUIS


    Dios NO los llamo LAS DIEZ RECOMENDACIONES

    • Marcado como respuesta FranNovato jueves, 10 de diciembre de 2015 6:23
    lunes, 10 de agosto de 2015 17:47