none
Problema DataGridView RRS feed

  • Pregunta

  • Muy buenas esta es mi primera vez por aqui tengo un problema con mi datagridview hace unas semanas me mostraba bien los datos ahora cuando hago una consulta a mi BD (que esta en access) me da problema al desplegar los datos al grid he consultado los datos en la BD y estan correctos.

    Quisiera que alguien me ayude con este problema 

    Como se puede apreciar en la siguiente imagen los datos que muestra el formulario con el DataGridView y los datos correctos que estan en la BD de Access

    domingo, 21 de julio de 2013 4:28

Todas las respuestas

  • Puedes mostrarnos como cargas el datagridview?

    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó vótala como útil. Saludos

    domingo, 21 de julio de 2013 13:15
  • con este codigo cargo el datagridview

    sql es mi string de la consulta a access

    orden = New OleDbDataAdapter(sql, myConnection)
            
            tabla = New DataSet()

            orden.Fill(tabla, "part1")

            FlujoData.DataSource = tabla.Tables("part1").DefaultView

            FlujoData.AutoSizeColumnsMode = DataGridViewAutoSizeColumnsMode.Fill

            FlujoData.AutoSizeColumnsMode = DataGridViewAutoSizeColumnsMode.AllCells
            FlujoData.ScrollBars = ScrollBars.Both
            FlujoData.ForeColor = Color.Black
            FlujoData.AlternatingRowsDefaultCellStyle.BackColor = Color.LightCyan

    domingo, 4 de agosto de 2013 2:12
  • Hola:

     El las columnas del DataGridView tienen los formatos correctos? por ejemplo la columna que mostrara las cantidades permite es numerico,  permite decimales? ya validaste la configuracion regional de tu pc? porque si dices que antes todo cargaba normal y despues dejo de hacerlo probablemente sea por algun cambio en la configuracion regional de la pc.


    Saludos desde Monterrey, Nuevo León, México!!!

    martes, 6 de agosto de 2013 14:45
  • Puede ser que el problema venga dado por aqui

    FlujoData.DataSource = tabla.Tables("part1").DefaultView

    Puedes validar que el contenido de tu datatable sea el correcto? La consulta SQL es la misma con la que accedes desde Access?


    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó vótala como útil. Saludos

    martes, 6 de agosto de 2013 14:51
  • ya cambie el codigo para llenar el grid y mi configuracion regional esta bien al compilar a x86 es cuando todo se muestra mal mientras si compilo a x64 se muestran bien los datos este es el codigo que estoy utilizando ahora

    Dim dt As New DataTable
            Dim ds As New DataSet
            ds.Tables.Add(dt)

            orden = New OleDbDataAdapter(sql, myConnection)

            orden.Fill(dt)

            FlujoData.DataSource = dt

            FlujoData.AutoSizeColumnsMode = DataGridViewAutoSizeColumnsMode.Fill

            FlujoData.AutoSizeColumnsMode = DataGridViewAutoSizeColumnsMode.AllCells
            FlujoData.ScrollBars = ScrollBars.Both
            FlujoData.ForeColor = Color.Black
            FlujoData.AlternatingRowsDefaultCellStyle.BackColor = Color.LightCyan

    jueves, 15 de agosto de 2013 17:24