none
No puedo hacer un deploy de mi app silverlight/WCF RRS feed

  • Pregunta

  • Estoy pasando a producción un sistema silverlight/Entity framework. Con el depurador funciona perfecto, pero al publicar no funciona.(Incluso debugueo en el servidor y funciona)

    Tengo en el web.config dentro de connectionStrings tres conexiones, de las cuales una es para el login y las otras para el modelo de EF.

    en el debug uso seguridad integrada, pero ahora necesito acceder a una base de datos con usuario y contraseña de sql.
    Por lo tanto setié seguridad integrada= false y le agregué user id y password. La conexión del logueo funciona, pero la conexión con las entidades no (Cuyas tablas mapeadas se encuentran en la misma base de datos donde esta el login).

    Me da el error: System.ServiceModel.DomainServices.Client.DomainOperationException: Load operation failed for query 'GetEquipo'. La conexión con nombre especificada no se cuencuentra en la configuracion, no es apropiada para ser utilizada con el proveedor de EntityClient, o no es válida.

    este es mi web.config

    <?xml version="1.0" encoding="utf-8"?>
    <configuration>
     <configSections>
      <sectionGroup name="system.serviceModel">
       <section name="domainServices" type="System.ServiceModel.DomainServices.Hosting.DomainServicesSection, System.ServiceModel.DomainServices.Hosting, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" allowDefinition="MachineToApplication" requirePermission="false" />
      </sectionGroup>
     </configSections>
     <system.web>
      <httpModules>
       <add name="DomainServiceModule" type="System.ServiceModel.DomainServices.Hosting.DomainServiceHttpModule, System.ServiceModel.DomainServices.Hosting, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
      </httpModules>
      <compilation debug="true" targetFramework="4.0">
       <assemblies>
        <add assembly="System.Data.Entity, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
       </assemblies>
      </compilation>
      <roleManager enabled="true" />
      <authentication mode="Forms">
       <forms name=".LabSVLRC_ASPXAUTH" />
      </authentication>
      <profile>
       <properties>
        <add name="FriendlyName" />
       </properties>
      </profile>
     </system.web>
     <system.webServer>
      <validation validateIntegratedModeConfiguration="false" />
      <modules runAllManagedModulesForAllRequests="true">
       <add name="DomainServiceModule" preCondition="managedHandler" type="System.ServiceModel.DomainServices.Hosting.DomainServiceHttpModule, System.ServiceModel.DomainServices.Hosting, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
      </modules>
     </system.webServer>
     <system.serviceModel>
      <serviceHostingEnvironment aspNetCompatibilityEnabled="true" multipleSiteBindingsEnabled="true" />
     </system.serviceModel>
     <connectionStrings>
      <clear />
      <add name="localSqlServer" connectionString="Data Source=jp;Initial Catalog=Lab;Integrated Security=False; User id= xxx; password=xxxx" />
      <add name="LabEntities" connectionString="metadata=res://*/Models.ModelLab.csdl|res://*/Models.ModelLab.ssdl|res://*/Models.ModelLab.msl;provider=System.Data.SqlClient;provider connection string=&quot;Data Source=JP;Initial Catalog=Lab;Integrated Security=True;MultipleActiveResultSets=True&quot;" providerName="System.Data.EntityClient" />
      <add name="Entities" connectionString="metadata=res://*/Models.ModelLab.csdl|res://*/Models.ModelLab.ssdl|res://*/Models.ModelLab.msl;provider=System.Data.SqlClient;provider connection string=&quot;Data Source=JP;Initial Catalog=Lab;Integrated Security=True;MultipleActiveResultSets=True&quot;" providerName="System.Data.EntityClient" />
     </connectionStrings>
    </configuration>
    

     

     

    Gracias de antemano

    viernes, 30 de julio de 2010 18:11

Todas las respuestas

  • Hola:

    Primero de todo, seguramente esta pregunta te la podrán contestar con mayor precisión en el foro de C#, donde parece que se suelen hacer las preguntas relacionadas con Entity Framework, puesto que parece que tu problema está relacionado con esa tecnología y no con WCF.

    En cualquier caso, supongo que si a tu base de datos tienes que acceder utilizando login/password, no te basta con configurar únicamente tu conexión para el login, sino que tienes que hacerlo con todas las conexiones de bases de datos. En el trozo de configuración que has posteado, parece que sólo has cambiado la configuración para localSqlServer, pero sigues usando seguridad integrada con las conexiones LabEntities y Entities, de las cuales supongo que EF está haciendo uso.

    Yo probaría a actualizar ambas conexiones.

    De todas formas, si esto no resuelve tu problema, pásate por el otro foro que ahí encontrarás gente mucho más experimentada en el tema.

    Un saludo.

    jueves, 12 de agosto de 2010 14:31