none
Tiempo invertido en generar proyecto. RRS feed

  • Pregunta

  • Hola a todos,

    Tengo un problema de renidimiento con Visual Studio 2008 y los proyectos para sistemas móviles.
    Cada vez que genero mi proyecto y lo quiero probar sobre uno de los emuladores, tengo que estar esperando del orden de unos 10 minutos, tengo un equipo suficientemente potente y únicamente me sucede con este tipo de aplicaciones para móviles.
    ¿Tenéis idea de porque puede ser?
    Gracias por vuestra ayuda.

    Javi.
    lunes, 13 de julio de 2009 11:58

Todas las respuestas

  • De momento lo que voy haciendo es cerrar Visual Studio y volver a abrir el proyecto, ya que de este modo no le cuesta tanto tiempo ejecutar la aplicación. La primera vez ejecuta el proyecto bien, pero las siguientes le puede llegar a costar hasta 15 minutos, así que es más eficaz, cerrar el proyecto y volver a abrirlo.

    Seguro que habrá algún motivo para esto, si se os ocurre algo os lo agradecería.

    Javi.
    martes, 14 de julio de 2009 11:49
  • Hola,

    Al cerrar el emulador, le indicas que No guarde la configuracion? esto causa que siempre se instalaen las librerias necesarias para ejecutar tu aplicacion.

    Otro punto seria si tienes imagenes pesadas o archivos dentro del proyecto y le estas indicando en la ventana de propiedades que siempre las copie al directorio de ejecucion.

    En la barra de estado de VS aparece que esta copiando o que esta instalando en el emulador... revisa a ver si esta haciendo alguna de las dos cosas.

    Saludos,

    Roberto Alvarado Taborda Core Group BogotaDotNET Compact Framework Developer .NET Bogota - Colombia
    martes, 14 de julio de 2009 16:03
  • Hola,

    Lo primero, gracias por la respuesta.

    En mi proyecto no tengo grandes archivos ni imagenes pesadas. En cuanto a guardar la configuración, la suelo guardar, o no cierro el emulador.

    El proceso se "atasca" antes de llegar a la fase de implementación, una vez que llega a esta fase, copia los archivos rápidamente.
    Lo curioso es que siempre, la primera vez que genero el proyecto, lo hace muy rápido, pero a partir de la segunda vez, le cuesta una eternidad (hablo de más de 10 min...), así que lo que os comentaba antes, es más rápido que cierre el proyecto y lo vuelva a abrir, cada vez que necesite generar el proyecto para probar las modificaciones que voy añadiendo...demasiado laborioso...

    Gracias de nuevo.

    Javi.
    miércoles, 15 de julio de 2009 6:55
  • Hola amigo,

    Verifica si tu VS 2008 tiene aplicado el SP 1

    Ademas verifica si esta utilizando el SDK Windows mobile 6.0 o superior


    Prueba y cualquier cosa  me avisa!


    saludos.

    calificame!

    Developer
    viernes, 31 de julio de 2009 19:53