none
Problema con roles y acciones RRS feed

  • Pregunta

  • Hola, tengo un problema usando roles en mi aplicacion, a traves de l ainterfaz web de visual studio, he creado un rol "Administradores", luego en mi controller sobre la accion puse [Authorize(Roles="Administradores")]

    cuando no estoy logueado, y trato de acceder a esa accion el sistema me redirecciona al formulario de login, el problema es que aun despues de loguearme con el nombre de usuario que tiene asignado el rol de "Administradores" no puedo acceder a los resultados de la accion, pues me sigue redireccionando al formulario de login. Por que me sucede esto y como podria corregirlo?

    Tengo que añadir que intente creando reglas  de acceso para el rol "Administradores" donde le permitia el acceso a la carpeta raiz de la aplicacion, pero esto no resolvio el problema, entonces quité la regla.

    Saludos cordiales


    viernes, 12 de agosto de 2011 14:12

Respuestas

  • Hola Richof

    Podrías explicar más la situación, por ejemplo: ¿qué proveedor de roles estás usando? ¿está ese proveedor adecuadamente registrado en el web.config?

    Por ejemplo si estuvieras usando un proveedor de roles personalizado en el web.confing tendrías que tener algo parecido a lo siguiente:

    <roleManager enabled="true" defaultProvider="MyRoleProvider">
    <providers>
    <clear/>
    <add name="MyRoleProvider" connectionStringName="TuStringDeConexion"
     applicationName="/"
     type="MyRoleProvider" />
    </providers>
    </roleManager>
    

    En este enlace: http://www.4guysfromrolla.com/articles/120705-1.aspx está bastante explicado el tema de la membresía y los roles, por ahí puede serte de ayuda.

    Saludos!

    • Marcado como respuesta Richof sábado, 20 de agosto de 2011 18:35
    martes, 16 de agosto de 2011 23:14
  • Hola Richof

    Ademas de lo que te comenta Laura, tienes otra especificacion de restriccion por roles? (tienes restringido por location en el web.cofig?)

    Si puedes colocar parte de código de tu configuración te podremos ayudar mejor


    Jose. A Fernandez | blog: http://geeks.ms/blogs/fernandezja
    • Marcado como respuesta Richof sábado, 20 de agosto de 2011 18:35
    viernes, 19 de agosto de 2011 23:59
  • Hola, gracias por sus respuestas, el error estaba solo en la definicion del rol, en el webconfig estaba como "Administrador" y no como "Administradores"

    Muchas gracias

    Saludos

    • Marcado como respuesta Richof sábado, 20 de agosto de 2011 18:34
    sábado, 20 de agosto de 2011 18:21

Todas las respuestas

  • Hola Richof

    Podrías explicar más la situación, por ejemplo: ¿qué proveedor de roles estás usando? ¿está ese proveedor adecuadamente registrado en el web.config?

    Por ejemplo si estuvieras usando un proveedor de roles personalizado en el web.confing tendrías que tener algo parecido a lo siguiente:

    <roleManager enabled="true" defaultProvider="MyRoleProvider">
    <providers>
    <clear/>
    <add name="MyRoleProvider" connectionStringName="TuStringDeConexion"
     applicationName="/"
     type="MyRoleProvider" />
    </providers>
    </roleManager>
    

    En este enlace: http://www.4guysfromrolla.com/articles/120705-1.aspx está bastante explicado el tema de la membresía y los roles, por ahí puede serte de ayuda.

    Saludos!

    • Marcado como respuesta Richof sábado, 20 de agosto de 2011 18:35
    martes, 16 de agosto de 2011 23:14
  • Hola Richof

    Ademas de lo que te comenta Laura, tienes otra especificacion de restriccion por roles? (tienes restringido por location en el web.cofig?)

    Si puedes colocar parte de código de tu configuración te podremos ayudar mejor


    Jose. A Fernandez | blog: http://geeks.ms/blogs/fernandezja
    • Marcado como respuesta Richof sábado, 20 de agosto de 2011 18:35
    viernes, 19 de agosto de 2011 23:59
  • Hola, gracias por sus respuestas, el error estaba solo en la definicion del rol, en el webconfig estaba como "Administrador" y no como "Administradores"

    Muchas gracias

    Saludos

    • Marcado como respuesta Richof sábado, 20 de agosto de 2011 18:34
    sábado, 20 de agosto de 2011 18:21