none
Problema para abrir un proyecto RRS feed

  • Pregunta

  • Hola, les escribo porque necesito que me ayuden.. espero que este sea el lugar adecuado para hacer la pregunta.

    Tengo una pc (Windows XP) en la cual están instalados visual studio 2005 sp1 y 2008 sp1 y allí tengo 2 proyectos de 2 webs en ASP.NET MVC en C#. El tema es que necesito copiar estos proyectos para utilizarlos en otra PC, la cual está desde cero (se formateó) con windows 7 y a la cual tiene instalados el vs2005 sp1 y vs2008 sp1 (con todas las actualizaciones que salieron de windows update) junto con el MVC. Los proyectos, los copié de una pc a la otra por red copiando la carpeta del proyecto con todos sus archivos dentro, sea, solución, vistas, etc.. todo lo referente al proyecto. Pero el tema es que cuando quiero abrir el proyecto en la nueva PC, me salta el cartel en Visual Studio 2008 que me dice "No se puede abrir el archivo del proyecto 'C:\...\Carpeta del proy\proyecto.csproj'. El tipo de proyecto no es compatible con esta instalación" y no abre el proyecto, que puede ser? ya intenté actualizar nuevamente por windows update y nada... sigue igual, espero me puedan ayudar, muchas gracias!!!

    miércoles, 24 de marzo de 2010 18:28

Respuestas

  • hola

    istala tambien la version 1.0 de mvc, puedes que tengas instalado las dos versiones en la pc anterior, pero que el proyecto este creada con la version 1.0 por eso aunque tengas la verion 2.0 no te detecte el tipo de proyecto

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    miércoles, 24 de marzo de 2010 20:35

Todas las respuestas

  • hola

    has puesto en la otra pc el instalador del asp.net mvc en la version con que estas desarollando, ojo que ahora estas la 1.0 y 2.0, piede que no tengas la version correcta

    - cuando da este fallo, la solucion si la abre ?

    solo es el proyecto mvc el que no reconoce

     

    me refiero a esto

    http://www.microsoft.com/downloads/details.aspx?FamilyID=53289097-73ce-43bf-b6a6-35e00103cb4b&displaylang=en

    o este

    http://www.microsoft.com/downloads/details.aspx?familyid=7ABA081A-19B9-44C4-A247-3882C8F749E3&displaylang=en

     

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    miércoles, 24 de marzo de 2010 19:06
  • hola

    has puesto en la otra pc el instalador del asp.net mvc en la version con que estas desarollando, ojo que ahora estas la 1.0 y 2.0, piede que no tengas la version correcta

    - cuando da este fallo, la solucion si la abre ?

    solo es el proyecto mvc el que no reconoce

     

    me refiero a esto

    http://www.microsoft.com/downloads/details.aspx?FamilyID=53289097-73ce-43bf-b6a6-35e00103cb4b&displaylang=en

    o este

    http://www.microsoft.com/downloads/details.aspx?familyid=7ABA081A-19B9-44C4-A247-3882C8F749E3&displaylang=en

     

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina


    Hola, gracias por responder! La solución la abre luego de aceptar el mensaje de error, pero el proyecto está en "gricesito" sin poder acceder a él.

    En la pc "vieja" el proyecto lo comencé con asp.net mvc 1.0 y luego instalé la versión 2.0 (sigo hablando de la pc "vieja"), y en la pc "nueva" le instalé solamente el 2.0.

    Espero te ayude esto a solucionar mi problema, gracias!

    miércoles, 24 de marzo de 2010 20:33
  • hola

    istala tambien la version 1.0 de mvc, puedes que tengas instalado las dos versiones en la pc anterior, pero que el proyecto este creada con la version 1.0 por eso aunque tengas la verion 2.0 no te detecte el tipo de proyecto

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    miércoles, 24 de marzo de 2010 20:35
  • hola

    istala tambien la version 1.0 de mvc, puedes que tengas instalado las dos versiones en la pc anterior, pero que el proyecto este creada con la version 1.0 por eso aunque tengas la verion 2.0 no te detecte el tipo de proyecto

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    Hola, gracias nuevamente por responder, me solucionaste el problema! pensé que instalando la versión 2.0 sería suficiente, pero instalé también ahora la 1.0 como me sugeriste y se solucionó y pude abrir el proyecto, muchas gracias!
    jueves, 25 de marzo de 2010 12:14