Problems using port 80: Services not running?


  • I have been developing a client/server application for some time now and recently I did a complete reinstall of Windows XP Professional.  I have everything working, and everything has been working the past few weeks, so all was good until I had a friend test connect to my server remotely.  My server runs on port 80.

    The problem is that now port 80 is closed on my computer.  I have it forwarded to my computer via my router's port forwarding, and I have no firewalls running at all.  Windows Security Center is disabled as well.

    So my question is, are there any services that port 80 depends on for me to be able to accept incoming connections?  Is there a way I can force it open on my computer?

    I will provide any details necessary.  This is kind of urgent, so if you help I really appreciate it.
    Sunday, March 04, 2007 5:54 AM

All replies

  • Hi,

    Port 80 is used by IIS for http traffic.

    Sunday, March 04, 2007 7:34 AM
  • I have had this working before, I've been running a web server on my computer for 6 years now on port 80.  I've tried installing/uninstalling, enabling/disabling IIS to no effect.  I have configured loads of Windows settings regarding firewalls/IIS and other network components to no avail.

    I called my ISP and they said that they do not block any ports, so there must be a service I have disabled/not running or some kind of setting that needs to be restored or changed.
    Sunday, March 04, 2007 7:50 AM
  • Apparently not one single TCP connection will connect to my computer, so something in Windows is messed up and I just spent the last 10+ hours trying to fix it. If anyone can shed some light here, I would really appreciate it.

    EDIT:  I have also noticed that the only port that is forwarded that seems to work is the Remote Desktop Port for Windows.  Any other port I forward to my computer does not work.  (I am using an ActionTec router by the way with Qwest DSL)
    Sunday, March 04, 2007 11:42 AM
  • I'm going to clarify here so I can get a better response.
    • Port 80 is forwarded to my Network IP via my Router
    • Port 80 is in the Windows Firewall Exceptions
    • Windows Firewall is also disabled
    • Windows Internet Connection/Firewall Sharing Service is disabled
    • Other TCP Ports that are forwarded to my Network IP don't work either.
    • I ran a port scanner and it says all of my forwarded ports are closed.
    • The only forwarded port that does work is Remote Desktop Port (TCP)
    • I have tried repair tools to reinstall the TCP/IP Protocol and fix the Winsock Catalog
    • I have reinstalled my network adapter
    • I have reinstalled all network drivers
    • I have released, renewed my network adapter
    • All this to no avail.
    So I really have no clue what else to do.  I am starting to think I should reinstall Windows again....  If you think you can help, or actually can, I would really appreciate it.  I havn't slept in 2 days and would like to get some sleep knowing I don't have to wake up and fix my computer.  >.<
    Sunday, March 04, 2007 4:09 PM
  • Have you checked Event Viewer for any failures?

       Ed t.

    Sunday, March 04, 2007 8:58 PM
  • Yeah, but there isn't anything relating to my problem.  So here is what I have done also:

    • I reinstalled and reconfigured my router
    • I reinstalled Windows
    • I called my ISP and tried many things to no avail.  (They say they do not block any ports what so ever)
    • I tried turning NAT off.  No avail.

    ....  so, something in Windows is fishy here.  Is there a possibility that something is wrong with my HOSTS file or some other network/internet related setting?

    Also on a side note, my router is nearly 4 years old and the Firmware is outdated and not used anymore.  My ISP said to update the Firmware, but it failed to update so I am stuck on the old Firmware.  Could this be the reason port forwarding is not working because I don't have Firmware that can properly communicate with my ISP due to it being so outdated?

    Monday, March 05, 2007 7:24 AM