none
Image not showing up as transparent in Print Preview RRS feed

  • Question

  • I posted this on another Access forum, but no replies, so I'm hoping someone here might be able to help.

    In Access 2016, I'm trying to add a PNG file (with a transparent background) to a report, using a link to the file that is in one of the fields of my table. This way the image can change based on the record that is being printed on the report.

    The image is showing up on the report, and when I am looking at it in Report View and Layout View, the background is transparent just as it should be. However, when I switch to Print Preview, the background is no longer transparent. I cannot for the life of me figure out why. I have the Back Style set to Transparent, and the Back Color is set to No Color.  When I scroll through the various pages of the report (one for each record in the table/query), on the even numbered pages, the background of the image changes from white to a light tan.

    I tried printing the report, just for the heck of it, and on the printed version, it's also not transparent. I'm at a loss. Why would it show up as transparent in Report View and Layout View, but not in Print Preview?  Not be able to do this completely eliminates the purpose of my database, as the purpose is to insert a signature (the image file in question) onto various reports and then have them converted to PDF.  If the signature background won't show up as transparent, the PDF files won't be acceptable to the people I need to submit them to.

    Any help someone could offer is greatly appreciated.  I'm happy to send someone my database file.  Right now it's just a test database, so there is no sensitive information inside.

    Wednesday, September 20, 2017 3:42 PM

All replies

  • Does the image also not show up as transparent if you simply output the report straight to PDF? Just curious...
    Wednesday, September 20, 2017 4:08 PM
  • Correct.

    One slight mistake in my first post... on the even number pages, the background is not light tan -- it's more like a light blue.

    I have created a ZIP file that everyone is welcome to download to see if it does the same thing on your computer.

    https://www.dropbox.com/s/5z8c8665apjrp67/TestDatabase.zip?dl=0

    Inside are three files:

    -the database file itself

    -the signature image (PNG with transparent background), which will need to be put in the root folder of your C drive (or else change the link in the Employees table for the Signature)

    -the PDF I just made to test it (and you will see the background is not transparent)

    There are three reports in my Access database.  The one you want to look at is 'Deal Memo - imported as TIF'.

    TIA for any help you can offer.

    Wednesday, September 20, 2017 4:36 PM
  • Hi,

    Here's what I did:

    And then got this:

    Hope it helps...

    Wednesday, September 20, 2017 4:56 PM
  • Oh wow.  Thank you so much!!  :)
    Wednesday, September 20, 2017 5:11 PM
  • Oh wow.  Thank you so much!!  :)

    Hi,

    You're welcome. I hope it works for you as well. Good luck!

    Wednesday, September 20, 2017 5:25 PM
  • Hi mcomp72,

    I can see that your issue is solved now.

    but this thread is still open.

    I suggest you to mark the suggestion as answer given by .theDBguy

    it will help other community members in future , who will have same kind of issue.

    if you not mark the answer then this thread will remain open.

    if you mark the answer then we can close this thread.

    thanks for your understanding.

    Regards

    Deepak


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, September 21, 2017 1:40 AM
    Moderator