locked
How to trouble shoot Webcam service issue? RRS feed

  • Question

  •  

    I follow http://msdn.microsoft.com/en-us/library/bb483096.aspx to learn how to play with Webcam.

    I have one Microsoft LifeCam NX-6000 Webcam attached to my PC(Windows XP SP2), and start the service as the tutorial says "dsshost /p:50000 /m:"samples\config\WebCam.manifest.xml". The console prints:

     

    *   Service started [05/13/2008 19:53:57][http://mymachine:50000/directory]
    *   Service started [05/13/2008 19:53:57][http://mymachine:50000/constructor/788c3a79-9295-4f95-9c71-5fc4a69759c1]
    *   Service started [05/13/2008 19:53:57][http://mymachine:50000/console/output]
    *   Starting manifest load: file:///C:/Documents and Settings/username/Microsoft
    Robotics Dev Studio 2008/samples/config/WebCam.manifest.xml [05/13/2008 19:53:57
    ][http://mymachine:50000/manifestloaderclient]
    *   Manifest load complete [05/13/2008 19:53:58][http://mymachine:50000/manifestloaderclient]

     

    It looks like it's OK. However, when i type http://localhost:50000/webcam/jpg in IE, it just redirect to service directory. No image is displayed. Then I checked http://localhost:50000/console/output. There is a error message, seems cannot find webcam device.

    Unable to select device

     

     

    Anyone has same experience?

    How to shoot this issue?

     

    Thanks,

     

     

     

     

     

    Tuesday, May 13, 2008 12:13 PM

Answers

  • if windows cant find your webcam, then we will not be able to either. we support most well known webcams (because there drivers for them etc)

     

     

     

    Thursday, May 15, 2008 4:42 AM