none
Start VM 'Failed' - Provisioning Failed, Key Vault Does Not Exist RRS feed

  • Question

  • I stopped/deallocated an Azure VM a couple of weeks ago.

    I just tried to restart it, but it just says 'Failed' with a provisioning state error code of: ProvisioningState/failed/KeyVaultDoesNotExist

    What does this mean and how can we fix it?

    Thursday, August 8, 2019 3:25 PM

All replies

  • Can you please share the following details:

    Did you recently delete the KeyVault associated with that VM? 

    Do you have the KeyVault logging enabled in your tenant so we can capture more detailed information? 
    https://docs.microsoft.com/en-us/azure/key-vault/key-vault-logging

    Thursday, August 8, 2019 9:56 PM
    Moderator
  • Hi,

    No, I haven't deleted any Key Vaults - to be honest I don't know what they are.

    The only recent change is that I stopped/deallocated that VM about 2 weeks ago. Now I can't restart it.

    I don't know if KeyVault logging is enabled, how can I tell? I had a quick look at the article and it talks about Powershell and command line interface - I don't know how to do that and just use the Azure Portal to manage the VMs.

    Friday, August 9, 2019 8:33 AM
  • Thank you for sharing the details. Can you please check the Activity log on Azure portal and see if there any activity log related to Azure KeyVault or the VM that could provide us some insights. Let me know and I can dig deeper. Thanks.
    Friday, August 9, 2019 9:19 PM
    Moderator
  • No, I couldn't see anything.

    However, issue is now resolved. I purchased a support plan.

    I don't know what caused it - looks like Azure somehow corrupted the config for the disk. The resolution was to create a new managed disk, copy over the VHD and create a new VM to use the copied disk. All worked fine then.

    So, the old disk, for some reason decided that it needed a key vault that had never existed!

    I've cancelled the support plan so that I only pay for one month. However, as feedback, I find it very unpleasant to have to pay for support when its an Azure service issue (that is already being charged!). It makes me want to use Azure a lot less, look at alternates as we grow our cloud needs and is something I always mention when asked for a recommendation for a cloud provider!

    Thanks for your help though.

    Monday, August 12, 2019 7:59 AM
  • I am sorry that you had such experience with Azure. Can you please share your Support request number and I will reach out to the product team to understand the root cause and ensure, if this is a product issue, it is fixed.
    Thank you for your honest feedback.
    Monday, August 12, 2019 6:02 PM
    Moderator
  • Thanks for all the details on this. I have worked with that KeyVault errors many times before and it stems from setting up a keyvault or a storage account associated to the VM that was either renamed or removed. Generally adding the storage account or keyvault resolves the error but in your case as you found it does not always fix the issue. 

    Luckily there are ways to recover much of the data of a corrupted disk and support did point you in the right direction. Hard to say exactly what caused the corruption unfortunately. At least I am glad to hear you were able to get a solution and get back up and running. 

    We have a few different support plan options depending on your needs. However I totally get the annoyance of paying for support when something is broken. If you encounter any other issues please feel free to post here on MSDN and myself and my team will do our best to assist. 

    Thursday, August 15, 2019 10:50 PM
    Moderator
  • Any update on this? 

    If the proposed answer was useful, please remember to "Up-Vote" and "Mark as Answer" so others in the community can benefit 

    Thursday, August 22, 2019 10:04 PM
    Moderator
  • No update, same as my previous answer. Its now fixed as I had to purchase a support plan to fix an Azure problem!

    The resolution was, as I said, to copy the VHD file and build a new VM. Lots of hassle to move IP over, etc, but it worked in the end.

    However, no answer to why it happened. Just 'one of those things' where Azure decided to mess with it. It was fine, got stopped and then never restarted.

    So, other than to purchase a support plan there's no other resolution in this thread as I didn't find out what the problem was!

    Friday, August 23, 2019 7:10 AM
  • Got it. Well thank you for getting back and confirming that. 

    If you end up with any other issues, please just post a thread and we will make sure to get you back up and running without the need to purchase additional support. 

    Friday, August 23, 2019 5:19 PM
    Moderator