locked
Weird error - webclient (visual studio 2012) RRS feed

  • Question

  • Hello all

    I tried to add a webclient to a form, and it drops just fine on the form, but I get a weird error on build time.

    Type in the data at line 140, position 5, cannot be loaded because it threw the following exception during construction: No data is available for encoding 1252

    I tried to debug it but no chance to do anything with it. Is my system that has issues or is it just me. I used to be able to code with a webclient in visual studio 2010.

    Tuesday, July 24, 2012 5:03 PM

Answers

  • OK, did that. It does appear to be a bit of a disaster - in the designer.vb file it highlights a couple more problems. You might want to report it as a bug (under the Help menu). I've removed it from my toolbox just to be safe.

    I'd just create it in code instead of dropping it onto the form.

    HTH,

    Andrew

    • Marked as answer by Gwolf2u Tuesday, July 24, 2012 7:28 PM
    Tuesday, July 24, 2012 7:25 PM
  • ok good to know it's not just me

    was wondering why it got that especially since in 2010 version, it works just fine.

    well I will report as a bug

    ty for testing and letting me know

    • Marked as answer by Gwolf2u Tuesday, July 24, 2012 7:28 PM
    Tuesday, July 24, 2012 7:28 PM

All replies

  • I can't find a WebClient in the toolbox in VS2012 to drop on to a form to try to reproduce the error. Where does it live?

    The only applicable reference to the error you're getting which I can find suggests setting the WebClient to use UTF8 encoding instead of Windows-1252.

    --
    Andrew

    Tuesday, July 24, 2012 6:18 PM
  • Made a simple screenshot to help you find it

    screen shot

    • Marked as answer by Gwolf2u Tuesday, July 24, 2012 7:28 PM
    • Unmarked as answer by Gwolf2u Tuesday, July 24, 2012 7:28 PM
    Tuesday, July 24, 2012 6:25 PM
  • OK, did that. It does appear to be a bit of a disaster - in the designer.vb file it highlights a couple more problems. You might want to report it as a bug (under the Help menu). I've removed it from my toolbox just to be safe.

    I'd just create it in code instead of dropping it onto the form.

    HTH,

    Andrew

    • Marked as answer by Gwolf2u Tuesday, July 24, 2012 7:28 PM
    Tuesday, July 24, 2012 7:25 PM
  • ok good to know it's not just me

    was wondering why it got that especially since in 2010 version, it works just fine.

    well I will report as a bug

    ty for testing and letting me know

    • Marked as answer by Gwolf2u Tuesday, July 24, 2012 7:28 PM
    Tuesday, July 24, 2012 7:28 PM