locked
Displaying images that are accessed through URL RRS feed

  • Question

  • Hi,

    I have trouble displaying images that are accessed through URLs in my report.
    If I call the URL directly in the Browser the Image can be opened without problems.
    The images can be accessed with an anonymous access.

    When I deploy the report or in the Preview of Visual Studio I get the following message:

    [rsWarningFetchingExternalImages] Images with external URL references will not display if the report is published to a report server without an UnattendedExecutionAccount or the target image(s) are not enabled for anonymous access.

    In Layout View of Visual Studio the image is showen correctly.

    The Images are stored on a Solaris maschine with WebSphere 6.0 as WebServer.

    Any ideas?

    Thank you.

    Frank


     

    Wednesday, November 29, 2006 10:40 AM

Answers

  • I enabled anonymous access and that solved my issue.

    Tuesday, September 25, 2007 6:54 PM

All replies

  • You need to configure unattended execution account: http://msdn2.microsoft.com/en-us/library/ms156302.aspx

     

    Wednesday, November 29, 2006 11:21 PM
  • I configured the unattended execution account, but there I can only use windows user. The images are on a Sun Server with Solaris 9 (Unix) which has different users. Allthough the Images can be accessed without any authorisation, so I think I don't need  the unattended execution account.

    Any more ideas

    Thank you

     

     

     

    Thursday, November 30, 2006 7:59 AM
  • Have you ever figured this out?  I am having the same issue, but the file is on the report server.  Actually, it's not an image file, but an ASP.Net web application that creates an image on the fly.  Like you, I can get it to come up in the development environment or if I enter the URL directly, but it won't appear in the deployed report.

    I have set the unattended execution account, restarted IIS, set permissions to the app's dll everywhere I could think... nothing works.

    Interestingly, if you look at the report's source, you can see the images "src" attribute is an empty string, so the report renderer is blocking it.

     

    Thursday, January 11, 2007 4:13 PM
  • Has anyone found a resolution for this.  I have taken the same steps and still only get the RED X in the  image space.  Account used for unattended execution has admin rights and I can see the image when calling the URL directly from IE.
    Tuesday, March 27, 2007 1:08 PM
  •  

    i am also desperately looking for a resolution here
    Thursday, August 2, 2007 9:03 AM
  • I enabled anonymous access and that solved my issue.

    Tuesday, September 25, 2007 6:54 PM
  • I found the solution for my problem. The mime type for the images was not set on the WebSphere Server.

    After I set the mime type on the WebSpere Server, the images where shown correctly.

     

    I hope this helps.

     

    Frank

    Wednesday, September 26, 2007 6:31 AM
  •  aggle-rithm wrote:

    Have you ever figured this out?  I am having the same issue, but the file is on the report server.  Actually, it's not an image file, but an ASP.Net web application that creates an image on the fly.  Like you, I can get it to come up in the development environment or if I enter the URL directly, but it won't appear in the deployed report.

    I have set the unattended execution account, restarted IIS, set permissions to the app's dll everywhere I could think... nothing works.

    Interestingly, if you look at the report's source, you can see the images "src" attribute is an empty string, so the report renderer is blocking it.

     



    I'm doing this exact same thing.. i was running around for hours trying to figure this out.. turns out that I needed to set my context.Response.ContextType = "image/jpeg"

    i had originally had it set to "Image/Jpeg"

    Hope this helps somebody.
    Bryan


    Tuesday, August 26, 2008 7:48 PM
  •  

    I am so badly looking for a resolution for this. I have images stores in a network folder but i am unable to view images when the report is uploaded. Any help would be greatly appreciated.

    thanks,

    Zeph.

    Thursday, September 18, 2008 4:22 PM
  • Hello,

    I have struggled with the Unattended Account and did not want to use the anonymous access. One solution I thought is using a IIS Virtual Directory pointing to an UNC path for hosting images. The following worked for me if the images were stored on a Win server.

    * Specify the RS Unattended Execution Account in the Reporting Services Configuration Tool.

    * Create a share containing the images (eg. \\SERVER\imageshare )
    ** Make sure to give read permissions (both share and filesystem wise) to the RS Execution Account.

    * Create a new IIS Virtual Directory pointing to the share:
    ** Open IIS Manager on the reporting server (eg. REPORTSERVER ):
    ** Create a new Virtual Directory (Web Sites --> Default Web Site --> New --> Virtual Directory)
    ** In the Alias prompt, type some name (eg. Pics) and in the Path prompt, specify \\SERVER\imageshare . Other options should be left default.

    * When designing reports, use "http://REPORTSERVER/Pics/somepicture.jpg" as the "Value" property for images.

    Hope this helps.


    Kind regards,
    Rain


    • Proposed as answer by derksl Friday, January 10, 2014 11:02 PM
    Monday, December 1, 2008 1:49 PM
  •  Rain3 wrote:

     

    * Create a new IIS Virtual Directory pointing to the share:
    ** Open IIS Manager on the reporting server (eg. REPORTSERVER ):
    ** Create a new Virtual Directory (Web Sites --> Default Web Site --> New --> Virtual Directory)
    ** In the Alias prompt, type some name (eg. Pics) and in the Path prompt, specify \\SERVER\imageshare . Other options should be left default.

    * When designing reports, use "http://REPORTSERVER/Pics/somepicture.jpg" as the "Value" property for images.

     

    I have followed these steps but I still can not get the images to display.

     

    Our reportserver resides in the directory of another website rather than the default site.  I would assume that I would still follow the same procedure that you have listed but it did not help.

     

    Does anyone have any other recommendations?

    Thursday, December 11, 2008 9:51 PM
  • Hi,

    How to enable the anonymous access


    vinoth arun raj X

    Wednesday, December 12, 2012 10:13 AM
  • Thank you for the great tip! I set up a Virtual Directory on the report server like you described. I modified my SSRS report to use the virtual directory as the value.
    Friday, January 10, 2014 11:03 PM
  • Hi.I'm facing same issue. Please tell the way detail.
    Thanks
    Friday, November 10, 2017 9:35 AM