locked
Shared Configuration icon not showed up RRS feed

  • Question

  • User-778714974 posted
    I installed iis 8 on a windows server 2012 core, i connected using iis manager from another server using GUI.

    I need to setup iis shared configuration between two nodes on a windows failover cluster.
    I was able to enable shared configuration normally on the first server (full install) but the problem is, the IIS shared config icon is not present on the core server. Under management section, I can only see "Configuration editor", "Feature Delegation", "IIS manager permissions", "IIS manager users"
    I'm connecting the the server using domain admin account... please advise how do i setup the IIS configuration server under this circumstance

    PS: i am not really expert at IIS & server core setting so a detailed advice will be very much appreciated
    Wednesday, November 27, 2019 5:02 PM

All replies

  • User690216013 posted

    Certain icons won't appear if you use IIS Manager on another machine to remotely manage.

    Switch to the equivalent PowerShell scripts or appcmd commands.

    Wednesday, November 27, 2019 6:45 PM
  • User-778714974 posted
    Hi lextm, thanks for the answer
    Do you know the equivalent powershell command to enable iis shared config on windows server 2012 core?
    I tried look it up on the internet and all i found is command for win server 2016 (Enable-IisSharedConfig) which apparently is not accepted on my server.... i have import module webadministration and it seems such command is not available in there too

    Please advise :(
    Thursday, November 28, 2019 5:56 AM
  • Thursday, November 28, 2019 6:52 AM
  • User-778714974 posted
    Lextm... thanks again for the answer
    But... The import module iisadministration not working for me
    And i cant find more detailed information on the link you sent me , i followed the steps and i dont know how to continue after the paragraph says “Now let’s convert the generated code into IISAdministration powshell cmdlet..”
    .....
    Really sorry, i am totally new to this, if there’s a “for noob” guidance i’ll be very grateful
    Thursday, November 28, 2019 5:47 PM
  • User-460007017 posted

    Hi asaputra026,

    Have you installed IIS management tool? If you didn't install that, IISadministration will not work.

    Besides, have you tried this 

    Install-Module –Name IISAdministration.

    Best Regards,

    Jokies Ding

    Tuesday, December 3, 2019 9:50 AM
  • User1233919575 posted

    Hi, thanks for the answer
    Do you know the equivalent powershell command to enable iis shared config on windows server 2019 core?

    Thursday, December 12, 2019 9:06 AM
  • User-428885997 posted

    I have the same problem and am following the instructions apk mod

    Sunday, December 15, 2019 6:07 PM