locked
Expression Blend is completely garbage now

    General discussion

  • Here's what's broken:

    No autocomplete.

    No creating design-time data.

    Projects that build in Visual Studio won't build in Blend, so sometimes it won't even show the UI when Visual Studio will show it just fine.

    What are you guys doing?  How could you make a new version that regresses this badly?


    Friday, June 01, 2012 7:01 AM

All replies

  • Hi Arash,

    Thanks for the feedback, there have been lot of architectural changes in Blend and Visual Studio to support the same XAML designer experiences between the two. I will communicate your feedback about autocomplete and design-time data to other members of the team as well.

    I would really like to understand the build issue you have mentioned above, can you please share the error messages you see after building the project in Blend?

    I would also recommend you to use Blend installed with Visual Studio 2012 RC bits as we have fixed significant number of issues since Beta.

    -Navit Saxena

    Friday, June 01, 2012 7:02 PM
  • Hi Navit,

    I am using the latest bits.

    The build issue was sporadic, and really it's the other stuff I mentioned that is critical.  Without design-time data, and without autocomplete, there is no longer a reason to use Blend at all.

    Visual Studio is pretty awful for working with XAML as well.

    Right now it's a matter of "pick your poison".

    Saturday, June 02, 2012 6:37 AM