none
Server 2012 RTM Remote Desktop Connection Broker Role Won't Install RRS feed

  • Question

  • Hey guys,


    I have been searching for and trying fixes for this for 3 days, and I've gotten no where.  Thanks in advance for trying to help me out.


    Here's the situation:

    I have a brand new installation of the Windows Server 2012 Datacenter 64-Bit RTM from MSDN.  This is my one and only server (just my personal one for home), so I'm using this single server to run all of the services that I need.  After a fresh installation, I added the AD and DNS roles and promoted the server to the PDC.  Then I go to add the Remote Desktop Virtualization Services (the VM virtualization role).  The installation fails, but I can't find any explanation as to why.


    I've wiped out the OS and reinstalled from scratch at leat 15 times, trying various combinations, fixes, approaches, etc.  including powershell, Remote Desktop Services Deployment, standard role-based deployment, etc.


    Using the role-based deployment, I can get every 'Remote Desktop Services' component to install except the Remote Desktop Connection Broker.  I've tried enabling RDMSUI_TRACING, but didn't get any information at all as to why it's failing.  I also cannot find RDMSDeploymentUI.txt log.


    I've also tried to deploy this using Powershell using this command:

    New-SessionDeployment [-ConnectionBroker] <string> [-WebAccessServer] <string> [-SessionHost] <string>


    That particular item does provide some error messages, but they seem to complain about the Session Host not being able to install due to not being able to find the connection string key in the registry for the Windows Internal Database.  However, I can get the session host and every other component to install using role-based deployment, except the Connection Broker.


    I've run an SFC scan, which found no issues.   I've also tried applying the one update available in Microsoft Update, and tried it without applying that update (reinstalling between attempts of course).


    I'm completely at a loss.  Has anyone encountered this before?  Any suggestions would be greatly appreciated.  Is there a powershell command for just installing the Connection Broker that might provide some additional error information, or any information at all?


    I would greatly appreciate any help anyone could offer.  I'm willing to try anything.  Thanks for taking the time to read this.


    Sincerely,


    Dominick

    Saturday, September 22, 2012 11:47 PM

All replies

  • For what it's worth, I have exactly the same problem with the Foundation edition. The error message I'm getting is that  halfway through broker installation I get a "can't add feature or role because restart is pending." At that point, if you try to add any other roles or features, you can't because a restart is pending. I then reboot and windows update seems to do something, and I can roles and features again -- except for remote desktop connection broker, which keeps dying halfway through the installation process. Interestingly, I got "Windows Update Failure: Retrying" a couple times when shutting down, but not the last few times. It seems something different  may be happening each time and maybe all the necessary components might get installed... but I've rebooted ~10 times, so I would say this is some kind of bug ...

    Thanks also for any help/advice!

    Paolo

    Monday, September 24, 2012 2:41 AM
  • Same problem for me!

    just for some test purposes I tried to put all roles on same server, so I also have the DC role on server, not sure if that causes any conflicts! I also tried to install the Windows Internal Database first since the broker seems to relay on that, but that install went fine, and broker won't install after that either. Complaints about pending reboot, and sometimes something about that it can't list installed software.

    I'm testing this on datacenter edition!

    //Mattias


    Friday, October 12, 2012 8:03 AM
  • I have the same exact problem, when I try to install the connection broker, it tell me that i have a restart pending the the installation won't proceed. I am trying this on a clean install of Server 2012 Essentials with absolutly nothing installed. If someone has any clue what might be causing this error please share.

    Thanks in advance

    Mark

    Monday, October 15, 2012 3:22 AM
  • I have the same problem!
    Monday, October 15, 2012 10:46 AM
  • I've had the same problem for a demo setup. I've learnt you can't install connection broker on a DC as the remote desktop management service needs access to the windows internal DB. Answer found here: http://social.technet.microsoft.com/Forums/en-US/winserverTS/thread/bbf47aa2-8ae5-4f22-9827-afee5a11417a
    Thursday, October 18, 2012 10:40 PM
  • Hello,

      We have the same exact problem and have opened a ticket with MS on the issue. Come to find out the Windows Internal Database fails to install causing the session broker install to fail. MS has collected logs files etc to see why this is happening. We have these as 2 seperate servers with only the 2012 RDS role installed. Hopefully they will have a fix soon for this issue.

      Thanks,

        Shaun

    Monday, November 5, 2012 5:57 PM
  • +1.  Can't install Remote Access (RRAS) role or Windows Internal Database, always complains it needs a restart, infinite loop.  Wow.
    Sunday, December 2, 2012 11:49 AM
  • Hello, sorry for my bad English. I experienced exactly the same mistakes that you. The reason can not be installed, as I read in other forums and corroborated myself, is that the 2012 version does not let you install the RDS on the same computer DC.
    Here is the link to the topic, including a possible solution, which I have not tried it yet.

    http://social.technet.microsoft.com/Forums/en-US/winserverTS/thread/bbf47aa2-8ae5-4f22-9827-afee5a11417a

    Regards

    Adrian


    Wednesday, December 5, 2012 4:11 AM
  • Hi,

    it's June 2013 and I have the very same issue that appears not to be solved by any of the updates available today via MS.

    Have you solved the issue?

    Kind regards,

    Tomaz

    Wednesday, June 19, 2013 11:08 PM
  • Hi, I have the same issue as well.  Trying to install Remote Desktop Services on a Windows 2012 server that I am running as a virtual machine (which from various accounts that I have read, should be entirely possible); this Server 2012 VM is a guest on a Hyper-V host that is running Windows Server 2008 R2 (which is patched with the semi-recent hotfix that resolves the issue with a Server 2012 guest on a Server 2008 R2 host).

    I have tried both the "Remote Desktop Services installation" option, and manually (selecting individual RDS roles) through the "Role-based or feature-based installation", as a session based deployment.  The only component that I can get to install successfully is the RD Licensing role.  I too had though that perhaps the Windows Internal Database feature was an issue with the Remote Desktop Connection Broker role installation, so I (as some others here) tried to install it on it's own and was successful with that, but still cannot get the RDCB to install.  When attempting to install the RDCB on it's own, it fails with the following message, and I haven't been able to find too many details about it:

    The request to add or remove features on the specified server failed. Installation of one or more roles, role services, or features failed. The specified module could not be found. Error: 0x08007007e

    Thursday, June 20, 2013 4:44 PM
  • p.s. this server is not a DC, and is not running any roles other than the defaulted Storage Services role.
    Thursday, June 20, 2013 5:14 PM
  • Okay so I had the same issue using a "Standard" deployment with 3 virtual Server 2012s on a physical Hyper-V datacenter edition. I tried everything mentioned in the forums with no luck. I joined all servers to the domain but did not update any of the servers with Microsoft updates and presto it worked. There is some update that is breaking the RDS role installation. By the way mine was a session base deployment. You should be able to update the servers after the roles are installed. Good luck.

    Phillip Riley

    • Proposed as answer by Gal Chig Monday, June 24, 2013 11:21 AM
    Saturday, June 22, 2013 12:33 PM
  • Thanks. We had this same problem and got the roles to install before running the MS updates. Good suggestion.
    Monday, June 24, 2013 11:22 AM
  • Thanks Phillip, that was exactly what was required - I started with a fresh Server 2012 VM, and I was able to install the Remote Desktop Services Role (all role services, session based), and it installed just fine.

    I definitely hope that someone from the server team comes across this forum post, and comes up with a fix for whichever Windows Update messes up the ability to install the RDS role.

    Monday, June 24, 2013 1:00 PM
  • Check to see if you have MS update KB2821895.  There is a an apparent bug when trying to install the RDS Broker service on a Server 2012 server with this update.  If it is installed I believe the only option would be to make a new Server 2012 VM. 
    • Proposed as answer by Dam.L Monday, July 8, 2013 2:45 PM
    Wednesday, July 3, 2013 3:23 PM
  • If it was part of the general update releases, then I'm sure I had it installed, because the server was fully patched before I installed any roles on it.  I no longer have that "problematic" VM to test on, and I did have success with a new Server 2012 VM that I installed the RDS role on, before patching, (and it is still running/working today, even after being fully patched).

    Knowing that this might be the update that caused the issue, it would have been nice to test out uninstalling it on the old VM to see if that resolved the situation, in the event that it could have helped out any one else out there with the same issue.

    Wednesday, July 3, 2013 3:44 PM
  • Just FYI:  KB2821895 doesn't give you the option to uninstall it.

    I'm unable to install the RDVH role on my server at all... going to post a thread about it.

    • Edited by Racey Cave Friday, August 2, 2013 12:35 PM
    Friday, August 2, 2013 12:32 PM
  • If this update helps anyone - I worked w/Microsoft and they confirmed that KB2821895 is borked and causes issues installing several of the RDS roles.  They pushed over to me a not-yet-live updated KB2821895 which I installed over top of the original update and it fixed everything.  Why that fixed update isn't live and they're still handing out the broken one via WU I have no idea...
    • Proposed as answer by Joophil Tuesday, September 10, 2013 4:12 PM
    • Unproposed as answer by Joophil Tuesday, September 10, 2013 4:12 PM
    Monday, September 9, 2013 2:14 PM
  • Have you looked at this KB :http://support.microsoft.com/kb/2799605/en-us ?

    Looks like that could answer it if you have also AD installed.

    ...

    Tuesday, September 10, 2013 4:16 PM
  • Also Found this:

    1. You try to install the Remote Desktop Connection Broker (RDCB) on a server that also has the Active Directory Domain Server (domain controller) role installed. This configuration is not supported by Microsoft. You need to install the RDCB on a server that does not have this role installed. See: Remote Desktop Services role cannot co-exist with AD DS role on Windows Server 2012 http://support.microsoft.com/kb/2799605

    2. If you don’t have the Active Directory Domain Service install, this issue might be caused by the Windows internal database (WID) that the connection broker installs and the Windows Update KB2821895. If you have KB2821895 installed, unfortunately you can not uninstall this KB. Try to install the Remote Desktop Connection Broker (RDBC) role on a server that does not have this Windows update.

    Note: There is currently no official communication from Microsoft that here is an issue with RDBC and KB2821895. However, try the RDBC installation without this KB and see what happens.

    For more information, Refer below link...

    http://fabrikam.wordpress.com/2013/07/15/connection-broker-installation-failedremote-desktop-deployment-issues/

    Tuesday, September 10, 2013 4:24 PM
  • Yeah, that is one of the common errors that a lot of people have been getting with Server 2012; it was like the number one cause of error that I found, when trying to troubleshoot this several months ago, which made it hard to weed-out what the true problem was.  In my case, it was the more confusing, and much more frustrating scenario with KB2821895.

    I would say, bottom line, if you're going to setup RDS in Server 2012, install those roles first, before you patch your server.  And correct, plan to have the AD role installed on another server.

    Tuesday, September 10, 2013 4:29 PM
  • Single Server Deployment Possible with WS2012?

    It appears that the Improvement 2 ("Enables you to install the Remote Desktop Connection Broker role service on a domain controller.") of a recent Server 2012 update (Article ID: 2871777 - Last Review: September 11, 2013 - Revision: 4.0) makes DC role not a breaking point for the RDS role installation.

    Monday, September 16, 2013 12:12 PM
  • I had this restart issue, found there is a registry key that needed deleting:

    "HKLM\System\CurrentControlSet\Control\Session Manager\PendingFileRenameOperations"

    If key exists, delete it.

    I have RDS Gateway running on Server 2012 R2 which is a DC, RDS Session host is a separate VM.


    Miles

    Wednesday, November 6, 2013 7:48 AM
  • I found that a GPO needs to be set for the domain account NT Service\All Services

    Once you change the GPO giving this account the "Log on as a service" right the install will go smoothly. 

    Access this GPO by going to the following: Computer Configuration > Windows Settings > Security Settings > User Right Assignment > Log on as a service <Add the NT Service\All Services account>

    If you are unable to change this setting on the local 2012 machine, you will need to change the default domain policy through the Group Policy Management Console.

    After performing the above, the install should go through successfully.  I hope this helps someone else as I wasted about 4 hours on this and no valid error messages were given to lead me to this. 

    Friday, November 15, 2013 10:16 PM
  • "Access this GPO by going to the following: Computer Configuration > Windows Settings > Security Settings > User Right Assignment > Log on as a service <Add the NT Service\All Services account>"

    This does not work; the account does not resolve.


    Wednesday, January 8, 2014 5:35 PM
  • I had this restart issue, found there is a registry key that needed deleting:

    "HKLM\System\CurrentControlSet\Control\Session Manager\PendingFileRenameOperations"

    If key exists, delete it.

    I have RDS Gateway running on Server 2012 R2 which is a DC, RDS Session host is a separate VM.


    Miles

    This took care of it for me. After deleting was able to run through the deployment now. 
    Sunday, March 30, 2014 5:46 PM
  • That helped me out, thanks!
    Wednesday, May 28, 2014 9:22 AM
  • I had this restart issue, found there is a registry key that needed deleting:

    "HKLM\System\CurrentControlSet\Control\Session Manager\PendingFileRenameOperations"

    If key exists, delete it.

    I have RDS Gateway running on Server 2012 R2 which is a DC, RDS Session host is a separate VM.


    Miles

    Try to find the software, which is filling the PendingFileRenameOperations each time. Perhaps it is a tool startet with the login scripts each time. In my case it was a LanDesk Removal Tool. I switched it off in the login scripts and everything was installed fine. Regards Markus
    Thursday, June 19, 2014 9:27 AM
  • January 2015 and I was still facing this issue!

    My setup was to install connection broker and session host on a single server to provide a terminal server for users which would also be pointed to our existing licensing server.  Initially, I was trying to install the roles but this was incorrect and I started using the scenario based installation but still had the same issue just a different error.

    My problem was that a domain level GPO that I didn't have access to change was applying specific accounts the "Log on as a Service" right, not "NT Services\All services" which is default.

    The fixes below didn't work for me.
    1.  I didn't have reg key - HKLM\System\CurrentControlSet\Control\Session Manager\PendingFileRenameOperations" to delete.
    2.  I was unable to find a way to add "NT Service\All Services" to the "logon as a service" GPO either browsing locally or the domain.  (Would still like to know how to do this fyi).

    Though solution 2 would have probably worked had I had access, my solution was slightly different and may help those with limited access to group policy.  I looked up the account service "Windows Internal Database" used to log on as which was "NT SERVICE\MSSQL$MICROSOFT##WID". I then installed group policy manager on the server, created a GPO that would apply to this server then applied "NT SERVICE\MSSQL$MICROSOFT##WID" the Log on as a Service right.  You can find this account by selecting the local computer as the source of the account (ensuring local security principles is ticked) and typing the account name.  This is why I installed group policy locally so it could find this account.  After this the installation ran perfectly.

    • Proposed as answer by Btstech Monday, March 30, 2015 3:58 PM
    Tuesday, January 20, 2015 8:59 AM
  • Two part solution for me.

    1 - Delete the HKLM\System\CurrentControlSet\Control\Session Manager\PendingFileRenameOperations registry key. Not the value of the key, as you frequently have to do when installing Exchange service packs - the actual PendingFileRenameOperations key.

    2 - Guy_Wood's solution (directly above) to add NT SERVICE\MSSQL$MICROSOFT##WID to the Log on as a Service right in Domain Controller Security Policy.

    Monday, March 30, 2015 4:02 PM