locked
Installation of AppService fails RRS feed

  • Question

  • The installation of the App Service fails with the error (found in C:\Packages\Plugins\Microsoft.Compute.CustomScriptExtension\1.9\Status\0.status):

    2018.02.21 03:28:16 ---- Waiting for servers to be ready...
    2018.02.21 03:29:16 ---- Waiting for servers to be ready...
    2018.02.21 03:30:16 ---- Waiting for servers to be ready...
    2018.02.21 03:31:16 ---- Waiting for servers to be ready...
    2018.02.21 03:32:18 ---- Error while waiting for server to become ready. Exit code: 1."}},{"name":"StdErr","status":"success","code":0,"formattedMessage":{"lang":"en-US","message":"Wait for servers has timed out\
    At C:\\Packages\\Plugins\\Microsoft.Compute.CustomScriptExtension\\1.9\\Downloads\\0\\\
    Common\\common.ps1:454 char:13
    +             throw New-Object System.TimeoutException \"Wait for server ...
    +             ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : OperationStopped: (:) [], TimeoutException
        + FullyQualifiedErrorId : Wait for servers has timed out


    C:\\Packages\\Plugins\\Microsoft.Compute.CustomScriptExtension\\1.9\\Downloads\\0\\OnS
    tartAzureVirtualMachineController.ps1 : Error while waiting for server to 
    become ready. Exit code: 1.

    At line:1 char:1
    + .\\OnStartAzureVirtualMachineController.ps1 -controllerIndex 0 -feed h ...
    +
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

        + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
        + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,OnStartAzureVirtualMachineController.ps1
     "}}]}}]

    Friday, February 23, 2018 10:46 AM

Answers

  • It appears that some rights where not set correctly on the fileserver share, so that the provisioning failed.
    After correcting the rights on the share the "Web Cloud Management Console" showed all roles as 'ready.'

    I also changed the 0.status file with the following information:

    [{"status":{"code":0,"formattedMessage":{"lang":"en-US","message":"Finished executing command"},"name":"powershell.exe -ExecutionPolicy Unrestricted -Command .\\OnStartAzureVirtualMachineController.ps1","operation":"Command Execution Finished","status":"success","substatus":[{"code":0,"formattedMessage":{"lang":"en-US","message":"Waiting for servers to be ready...\\n2017.05.26 04:59:26 ---- Servers are ready!\\n2017.05.26 04:59:27 ---- All servers are ready!\\n2017.05.26 04:59:27 ---- App Service controller installation and configuration has completed successfully."},"name":"StdOut","status":"success"},{"code":0,"formattedMessage":{"lang":"en-US","message":""},"name":"StdErr","status":"success"}]},"timestampUTC":"\/Date(1495774767271)\/","version":"1"}]

    Now I rerun the Deploy App Service step and it succeeded until the last step.


    • Edited by Daniel Etten Friday, February 23, 2018 2:47 PM
    • Marked as answer by Daniel Etten Friday, February 23, 2018 2:47 PM
    Friday, February 23, 2018 2:23 PM

All replies

  • It appears that some rights where not set correctly on the fileserver share, so that the provisioning failed.
    After correcting the rights on the share the "Web Cloud Management Console" showed all roles as 'ready.'

    I also changed the 0.status file with the following information:

    [{"status":{"code":0,"formattedMessage":{"lang":"en-US","message":"Finished executing command"},"name":"powershell.exe -ExecutionPolicy Unrestricted -Command .\\OnStartAzureVirtualMachineController.ps1","operation":"Command Execution Finished","status":"success","substatus":[{"code":0,"formattedMessage":{"lang":"en-US","message":"Waiting for servers to be ready...\\n2017.05.26 04:59:26 ---- Servers are ready!\\n2017.05.26 04:59:27 ---- All servers are ready!\\n2017.05.26 04:59:27 ---- App Service controller installation and configuration has completed successfully."},"name":"StdOut","status":"success"},{"code":0,"formattedMessage":{"lang":"en-US","message":""},"name":"StdErr","status":"success"}]},"timestampUTC":"\/Date(1495774767271)\/","version":"1"}]

    Now I rerun the Deploy App Service step and it succeeded until the last step.


    • Edited by Daniel Etten Friday, February 23, 2018 2:47 PM
    • Marked as answer by Daniel Etten Friday, February 23, 2018 2:47 PM
    Friday, February 23, 2018 2:23 PM
  • It appears that some rights where not set correctly on the fileserver share, so that the provisioning failed.
    After correcting the rights on the share the "Web Cloud Management Console" showed all roles as 'ready.'

    I also changed the 0.status file with the following information:

    [{"status":{"code":0,"formattedMessage":{"lang":"en-US","message":"Finished executing command"},"name":"powershell.exe -ExecutionPolicy Unrestricted -Command .\\OnStartAzureVirtualMachineController.ps1","operation":"Command Execution Finished","status":"success","substatus":[{"code":0,"formattedMessage":{"lang":"en-US","message":"Waiting for servers to be ready...\\n2017.05.26 04:59:26 ---- Servers are ready!\\n2017.05.26 04:59:27 ---- All servers are ready!\\n2017.05.26 04:59:27 ---- App Service controller installation and configuration has completed successfully."},"name":"StdOut","status":"success"},{"code":0,"formattedMessage":{"lang":"en-US","message":""},"name":"StdErr","status":"success"}]},"timestampUTC":"\/Date(1495774767271)\/","version":"1"}]

    Now I rerun the Deploy App Service step and it succeeded until the last step.



    Glad to know that you got it working. Thank you for sharing the solution that helped, it would benefit other users with a similar issue.

    ------------------------------------------------------------------------------------------------------

    Do click on "Mark as Answer" on the post that helps you, this can be beneficial to other community members.

    Friday, February 23, 2018 3:36 PM
  • Hi Daniel, 

    Glad that you got the problem fixed.

    Would you please share the reason how could the file share access not correct? The installer should check file share access before actual install. How it slipped the check?

    On the other hand, also please share the diagnosis you did to find out it is the file share access issue.

    Thanks.

    Max

    Sunday, February 25, 2018 5:51 AM
  • Hi Daniel, 

    Glad that you got the problem fixed.

    Would you please share the reason how could the file share access not correct? The installer should check file share access before actual install. How it slipped the check?

    On the other hand, also please share the diagnosis you did to find out it is the file share access issue.

    Thanks.

    Max

    Hi Max,

    The installer did pass the file share check. However the installation of the App Service failed on that part.

    In the "Web Cloud Management Console" on the management role I found that there was in issue reaching the fileserver share (didn't capture the error message, sorry), so the installation failed. After correcting this, the management roles (and others depending on the file share) got installed. 

    Hope this helps (a little) in making the installation better.

    Regards,
    Daniël

    Monday, February 26, 2018 8:23 AM
  • Hi Daniel, 

    Glad that you got the problem fixed.

    Would you please share the reason how could the file share access not correct? The installer should check file share access before actual install. How it slipped the check?

    On the other hand, also please share the diagnosis you did to find out it is the file share access issue.

    Thanks.

    Max

    Hi Max,

    The installer did pass the file share check. However the installation of the App Service failed on that part.

    In the "Web Cloud Management Console" on the management role I found that there was in issue reaching the fileserver share (didn't capture the error message, sorry), so the installation failed. After correcting this, the management roles (and others depending on the file share) got installed. 

    Hope this helps (a little) in making the installation better.

    Regards,
    Daniël

    Thanks for the sharing the detailed steps and your feedback.

    ------------------------------------------------------------------------------------------------------

    Do click on "Mark as Answer" on the post that helps you, this can be beneficial to other community members

    Wednesday, February 28, 2018 8:06 PM