locked
Error with VSDBCMD:The database schema provider could not be determined from the supplied RRS feed

  • Question

  •  

    Hi,

    I have started using VSDBCMD command. On one of my server where both Database and VSTS 2008 + GDR is installed,this command is working fine with out any issue.However on the other server which is my test database server, after executing the command below gives me error "The database schema provider could not be determined from the supplied
    connection string.Check if the connection string is valid for the
    ADO.NET provider used for your database provider and that you have the
    privileges necessary to connect to the server."

    Command executed by my me:
    vsdbcmd.exe  /a:Deploy /dd /cs:"Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=xxxx;Data Source=xxxxNG" /dsp:Sql /model:xxxx.dbschema /p:TargetDatabase="xxxx"

    I have installed all the prerequisite mentioned in the MSDN site.

    It would be greate if anyone could provide some help

    Thanks,
    Mayank

    Tuesday, February 3, 2009 10:54 AM

All replies

  • Hi,

    That happned me too when I was trying to run VSDBCMD from a diferent folder than C:\Program Files\Microsoft Visual Studio 9.0\VSTSDB\Deploy...

    I hope this gives you a little help.

    Thanks,

    Paul
    Thursday, November 26, 2009 8:52 PM
  • The error message is a little misleading.
    You'll receive this message if the database connection fails for any reason.
    A inaccurate connection string is probably the culprit.
    Try this:
    1. Create a myLink.udl file on your desktop, then double-click to edit.
    2. Create a connection using the GUI and test it, then save/close.
    3. Open it with notepad and copy the connection string (excluding the provider) into your command.
    Wednesday, March 3, 2010 5:40 PM
  • I tested my connection in myLink.udl and it worked but I receive the same error as the original poster. Any other suggestions?
    Friday, October 22, 2010 6:29 PM