none
Disabling VSTS continuous delivery for Azure function app RRS feed

  • Question

  • We've recently configured a release definition from VSTS that was accidentally pointed to the wrong Function app in dev. Even after pointing the VSTS release definition to a different Function app we are not able to reconfigure the deployment options.

    Under deployment options the following message is displayed and the disconnect option is grayed out:

    Your app is setup to use Continuous Delivery with VSTS. Click on the 'Continuous Delivery' item on the left menu to configure it.

    Also, there is no 'continuous delivery' item on the left menu.

    Is there anyway we can reconfigure the deployment options for this function app? 

     
    Monday, May 15, 2017 2:39 PM

Answers

  • Hi Rob,

    Not sure how it got in that state, but try this:

    • Go to https://resources.azure.com/
    • Find your function app by searching or in the tree
    • Under it, open Config / Web
    • Click Edit (may need to set it to read/write first)
    • In the JSON, change scmType to None
    • Click PUT


    Then go back to Portal and try again.

    thanks,
    David


    • Marked as answer by Rob_Obdeijn Tuesday, May 16, 2017 3:07 PM
    • Edited by David Ebbo Monday, March 19, 2018 3:27 PM
    Tuesday, May 16, 2017 2:57 PM

All replies

  • Hi Rob,

    This is not yet supported for Function Apps. How did you set that up in the first place? Try doing it from the VSTS side, which should allow you to change the deployment options. e.g. https://[youraccount].visualstudio.com.

    David

    Monday, May 15, 2017 4:58 PM
  • Hey David,

    What we did in VSTS is simply create a release definition containing an app service deploy step based on a build that packages all the files from the VSTS git repo into a zip file. I figured that would just be a simple file sync. 

    We have tried changing the deployment options in VSTS so we no longer have a release definition pointing to the function app, but unfortunately that still did not allow us to reconfigure the deployment options in the function app. 

    Tuesday, May 16, 2017 8:06 AM
  • Hi Rob,

    Not sure how it got in that state, but try this:

    • Go to https://resources.azure.com/
    • Find your function app by searching or in the tree
    • Under it, open Config / Web
    • Click Edit (may need to set it to read/write first)
    • In the JSON, change scmType to None
    • Click PUT


    Then go back to Portal and try again.

    thanks,
    David


    • Marked as answer by Rob_Obdeijn Tuesday, May 16, 2017 3:07 PM
    • Edited by David Ebbo Monday, March 19, 2018 3:27 PM
    Tuesday, May 16, 2017 2:57 PM
  • That worked, thanks David.
    Tuesday, May 16, 2017 3:07 PM
  • Hi Rob,

    I am facing with the same issue. After deploying the code from VSTS it was showing"your app is setup to use Continuous delivery with VSTS. Click on the Continuous delivery item on the left menu to configure it" in azure portal. But it was disabled. when I am trying to click on it was showing like this feature is not supported for your current plan.Could you please suggest me what to change to enable it please.


    Thanks, Santosh Kola, skola2@miraclesoft.com


    Monday, March 19, 2018 1:56 PM
  • Hi Santosh,

    I followed the steps outlined by David i.e. change the SCM properties through the Azure resources portal.


    Monday, March 19, 2018 2:37 PM
  • Thanks for your reply. But, where we can find the SCM properties. I deployed only app.js, function.json, host.json file on to function app.But, david said web app. Could you please suggest me


    Thanks, Santosh Kola, skola2@miraclesoft.com

    Monday, March 19, 2018 3:23 PM
  • Sorry, I meant Function App. They are actually the same thing at the resource level, and show up as 'sites'.
    Monday, March 19, 2018 3:28 PM
  • Hello David,

    Please check what I am doing is correct or not.

    After successful build and release in VSTS I changed the scmtype as none in Resource Explorer of function app which is in development tools. Please suggest


    Thanks, Santosh Kola, skola2@miraclesoft.com

    Monday, March 19, 2018 5:31 PM
  • Santosh, I'm not sure I follow. What specific problem are you having after setting it to None?

    David

    Monday, March 19, 2018 5:37 PM
  • David,

    when I check deployment options after setting Scmtype to none it was showing active. But, when I check functions it was not showing anything. Please suggest david.


    Thanks, Santosh Kola, skola2@miraclesoft.com

    Monday, March 19, 2018 5:52 PM
  • Santosh, please provide more complete description of what you are seeing. e.g.

    • What does "showing active" mean? Where are you looking for this specifically?
    • WHat do you mean by Functions "not showing anything"?


    Providing screenshots might help clarify.

    David

    Monday, March 19, 2018 5:58 PM
  • Hello David

    Here are my screenshots

    when I check deployment options after setting Scmtype to none it was showing active. But, when I check functions it was not showing anything.


    Thanks, Santosh Kola, skola2@miraclesoft.com

    Monday, March 19, 2018 7:07 PM
  • I see. Using Kudu Console, try going to your site\wwwroot folder to see if anything was actually deployed. It could be that no files ended up there, which would explain why you don't see any Functions in the portal.
    Monday, March 19, 2018 7:15 PM
  • David,

    Yes, the files are not deploying properly. Here is the error 

    please suggest


    Thanks, Santosh Kola, skola2@miraclesoft.com

    Monday, March 19, 2018 10:05 PM
  • Hi Santosh,

    It sounds like your issue is on the VSTS side while deploying via msdeploy, and not with Azure Functions (which never receives your files). So I would suggest starting a thread on the VSTS forum to reach the right experts.

    thanks,
    David

    Monday, March 19, 2018 10:09 PM
  • Thanks David. Its working.

    Now, I have a small doubt. I know that we can deploy multiple functions in one single function app. So, every time we need to deploy each and  every function individually. Can we have any other way to avoid this individual function deploying.


    Thanks, Santosh Kola, skola2@miraclesoft.com

    Thursday, March 22, 2018 6:14 PM
  • Hi Santosh,

    Generally, you should treat a Function App as a unit of deployment. It's best to avoid trying to just deploy individual functions without deploying the whole app.

    David

    Thursday, March 22, 2018 6:28 PM
  • This is also a fix/workaround for the current deployment center that went GA if you enable continuous integration, and then delete the Azure DevOps pipelines.  In this case, the Azure UI will not allow you to disconnect it since it cannot connect to the correct pipelines (because they are deleted already).

    By following this process, it becomes "Disconnected" and will allow you to set it up again to a different CI/CD pipeline.

    Tuesday, November 6, 2018 9:22 PM