none
EF 5 - Cannot add ADO.NET Entity Data Model item in VS 2010 RRS feed

  • General discussion

  • I've added EF 5 to one of my project using NuGet. That project never used any version of EF before. I could recompile the solution successfully. Now, I am trying to add a new item ADO.Net Entity Data Model to the project. I select "Generate from database" icon and clicking the Next button just close the wizard. What's wrong with the wizard or EF? Thanks.

    Monday, October 22, 2012 9:47 PM

All replies

  • Hi ANickV,

    Welcome to MSDN Forum.

    I think this is not caused by EF installation, please try to restart your VS and check if the wizard works.

    Best Regards


    Allen Li [MSFT]
    MSDN Community Support | Feedback to us

    Tuesday, October 23, 2012 2:03 AM
    Moderator
  • I even tried to restart my computer - it did not help. I can add a blank model but when I right click it and select "Update Model from Database", then selecting Yes or No option and then pressing the Next button closes the wizard as well. We are using Oracle ODP.Net. Maybe it causes this problem. If so, why wizards are just closed without displaying any error message?
    Wednesday, October 24, 2012 3:14 AM
  • Hi,

    After you have run through the wizard can you open the Error List in visual studio and see if there is an error there?

    If there is an error generating a model from the database then there is often an error in this error list, sometimes the database can be in a state that EF cannot handle and an error will be thrown.


    We are seeing a lot of great Entity Framework questions (and answers) from the community on Stack Overflow. As a result, our team is going to spend more time reading and answering questions posted on Stack Overflow. We would encourage you to post questions on Stack Overflow using the entity-framework tag. We will also continue to monitor the Entity Framework forum.

    Wednesday, October 24, 2012 10:19 PM
    Moderator
  • No errors is displayed in the Error List panel. As I said before - the wizard is just closed. Any other ideas how to get information about the reason why the wizard is closed?
    Thursday, October 25, 2012 12:23 AM
  • I found what causes the problem. Looks like it is Oracle tools for VS. Some internal probably exception is thrown if you have connection to Oracle database in Server Explorer and then trying to add entity model to the project. So, the fix is to remove all existing connection in Server Explorer and then add a new ADO.Net Entity Data Model. Updating model from database works correctly as well.
    Friday, October 26, 2012 1:00 AM