none
w3wp.exe make CPU 100% on Windows Server 2008, missing library v4.0_policy.4.0.mscorlib.resources_de-DE_b77a5c561934e089 RRS feed

  • Question

  • Hi guys,

    We have a Website (it is running on .NET Framework 4.0 with Integrated Mode) sitting on Windows Server 2008 that just recently switch over to implement RP WIF codes.

    Before switch over, the CPU usage hardly hit 100% during morning peak hours.

    After switch over, the CPU usage hits 100% constantly during morning peak hours, resulting the website very slow in serving request to clients.

    We ran a few performance and monitoring tools to try to find the cause of it.

    We noticed that there's this Current Connection and Current Anonymous Users values in 1 of the monitoring module. We managed to use Google Analytic to find out the total current user visiting the website (home page) at 1 particular time in the morning.

    Only about 35 users connected, and the Current Anonymous Users is about 70+ whereas the Current Connection exceeded 2000!! 

    I referred to the Current Connection and Current Anonymous Users from this link below.

    http://www.it-notebook.org/iis/article/current_connections_users.htm

    We noticed that the Current Connection goes down very very slowly over the past few hours despite having a steady of 70+ Current Anonymous Users.

    Then, we checked on another monitoring module on the w3wp.exe, and found that we keep on hitting this message saying about some missing library v4.0_policy.4.0.mscorlib.resources_de-DE_b77a5c561934e089

    We had tried recycle the Application Pool on IIS manager for this website but it didn't help.

    Any one has any idea what is this missing library? Could it be the cause?

    Appreciate the effort in advance.

    Thanks.

    Monday, April 30, 2012 6:25 AM

All replies

  • That is a publisher policy for german resource library of mscorlib.dll. Did you try repairing or reistalling .NET framework? May be this missing library is causing the issue, but not sure.


    Please mark this post as answer if it solved your problem. Happy Programming!

    Monday, April 30, 2012 7:59 AM
  • Hi Adavesh, thanks for the prompt reply.

    Good observation, I did thought of something related to German (de-DE).

    What would be a good approach to solve this issue?

    Should I re-install the .NET Framework 4.0 on the server?

    Another question, in what cases that a publisher policy is being used by a web site / web application from the w3wp.exe IIS worker process?

    I don't know what we do that uses such publisher policy.

    Thanks

    • Edited by FbLover2011 Monday, April 30, 2012 8:51 AM added addtional question
    Monday, April 30, 2012 8:34 AM
  • That publisher policy just redirects the request to resource dll of version 4.0 to something defined in the policy. For example, if the request comes for 4.0 resource, the request is redirected to 4.5 version (if this what is defined in the policy). May be that policy was installed while installing framework and that might be missing now. So, try repairing the framework.


    Please mark this post as answer if it solved your problem. Happy Programming!

    Monday, April 30, 2012 9:11 AM
  • Apparently, upon inspecting on the web.config, apparently, there's this uiCulture="de-DE" as below

    <globalization fileEncoding="ISO-8859-1" requestEncoding="ISO-8859-1" responseEncoding="ISO-8859-1" culture="en-US" uiCulture="de-DE" />

    Somehow the WIF refers to this configuration and attempt to search for this resource publisher policy of German.

    Changed it to uiCulture="en" should be able to help on the missing library issue.


    EDIT:

    to correct my post here, after changing to uiCulture="en", it didn't help. Instead, it throws back the missing library, but now mentioning the en instead of de-DE.

    But, if remove the culture and uiCulture element from the globalization tag, we didn't get the missing library error.

    However, my main concern is this:

    Does WIF (in general) needs to use globalization tag or using.System.Globalization namespace?

    I'm gone through the codes for my RP, but didn't find anything on using.System.Globalization, and also checked on the global.asax code behind, there is no code that uses the globalization or any culture stuff.

    Any idea what could be referring to the missing library?

    • Edited by FbLover2011 Wednesday, May 2, 2012 3:39 AM to add on additional discoveries
    Wednesday, May 2, 2012 2:33 AM
  • As far as I know WIF don't use globalization.

    Have a nice day.


    Ghost,
    Call me ghost for short, Thanks
    To get the better answer, it should be a better question.

    Friday, May 4, 2012 8:26 AM
  • Hi FbLover2011,

    check this, it might provide you some pointer:

    http://msdn.microsoft.com/en-us/library/cb6t8dtz.aspx


    Regards, http://shwetamannjain.blogspot.com

    Friday, May 4, 2012 1:54 PM
  • Trying installing Service pack into your Windows Server 2008. This Will solve the problem
    Monday, May 14, 2012 1:52 PM