locked
Staging Batch - Large Number - ERR210054 - An unknown error occurred when staging attribute values. RRS feed

  • Question

  • Hello !

    I defined an entity which contain an attribute defined as a number with 0 decimal.

    - When I try to insert a batch of 40 000 records with big values in that attribute via the tblStgMemberAttribute table, I get the error code ERR210054: an unknown error occurred when staging attribute values.
    - When I use the same big value but with only one record in the batch, it works
    - When I insert that value via the user interface, it also works
    (Example of values used: 2500000000000000, 4000000000000000, 2099999999999999, ...)

    In term of performance, it is not acceptable to create one batch per record.

    Do you have any idea of why I cannot process those 40 000 records in one batch ?
    Do you know how can I get more information about that "unknown error" ?

    Friday, December 3, 2010 3:23 PM

Answers

  • Hi Guillaume

    did you check in MDS Database Log in SQL management studio

    you could launch a SQL server trace to verify the error details

    Can't you split your batch file in several smaller ones ?

     


    Note: Please vote/mark the post as answered if it answers your question/helps to solve your problem. _________________________________________________________ Regards, Xavier Averbouch, Consultant, Avanade France
    Wednesday, December 8, 2010 3:49 PM
  • Hi guillaume,

    I recently saw something that could be usefull :

    In the System Settings section, the following options are available:

    • Rows per batch: indicate the number of rows per batch to be imported.


    Note: Please vote/mark the post as answered if it answers your question/helps to solve your problem. _________________________________________________________ Regards, Xavier Averbouch, Consultant, Avanade France
    Monday, January 24, 2011 12:47 PM

All replies

  • Hi Guillaume

    did you check in MDS Database Log in SQL management studio

    you could launch a SQL server trace to verify the error details

    Can't you split your batch file in several smaller ones ?

     


    Note: Please vote/mark the post as answered if it answers your question/helps to solve your problem. _________________________________________________________ Regards, Xavier Averbouch, Consultant, Avanade France
    Wednesday, December 8, 2010 3:49 PM
  • Hi guillaume,

    I recently saw something that could be usefull :

    In the System Settings section, the following options are available:

    • Rows per batch: indicate the number of rows per batch to be imported.


    Note: Please vote/mark the post as answered if it answers your question/helps to solve your problem. _________________________________________________________ Regards, Xavier Averbouch, Consultant, Avanade France
    Monday, January 24, 2011 12:47 PM