none
Virtual Server drives do not attach after reboot

    Question

  • I have a virtual server running Server 2012 R2 with C (OS), D (Temporary Storage), E (SQL Data), F (SQL Logs), G (TempDB Data), H (TempDB Logs), J (SQL Programs), K (Backups).

    After rebooting the server E and K did not reconnect. Any ideas how to resolve? The system is a 2 node Always ON High availability group.

    Wednesday, June 8, 2016 3:50 PM

Answers

  • Yes. I figured it out. Some how the parameter IsManualAttach got set to True. I changed that for the drives that were not coming online, rebooted and the drives came online.
    • Marked as answer by Lithuanian98 Wednesday, June 8, 2016 7:35 PM
    Wednesday, June 8, 2016 6:31 PM
  • Yep, that's what I was gonna tell you haha, happened to me a few times. For anyone else the powershell commands to run are:

    Show disks that are set to manualy attach:

    Get-VirtualDisk | Where-Object {$_.IsManualAttach eq $True}

    Change those disks:

    Get-VirtualDisk | Where-Object {$_.IsManualAttach eq $True} | Set-VirtualDisk IsManualAttach $False

    • Marked as answer by Lithuanian98 Wednesday, June 8, 2016 7:35 PM
    Wednesday, June 8, 2016 6:41 PM

All replies

  • Are you using Windows Storage Pools for the disks that aren't reattaching?
    Wednesday, June 8, 2016 6:02 PM
  • Yes. I figured it out. Some how the parameter IsManualAttach got set to True. I changed that for the drives that were not coming online, rebooted and the drives came online.
    • Marked as answer by Lithuanian98 Wednesday, June 8, 2016 7:35 PM
    Wednesday, June 8, 2016 6:31 PM
  • Yep, that's what I was gonna tell you haha, happened to me a few times. For anyone else the powershell commands to run are:

    Show disks that are set to manualy attach:

    Get-VirtualDisk | Where-Object {$_.IsManualAttach eq $True}

    Change those disks:

    Get-VirtualDisk | Where-Object {$_.IsManualAttach eq $True} | Set-VirtualDisk IsManualAttach $False

    • Marked as answer by Lithuanian98 Wednesday, June 8, 2016 7:35 PM
    Wednesday, June 8, 2016 6:41 PM