none
Problem with the culture in vs2008 of System.Globalization Cultue? RRS feed

  • Question

  • Hi

     

    I had a problem with System.Globalization Culture of en-in? the application is raising en-in as unspecified culture. how do i solve this? coluld anyone please help me out from this scenario?

     

    Regards

    Bhuvan

    Tuesday, October 4, 2011 3:25 PM

Answers

  • Hi Bhuvan,

    Do you mean your application are raising a culture that is not what you want?

    If yes, you can change culture as below:

    Thread.CurrentThread.CurrentCulture = new CultureInfo( "en-US" );


    Paul Zhou [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Paul Zhou Wednesday, October 12, 2011 6:28 AM
    Thursday, October 6, 2011 7:38 AM
  • Hi,

    Could you post your code here?, which is causing the problem,

    also check whether the culture is a neutral culture which may cause the problem, see the following links.

    http://social.msdn.microsoft.com/Search/en-US?query=isneutralculture&ac=1

    Looking forward to hear from you.

    Regards,

    A.Murugan


    If it solved your problem,Please click "Mark As Answer" on that post and "Mark as Helpful". Happy Programming!
    • Edited by Murugan A Thursday, October 6, 2011 8:08 AM
    • Marked as answer by Paul Zhou Wednesday, October 12, 2011 6:28 AM
    Thursday, October 6, 2011 8:07 AM

All replies

  • Hi Bhuvan,

    Do you mean your application are raising a culture that is not what you want?

    If yes, you can change culture as below:

    Thread.CurrentThread.CurrentCulture = new CultureInfo( "en-US" );


    Paul Zhou [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Paul Zhou Wednesday, October 12, 2011 6:28 AM
    Thursday, October 6, 2011 7:38 AM
  • Hi,

    Could you post your code here?, which is causing the problem,

    also check whether the culture is a neutral culture which may cause the problem, see the following links.

    http://social.msdn.microsoft.com/Search/en-US?query=isneutralculture&ac=1

    Looking forward to hear from you.

    Regards,

    A.Murugan


    If it solved your problem,Please click "Mark As Answer" on that post and "Mark as Helpful". Happy Programming!
    • Edited by Murugan A Thursday, October 6, 2011 8:08 AM
    • Marked as answer by Paul Zhou Wednesday, October 12, 2011 6:28 AM
    Thursday, October 6, 2011 8:07 AM