locked
VS2015 Pro - Create New Univeral App generates Package Installation Error RRS feed

  • Question

  • I installed VS2015 Pro with no problems or issues.  I opened VS and selected New Project targeting VB and Blank Universal App.  I immediately get a Package Installation Error

    When I click OK, the project opens with 94 errors and 7 warnings.

    If I look at the project properties and References, there are none.

    Saving, closing and reopening the project has no effect.

    Any ideas?  It would be great to try this out.

    Glen

    Thursday, July 30, 2015 5:26 PM

Answers

  • Hi, I have the same problem. But strange thing is if I try to create the new Universal App from VS2015 Blend, it will work. I then save the project from Blend and re-open it from VS2015, then no more error.

    KBS .

    • Proposed as answer by Angie Xu Friday, August 7, 2015 2:56 AM
    • Marked as answer by Angie Xu Monday, August 10, 2015 3:26 AM
    Monday, August 3, 2015 7:53 AM

All replies

  • Can you please try launching Visual Studio setup and running repair? If it doesn't fix it, please send me an email with log files (starting with dd_ ) under %temp% folder. My email is navits at microsoft dot com.

    Thursday, July 30, 2015 5:30 PM
  • Are you running Windows 10? If so have you gone to the security settings and enabled the Windows instance for development mode?

    Dave


    Dave Baker | AIDE for LightSwitch | Xpert360 blog | twitter : @xpert360 | Xpert360 website | Opinions are my own. For better forums, remember to mark posts as helpful/answer.

    Thursday, July 30, 2015 7:44 PM
  • Dave,

    Yes, I enabled developer mode.  Also, repairing VS did not solve the problem.

    Glen

    Thursday, July 30, 2015 7:45 PM
  • Hi Glen,

    Go to Tools > Extensions and Updates

    I had an immediate update to the Git support so worth checking. I only tried UWP apps after applying updates.

    Dave


    Dave Baker | AIDE for LightSwitch | Xpert360 blog | twitter : @xpert360 | Xpert360 website | Opinions are my own. For better forums, remember to mark posts as helpful/answer.

    Thursday, July 30, 2015 7:54 PM
  • Updates applied, but did not resolve problem.  I am doing a full uninstall and then will re-install to see if that makes a difference.

    Glen

    Thursday, July 30, 2015 8:02 PM
  • Hi, If you upgrade from Windows 8.1 to 10 then you may need to reinstall VS 2015, enable developer mode and enable VM mode in Bios if you are using devices simulation. Thanks
    Friday, July 31, 2015 9:08 PM
  • VS2015 Pro was installed on clean Win 10 installations, one a VM and the other a notebook.  Both exhibit the same problem.

    I have tried doing a repair on the installation with no effect and have uninstalled and re-installed VS with no effect.

    I am out of things to try.

    Glen

    Friday, July 31, 2015 9:19 PM
  • Hi, I have the same problem. But strange thing is if I try to create the new Universal App from VS2015 Blend, it will work. I then save the project from Blend and re-open it from VS2015, then no more error.

    KBS .

    • Proposed as answer by Angie Xu Friday, August 7, 2015 2:56 AM
    • Marked as answer by Angie Xu Monday, August 10, 2015 3:26 AM
    Monday, August 3, 2015 7:53 AM
  • KBS - Great catch.  That works for me too.  It isn't ideal but it works and that is definitely a step in the right direction.  Hopefully this will help point MS in the right direction, but I am curious to know if there are more people having this problem.

    Thanks Again.

    Glen

    Monday, August 3, 2015 3:12 PM
  • Yes. I have the same problem and have been trying to solve it for four days. I have uninstalled and installed three times. I have repaired three times. I have installed windows 10 as an upgrade to windows 7. Visual Studio Community 2015 was not installed over the RC, but it was installed over VS 2013 and VS 2012.
    Monday, August 3, 2015 3:55 PM
  • Yes!  I tried this and it worked for me, too. I opened universal project blank page in blend, then opened it in VS and it opened with no problem. I can also go to View in Blend, then "Open in Visual Studio" and it works. Thank you very much. I"ve been trying to fix this or find a work around for four days. Hopefully, MS will help with the problem so we don't have to use the workaround.
    Monday, August 3, 2015 4:16 PM