none
content disposition in a non SAS blob download response RRS feed

  • Question

  • Hi,

    When i add SAS token to the download url(blob storage) i am able to get the content disposition param in the download response,but when i use the non SAS uri content disposition param is not returned in the response. Should i always use SAS to get content disposition param?

    Thanks,

    Nivedita

    Friday, August 9, 2019 6:25 AM

Answers

All replies

  • No difference between SAS and non-SAS it depends on how the request was formed  and whether the blob has that property set. Take a HAR trace (or if it is an app, use fiddler) to see details and try to share to me if you still find any issues 

    May I know what exactly are you trying to perform (Can you bit elaborate more on the issue)?

    Hope this helps!

    Additional information :You may check the suggestion mentioned in this SO thread just for an idea. 

    Kindly let us know if the above helps or you need further assistance on this issue.
    ------------------------------------------------------------------------------------------

    Do click on "Mark as Answer" and Upvote on the post that helps you, this can be beneficial to other community members.

    Friday, August 9, 2019 9:38 AM
    Moderator
  • @niveditaece  Just checking in to see if the above answer helped. If this answers your query, do click “Mark as Answer” and Up-Vote for the same, which might be beneficial to other community members reading this thread. And, if you have any further query do let us know.
    Monday, August 12, 2019 5:19 AM
    Moderator
  • Thanks Sumanth for the reply. My requirement is as follows:

    Our customers should be able to download the files (that we upload to azure cloud storage with technical filenames ) with friendly file names. i have set the content disposition property of the blob while uploading the file. The requirement is not met when the Anonymous url request is made for the file download ,but if i set SAS token for the file and append that with the request, i am able to download the files with a name set during upload. I have tried the following already as mentioned in various SO questions.

    1. set the DefaultServiceVersion of storage blob service to 2017-11-09 t still the download response has x-ms-version as 2009-09-19..not sure why this has not changed yet..and content disposition param is not in the response.

    2. used XMLHttpRequest with x-ms-version as 2017-11-09---works. since the request now has the x-ms-version param

    3. tried using SAS token as mentioned in the beginning. --works as expected. but want to understand why it does not work for anonymous request

    Thanks again.

    • Edited by niveditaece Friday, August 16, 2019 7:53 AM
    Friday, August 16, 2019 7:49 AM
  • please let me know if using SAS is the only way to get a friendly file name during download
    Monday, August 19, 2019 4:50 AM
  • this works with an actual azure account..but emulator seems to have this issue. Thanks for all help
    Wednesday, August 21, 2019 4:59 AM
  • @niveditaece Glad to hear that issue got fixed.Thanks for the update and your positive comment.Do click on "Mark as Answer" and Upvote on the post that helps you, this can be beneficial to other community members!
    Wednesday, August 21, 2019 5:58 AM
    Moderator