none
WSS 3 attempting to save or retrieve has been blocked RRS feed

  • Question

  •  I had installed WSS 3 & Biztalk 2009 on brand new VPC, everything seems OK except talking to WSS. I tried to follow the Walkthrough: Module 1 - Sending and Receiving Messages with the Windows SharePoint Services Adapter. Once I finish configuration, in event viewer I have an error message
    ERROR MESSAGE :
    dapter "Windows SharePoint Services" raised an error message. Details "Client found response content type of 'text/html; charset=utf-8', but expected 'text/xml'.
    The request failed with the error message:
    bla bla bla bla
    bla.....

    When copying/pasting to HTML file the message error is

    The file you are attempting to save or retrieve has been blocked from this Web site by the server administrators. I reqd on some blogs that NTLM shouldbe enabled which I did.
    Still not working. while I was trying to run WSS configuration lab from microsoft, I saw that there is a a sharepointupdate.exe, not sure if it would be for this. In any case we are not able to download anything fromlab.

    Thanks for your help
    I have evrything running under administrator
    Saturday, December 5, 2009 3:45 PM

Answers

  • (1)
    After reading your posts, it seems there is some configuration issud with your WSS and BizTalk wss adapter. 

    You have said when you access http://machinename it goes to Central Admin.  that means your Central Admin is on port 80.  And you have also mentioned that
    ""
    Inside central admin, whe clicking on web applications list I have

    SharePoint - 81                                http://mymachine:81/
    SharePoint Central Administration v3 http://mymachine:5555/
    ""

    It shows that you have sharepoint central admin installed on port :5555.  Hmm.. do you have anything set up in "Alternaet access mappings"?  You can see that in Central Administrator -> Operations -> Alternet Access Mappings.


    (2)
    When you installed WSS adapter it ask you to install for which sharepoint web application.  You can re configure it also.  Start -> All Programs -> Microsoft Biztalk server -> Microsoft Biztalk server configuration.  And then select Sharepoint Adapter in left pane.  You can cross check "Windows sharepoint services adapter website" in Right pane.

    Post all your update.  Thanks.

    • Marked as answer by eliassal Sunday, December 20, 2009 9:52 AM
    Monday, December 14, 2009 10:16 PM
  • Correct, it was in alternate mapping and can not figure out why. What I mean there should have happened somewhere a mistake that lead to configure an alternat mapping using the default web site.
    I dropped this alternate mapping, reconfigured the web site at port 80, it started working correctly.
    Thanks
    • Marked as answer by eliassal Sunday, December 20, 2009 9:52 AM
    Sunday, December 20, 2009 9:52 AM

All replies

  • Did you run the biztalk configuration wizard for sharepoint adapter ? This configuration basically will install the Sharepoint Web service (BTSharePointAdapterWS) on the selected website which is needed for the wss adapter to work.

    Thanks,
    Anand B

    Monday, December 7, 2009 5:55 AM
  • Yes Anand, it is setup and I have BTSharePointAdapterWS web service up and running under classic apppool since the initial setup.
    Thanks for your help
    Monday, December 7, 2009 8:40 AM
  • Anand, in fact the error ment the .asmx file. Now, I went to WSS, took out asmx extension from blocked files. When I browse to http://mymachine/BTSharePointAdapterWS/BTSharePointAdapterWS.asmx, I get the following error

      
     Go back to site 
    Error  
       
    Cannot complete this action.

    Please try again.
    Troubleshoot issues with Windows SharePoint Services.
     
     
     
     

    Monday, December 7, 2009 8:55 AM
  • Can somebody please respond to this as it is becoming urgent as I have a demonstration to do next Monday for a customer
    Thanks
    Monday, December 7, 2009 4:19 PM
  • Hi Salam,

    This usually indicates WSS 3.0 isn't correctly configured on your server. Can you successfully go to the WSS central admin site?(check its port listening, etc) Will creating a normal WSS 3.0 site succeed? If not, please post detailed errors returned by WSS here. Or you may get more assistance from our WSS forum.

    In case the issue is quite urgent, please don't hesitate to call our support service for help.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, December 11, 2009 9:29 AM
    Moderator
  • Yes WEN
    I can go successfully to central admin at port 8888
    Yes I created a web site at port 81 with needed library
    I have some small doubts about default web  configured at port 80. I followed BTS2009 setpinstructions on 1 single machine, when I type http://mymachine without any port I go to central admin.
     Inside central admin, whe clicking on web applications list I have

    SharePoint - 81                                http://mymachine:81/
    SharePoint Central Administration v3 http://mymachine:5555/

    When I try to select or add a new web site, it seems to me that I don't see the any application at port 80 which is the default.When I try to create it, I get an error message indicating it exists. (In any case, I think has nothing to do with error message as the web site at port 81 functions correctly)

    Regards
    Saturday, December 12, 2009 11:37 AM
  • Wen, I opened IIS, I have just noticed that /BTSharePointAdapterWS virtual directory created during setupis runing under the application SharePoint Central Administration. When I browse to http://localhost/BTSharePointAdapterWS/BTSharePointAdapterWS.asmx, use administrator logon to enter the web service, it refuses to authenticate, 4th time I get the following error : Access denied.

    searching a little bit, I discovered the Sharepoint enabled hosts user group had no member. I added the "administrator member in this group tried to browse the web service above, I am getting now the following error:

    Server Error in '/BTSharePointAdapterWS' Application.
    --------------------------------------------------------------------------------

    Request format is unrecognized.
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.InvalidOperationException: Request format is unrecognized.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below. 

    Stack Trace:
    [InvalidOperationException: Request format is unrecognized.]
       System.Web.Services.Protocols.WebServiceHandlerFactory.CoreGetHandler(Type type, HttpContext context, HttpRequest request, HttpResponse response) +406022
       System.Web.Services.Protocols.WebServiceHandlerFactory.GetHandler(HttpContext context, String verb, String url, String filePath) +212
       System.Web.HttpApplication.MapHttpHandler(HttpContext context, String requestType, VirtualPath path, String pathTranslated, Boolean useAppConfig) +193
       System.Web.MapHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +93
       System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +155

     --------------------------------------------------------------------------------
    Version Information: Microsoft .NET Framework Version:2.0.50727.3603; ASP.NET Version:2.0.50727.3601

    Saturday, December 12, 2009 11:56 AM
  • (1)
    After reading your posts, it seems there is some configuration issud with your WSS and BizTalk wss adapter. 

    You have said when you access http://machinename it goes to Central Admin.  that means your Central Admin is on port 80.  And you have also mentioned that
    ""
    Inside central admin, whe clicking on web applications list I have

    SharePoint - 81                                http://mymachine:81/
    SharePoint Central Administration v3 http://mymachine:5555/
    ""

    It shows that you have sharepoint central admin installed on port :5555.  Hmm.. do you have anything set up in "Alternaet access mappings"?  You can see that in Central Administrator -> Operations -> Alternet Access Mappings.


    (2)
    When you installed WSS adapter it ask you to install for which sharepoint web application.  You can re configure it also.  Start -> All Programs -> Microsoft Biztalk server -> Microsoft Biztalk server configuration.  And then select Sharepoint Adapter in left pane.  You can cross check "Windows sharepoint services adapter website" in Right pane.

    Post all your update.  Thanks.

    • Marked as answer by eliassal Sunday, December 20, 2009 9:52 AM
    Monday, December 14, 2009 10:16 PM
  • Correct, it was in alternate mapping and can not figure out why. What I mean there should have happened somewhere a mistake that lead to configure an alternat mapping using the default web site.
    I dropped this alternate mapping, reconfigured the web site at port 80, it started working correctly.
    Thanks
    • Marked as answer by eliassal Sunday, December 20, 2009 9:52 AM
    Sunday, December 20, 2009 9:52 AM
  • I get this error when i try to view the webservices links e.g lists.asmx
    e.g
    http://mysite:8080/sites/dev/_vti_bin/lists.asmx
    The page just load a blank page.
    I have no idea whats wrong...
    The page and sites works normal..
    Any ideas
    Cheers
    Thursday, February 18, 2010 6:35 AM
  • Hi

    Waht do you get if you go to http://mysite:8080/_vti_bin/lists.asmx? Also just an empty screen?

    eliasen, representing himself and not the company he works for.
    Three times MVP and three times MCTS in BizTalk.
    Blog: http://blog.eliasen.dk
    Thursday, February 18, 2010 3:47 PM
  • Thanks Eliasen.
    Thats exactly it. i just get an empty screen :(
    Very wierd.
    Friday, February 19, 2010 12:26 AM
  • Thanks Eliasen.
    Thats exactly it. i just get an empty screen :(
    Very wierd.

    Hi again

    So an empty screen for lists.asmx for both the sub site and the main site?

    Try using something like Wireshark to verify what is received to make sure it is not your browser that fails.

    Also, consider creating a .NET project that consumes the web service just to see if it works and if any methods show up in your code.

    eliasen, representing himself and not the company he works for.
    Three times MVP and three times MCTS in BizTalk.
    Blog: http://blog.eliasen.dk
    Saturday, February 20, 2010 12:11 PM
  • yes empty screen on both.
    ok will try Wireshark.
    Well i tried Sharepoint Designer using xml webservices and i  can recieve some data back .
    No idea why is blank ...
    Thanks eliasen
    Monday, February 22, 2010 5:27 AM
  • yes empty screen on both.
    ok will try Wireshark.
    Well i tried Sharepoint Designer using xml webservices and i  can recieve some data back .
    No idea why is blank ...
    Thanks eliasen

    Ok... Well, if the web service works, then you are probably ready to go - just ignore that the browser doesn't show up anything for the web service?

    You could also consider finding a SharePoint forum instead to troubleshoot this specific issue.

    eliasen, representing himself and not the company he works for.
    Three times MVP and three times MCTS in BizTalk.
    Blog: http://blog.eliasen.dk
    Monday, February 22, 2010 8:48 AM
  • In order to see the Web Service from IE you need to comment out the protocols section in the BTSharepointAdapter web.config file.
    Tuesday, March 9, 2010 3:46 PM
  • I do not know why, but it appears running Microsoft.BizTalk.KwTpm.StsOmInterop3.exe  on the website (getting success) has made the w3wp.exe access denied errors disappear. Can someone explain this?
    Tuesday, March 9, 2010 4:17 PM
  • this worked for me thanks
    Wednesday, January 19, 2011 10:45 PM