none
Mount-DiskImage powershell cmdlet fails on WindowsServerCore:ltsc2019 RRS feed

  • Question

  • Hello,

    I am trying to mount an .iso image inside of a WindowsServerCore:ltsc2019 container using the PowerShell cmdlet: Mount-DiskImage . However, the mount operation fails with the following error:

    A virtual disk support provider for the specified file was not found.

    I tried with a Windows Base OS image as well and i face the same error on a Windows base OS image as well.

    I did like to know if the cmdlet Mount-DiskImage is supported inside of a Windows container. If not, what is the alternative to mount an .iso image inside of a Windows container?

    Regards,

    Kiran Hegde

    Monday, June 3, 2019 10:41 AM

All replies

  • Why do you need to mount ISO inside image? If you just need access contents of ISO image then extract it first on host and then either copy or mount volume instead
    Monday, June 3, 2019 12:56 PM
  • Hello,

    Thanks for the response.

    Let me explain. I am using a Chocolatey package to perform an installation of Visual Studio 2013 from an ISO image. The Chocolatey package downloads the ISO image for Visual Studio 2013, performs the installation.This is how we have built up our automation for VMs and physical systems. I did like to continue on with the same workflow(if possible) for Docker. I am trying to build a Docker image which has all the necessary compilers and build tools installed.

    Hence, i am trying to avoid any sort of mounting (if possible)

    Regards,

    Kiran Hegde

    Tuesday, June 4, 2019 4:51 AM
  • Hello there,

    Any advice on how i could accomplish this?

    Regards,

    Kiran Hegde

    Monday, June 10, 2019 3:55 AM
  • Greetings,

    I have to say the workflow should be changed.

    Microsoft provides SDK image to help you build applications.

    https://hub.docker.com/_/microsoft-dotnet-framework-sdk


    Sic Parvis Magna

    Wednesday, June 12, 2019 2:16 AM
  • I did like to know if this is a limitation of Docker on Windows.  Can we mount iso files inside of the Windows container?

    Regards,

    Kiran Hegde

    Wednesday, June 12, 2019 9:48 AM
  • Greetings,

    Usually we don't this (mount iso) inside a Windows Container. It doesn't make sense.

    @artisticcheese already tell you how to achieve your goal. You can use -v parameter when running container.


    Sic Parvis Magna

    Wednesday, June 12, 2019 10:56 AM
  • Thanks. I am now extracting the iso images inside of the container.
    Tuesday, June 25, 2019 6:24 AM
  • I do understand that this might not be a common operating inside of a container. However, i did like to know if this is a known issue with Windows containers. Linux containers seem to allow mounting of DVD images.
    Tuesday, June 25, 2019 6:25 AM
  • Hi Kiran, 

    I am also looking for a solution where in I'm trying to install Microsoft sql server inside my windows server core image and I get the same error. i have the iso file of sql server copied inside my container and then i'm trying to mount it. Could you please let me know how can I achieve this? 

    Any help would really be appreciated. Thank you. 

    Tuesday, January 7, 2020 9:24 AM
  • Hi.   I too am needing ISO mounting inside a Container.

    I am trying to build images in Docker and need to install some things that come in ISO form normally.

    It seems like the Virtual DVD feature did not get installed.

    I am using mcr.microsoft.com/windows/servercore:ltsc2019

    Friday, February 14, 2020 11:58 PM
  • From what i have tried, i have come to the conclusion that mounting of iso images is just not possible inside of Windows containers.  The way i solved this , was to , download the iso images, exract the same using 7zip and then perform the rest of my workflow.  Hope this helps.
    Saturday, February 15, 2020 5:26 AM
  • Hello , Please see my latest response here.
    Saturday, February 15, 2020 5:26 AM