locked
OData datasource: how to change reaonly setting RRS feed

  • Question

  • I think I may have selected "Attach to this data source as read only" when attaching an OData datasource. I can't find any way to check what the setting is or change it. Anybody know?


    Bruce

    Monday, November 11, 2013 5:21 PM

Answers

  • Hi Bruce,

    I take it that you have crafted a few screens using the OData entities and don't want to lose them. Which release are you on VS2012/2013 and how many screens?

    I would backup the screens, remove the data source and re-add it with the same name without the 'readonly' check. Then restore the screens and their code. That is using AIDE for LightSwitch. If you are on VS2013 then that has not been publically released yet. Get back as there are a few steps to make to switch the data source.

    Cheers

    Dave


    Dave Baker | AIDE for LightSwitch | Xpert360 blog | twitter : @xpert360 | Xpert360 website | Opinions are my own. For better forums, remember to mark posts as helpful/answer.

    Tuesday, November 12, 2013 11:20 AM
  • Thanks for the reply. I ended up deleting the screens and redoing them.

    One should be able to change this setting on the fly.


    Bruce

    Tuesday, November 19, 2013 4:54 PM

All replies

  • Hi Bruce,

    I take it that you have crafted a few screens using the OData entities and don't want to lose them. Which release are you on VS2012/2013 and how many screens?

    I would backup the screens, remove the data source and re-add it with the same name without the 'readonly' check. Then restore the screens and their code. That is using AIDE for LightSwitch. If you are on VS2013 then that has not been publically released yet. Get back as there are a few steps to make to switch the data source.

    Cheers

    Dave


    Dave Baker | AIDE for LightSwitch | Xpert360 blog | twitter : @xpert360 | Xpert360 website | Opinions are my own. For better forums, remember to mark posts as helpful/answer.

    Tuesday, November 12, 2013 11:20 AM
  • Thanks for the reply. I ended up deleting the screens and redoing them.

    One should be able to change this setting on the fly.


    Bruce

    Tuesday, November 19, 2013 4:54 PM