locked
SharePoint 2013 Workflow error RRS feed

  • Question

  • We are trying to deploy a simple list workflow and are encountering the error below.

    This is on a SharePoint 2013 Standard on-premise system. The web front end and workflow server are on

    different servers. Error occurs when we try to publish.

    System.InvalidOperationException: Operation failed with error Microsoft.Workflow.Client.ScopeNotFoundException: Scope '/SharePoint/default' was not found.  HTTP headers received from the server - ActivityId: 44639856-183b-4074-b74f-891f46c28348. NodeId: SPPRODWF. Scope: /SharePoint/default/5d585da5-16ef-4c43-893c-9e12269b104b. Client ActivityId : 25b63a9c-3edf-d01e-f1b8-0bd443891489. ---> System.Net.WebException: The remote server returned an error: (404) Not Found. at Microsoft.Workflow.Com

    Wednesday, August 21, 2013 7:47 PM

Answers

  • Hi,

    Base on the description, you can build the workflow. However, when trying to publish it, you got the error.

    We need to specify workflow "scope" for the SharePoint site following these steps:

    1. Created a new scope as workflow manager "pw3\_wfManager”.
    2. Grant the access rights of this scope to all users.
    3. Turn off "Anonymous Authentication" from workflow server IIS site settings.
    4. Go back to SharePoint server to register the workflow service.

    More information: On-premise windows workflow server configuration with SharePoint 2013: http://fangdahai.blogspot.in/2013/04/on-premise-windows-workflow-server.html

    Best Regards,

    Linda Li

    • Marked as answer by Lindali Thursday, August 29, 2013 10:35 AM
    Friday, August 23, 2013 12:58 AM

All replies

  • Hi,

    Base on the description, you can build the workflow. However, when trying to publish it, you got the error.

    We need to specify workflow "scope" for the SharePoint site following these steps:

    1. Created a new scope as workflow manager "pw3\_wfManager”.
    2. Grant the access rights of this scope to all users.
    3. Turn off "Anonymous Authentication" from workflow server IIS site settings.
    4. Go back to SharePoint server to register the workflow service.

    More information: On-premise windows workflow server configuration with SharePoint 2013: http://fangdahai.blogspot.in/2013/04/on-premise-windows-workflow-server.html

    Best Regards,

    Linda Li

    • Marked as answer by Lindali Thursday, August 29, 2013 10:35 AM
    Friday, August 23, 2013 12:58 AM
  • Reregister the workflow by specifying the scope like below.

    Register-SPWorkflowService -SPSite "http://server1/site " -WorkflowHostUri "http://server1:12291/" -AllowOAuthHttp -Force -ScopeName “SharePoint”

    Tuesday, November 17, 2015 10:45 AM
  • Wow - that actually worked, except it was port 12290, not 12291. And we use HTTPS, so left off the -AllowOAuthHTTP flag.

    Don't forget the iisreset after.

    Barry

    Tuesday, March 27, 2018 4:29 PM