locked
Problem with Windows Vista home premium IIS7 RRS feed

  • Question

  • User1434535609 posted

    I enabled IIS in my vista home premium, but when i try to install Test Director it says IIS not found please help

    Thursday, October 4, 2007 1:31 PM

Answers

  • User113421904 posted

    Hi VistaUser,

    Which versions of IIS does Test Director support as Bernard said? Could you show me the home page of Test Director?

    If it is not supporting IIS 7.0, you can try installing the IIS 6.0 Metabase Compatibility Layer in "Turn Windows Features on or off" in Vista. Here is the location: 

    • Internet Information Services
      • Web Management Tools
        • IIS 6 Management Compatibility
          • IIS 6 WMI Compatibility
          • IIS Metabase & IIS 6 configuration compatibility

    This component is not installed by default, because IIS 7.0 itself is not using it. This component intercepts all method calls to metabase and maps the method calls to the new system in IIS 7.

    You can refer to this article for more details:

    http://www.iis.net/articles/view.aspx/IIS7/Use-IIS7-Administration-Tools/Using-XML-Configuration/Metabase-Compatibility-with-IIS7

    Hope it helps.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, October 8, 2007 4:35 AM

All replies

  • User989702501 posted

    :) then you should check with TestDirector and see if it supports IIS 7.0

    Friday, October 5, 2007 2:50 AM
  • User113421904 posted

    Hi VistaUser,

    Which versions of IIS does Test Director support as Bernard said? Could you show me the home page of Test Director?

    If it is not supporting IIS 7.0, you can try installing the IIS 6.0 Metabase Compatibility Layer in "Turn Windows Features on or off" in Vista. Here is the location: 

    • Internet Information Services
      • Web Management Tools
        • IIS 6 Management Compatibility
          • IIS 6 WMI Compatibility
          • IIS Metabase & IIS 6 configuration compatibility

    This component is not installed by default, because IIS 7.0 itself is not using it. This component intercepts all method calls to metabase and maps the method calls to the new system in IIS 7.

    You can refer to this article for more details:

    http://www.iis.net/articles/view.aspx/IIS7/Use-IIS7-Administration-Tools/Using-XML-Configuration/Metabase-Compatibility-with-IIS7

    Hope it helps.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, October 8, 2007 4:35 AM