none
EDI Batching not working for 810 documents setup RRS feed

  • Question

  • I have an EDI 810 Project that creates 810's for several of my EDI Parties.  One of my Parties has requested for me to batch the 810's into one ISA instead of an ISA for each 810.  I attempted to set up the batching, but it is not working.  On the Party EDI Properties, I used the Interchange Batch Creation Settings.  I setup the Filter criteria to a max of 2 sets, just to test the process.  I activated the batching.  In the filter, I was noted to use EDI. DestinationPartyName == Customer 810 And EDI.ToBeBatched == False, on the send port.  I then created the send port, EDI.Demo.Example.BatchDemo.FILE with TYPE of FILE, Destination folder \Customer\IncomingData.  This is the  Send Port associated with the Parties.  I was not clear if the send port should be created with the EDI 810 Project/Application or the BizTalk EDI Application.

    I created the Receive Port/Location on the BizTalk EDI Application with the Type of FILE and the EdiReceive pipeline. 

    I must have missed a setup that I need.  Everytime I test the configuration, I get the following errors.

    Error 1:  If the EDI data has a zero at the end of the Data Element, IT104,  the data is invalid.  If I change the data from 11.930 to 11.931, it is ok.

    Error 2:  A message received by adapter "FILE" on receive location "EDI.Demo.Example.BatchDemo.FILE.LOCATION is suspended.  Error details:  The output message of the receive pipeline "Microsoft,BizTalk.Edi.DefaultPipeline.EdiReceive  failed routing because there is no subscribing orghestration or send port.

    I must have this  configured wrong.

    Tuesday, March 30, 2010 6:44 PM

Answers

  • Hi Brunsova

    1. Seems to be wierd behavior, I think you might not have restarted the batching orchestration. Stop the batching and start again. This should fix it.

    2. Two round trips for batching is not required. The batching should be done like:

    Recieve(EDI)->Batching orchestration->Send(EDI)

    On the party bind the send port used for filter as :EDI. DestinationPartyName == Customer 810 And EDI.ToBeBatched == False

    Regards

    Nikhil

    • Marked as answer by brunsova Wednesday, March 31, 2010 6:07 PM
    Wednesday, March 31, 2010 2:15 PM

All replies

  • Hi Brunsova.

    1. You can create the send port in the specific Application

    2. For error 1 you have to modify party settings. Go to the party->EDI properties->X12->Party as Sender->Ack generation and validation settings->Document  validation properties->Select EDI Type and also Allow leading and trailing zeros and spaces.

    3. For error 2 refer http://msdn.microsoft.com/en-us/library/bb226413(v=BTS.10).aspx. To give you a brief idea : if you are expecting it to get picked up by batching orchestration then check the batch filter is matching the incoming file context. Else if you are expecting it to get picked by send port then you need to use BTS.ReceivePortName=YourRecievePort.

    Nikhil

    Wednesday, March 31, 2010 7:24 AM
  • Hi, Nikhil.

    For error 1, I have the EDI type and also Allow leading and trailing zeros and spaces selected.  It works when I am not trying to batch, but when I turn on the batching for the Party, it fails.

    For error 2, I will look at the suggested website.   Please tell me if my thought process is correct or false.  My 810 Application generates the EDI810 files.  I need a send port using the EdiSend pipeline to send the files to the BizTalk EDI Application.  The URL for the send port is a file directory called Incoming.  The BizTalk EDI Application has the batching orchestration that I need to batch the multiple 810 files into one big 810 file.  On the BizTalk EDI Application, I will have a Receive Location/Port with the EdiReceive pipeline.  The URL for the Receve Location/Port is a File Type with the same directory called Incoming.   Also, on the Party the Send Port should be the Send port on my EDI 810 applicaton?

     

     

    Wednesday, March 31, 2010 12:43 PM
  • Hi Brunsova

    1. Seems to be wierd behavior, I think you might not have restarted the batching orchestration. Stop the batching and start again. This should fix it.

    2. Two round trips for batching is not required. The batching should be done like:

    Recieve(EDI)->Batching orchestration->Send(EDI)

    On the party bind the send port used for filter as :EDI. DestinationPartyName == Customer 810 And EDI.ToBeBatched == False

    Regards

    Nikhil

    • Marked as answer by brunsova Wednesday, March 31, 2010 6:07 PM
    Wednesday, March 31, 2010 2:15 PM
  • Hi, Nikhil.

     

    I tried stopping and restarted.  I am still getting an error. 

    My EDI 810 Application is creating 2 seperate invoices for Customer 810.  I output the invoices to a directory called 810Output.  

    Then, on the BizTalk EDI Application, I have the receive port setup for batching and a send port to output the batched invoices.

    The EDI Party has send port that is on the BizTalk EDI Application. 

    I am putting the 2 invoices in the folder EDI 810 incoming with is attached to the receive port on the BizTalk EDI Application.  I get the error "The output message of the receive pipeline failed routing because there is no subscribing orchestration or send port.

    I am confused.

    Wednesday, March 31, 2010 2:38 PM
  • Hi, Nikhil.

     

    Eventually, the batching began to work once I had stop and restrarted everything.

    I am still having the problem with data for the IT104  that ends with a zero.  I have the Trading Partner setup with EDI Type and allow trailing and leading zeros.   This only occurs with the batching.

     

     

    Wednesday, March 31, 2010 3:36 PM