none
Login failed for user xxxx Reason: Could not find a login matching the name provided RRS feed

  • Question

  • I installed SQL 2017 on Red Hat, added system to Active Directory and did setup AD authentication as mentioned in the documentation from Microsoft.

    As mentioned on this page: By creating logins for AD groups, you can manage access and permissions in SQL Server using AD group memberships, I added an AD group and added the sysadmin rights.

    When I try to logon to the server it cannot resolve the membership? Only users that are direct mentioned can logon.


    Thursday, May 2, 2019 12:04 PM

Answers

  • Hi Emile,

    Could you run the following query to check if the group has been created well? And also check the group scope in the AD. You can try to change it to universal.

    SELECT name, type_desc, is_disabled FROM sys.server_principals

    Best Regards,
    Puzzle
    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Monday, May 6, 2019 7:30 AM

All replies

  • Hi EmileTenhagen,

    Have you created a login for this AD group? Please refer to Create a Login and How to add Active Directory user group as login in SQL Server. You can use SSMS to connect from a Windows machine and create a login for this group. Or do it in T-SQL.

    Best Regards,
    Puzzle
    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com


    Friday, May 3, 2019 1:30 AM
  • are able to login using SA account ?  open using GUI ssms -> give right to aD user.

    also make sure that windows authentication is enabled ?

    1. Open SQL Server Management Studio.
    2. Choose Windows Authentication from the Authentication drop down list.
    3. Click Connect to open the Microsoft SQL Server Management Studio Express window.
    4. Right-click the SQL instance and choose Properties to open the Server Properties - <server\instance style="box-sizing:border-box;">window.</server\instance>
    5. Click Security on the left hand side.
    6. Choose SQL Server and Windows Authentication Mode on the right side.
    7. Click OK to close the Server Properties - <server\instance style="box-sizing:border-box;">window.</server\instance>
    8. Right-click the SQL instance and choose Restart.
    9. Click Yes to restart the SQL server.


    https://social.technet.microsoft.com/wiki/contents/articles/37872.sql-server-installation-on-centos-linux.aspx

    Friday, May 3, 2019 5:45 AM
  • Hello Puzzle,

    Yes, I have.

    Adding groups or user logins is not the problem. When I want to connect with a user who is member of a group I receive a login failed.

    I'm able to use id and getent to retrieve the user and group from AD.

    Rgds

    Emile

    Friday, May 3, 2019 1:33 PM
  • Hello,

    Yes, I'm able to login with sa.

    It's enabled.

    Rgds

    Emile

    Friday, May 3, 2019 1:34 PM
  • Hi Emile,

    Could you run the following query to check if the group has been created well? And also check the group scope in the AD. You can try to change it to universal.

    SELECT name, type_desc, is_disabled FROM sys.server_principals

    Best Regards,
    Puzzle
    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Monday, May 6, 2019 7:30 AM
  • Hello Puzzle,

    Thanks for your response.

    The groups are created. Your remark changing the scope of the groups did work. Changed them from "Local" to "Universal".

    Rgds

    Emile

    Monday, May 6, 2019 8:58 AM