locked
Subscription and email issues with Browser role. RRS feed

  • Question

  • We have our user's set up in the Browser role.  We are having an issue in that none of them can create a subscription on a  report or email a report.  If they set up a subscription, it is displayed but the report does not run.  When they try to email a report, the To: box is greyed out.  Has anyone encoutered this issue?  Does anyone have any suggestions on why this is happening?

    Thanks.

    Vicki

    Thursday, December 15, 2005 8:49 PM

Answers

  • Is the To: line populated?  It should be populated with the current user name. 

    By default, users in the Browser role can not chang the TO line, you can change this behavior by setting the SendEmailToUserAlias to false in the RSReportServer.config file.  This will mean any user that can subscribe to a report can send the email to anyone they wish.

     

    -Daniel

    Friday, December 16, 2005 6:27 PM

All replies

  • Is the SMTP server configured correctly?  Check the rsreportserver.config file to determine if the SMTP server is set.  The path to the file is something like C:\Program Files\Microsoft SQL Server\MSSQL.3\Reporting Services\ReportServer.

    Friday, December 16, 2005 2:00 PM
  • Subscriptions (email and fileshare) work perfectly fine for the users in Content Manager role just not the users in the Browser role.
    Friday, December 16, 2005 2:03 PM
  • Is the To: line populated?  It should be populated with the current user name. 

    By default, users in the Browser role can not chang the TO line, you can change this behavior by setting the SendEmailToUserAlias to false in the RSReportServer.config file.  This will mean any user that can subscribe to a report can send the email to anyone they wish.

     

    -Daniel

    Friday, December 16, 2005 6:27 PM
  • Hi,

      I changed the "SendEmailToUserAlias" to false in the RSReportServer.config file and then set up a subscription to a report. I typed in the email address and then clicked on the "Select Schedule" button to choose the schedule. When I had finished choosing the schedule and returned to the subscription setup window, the email address that I had typed in was gone. You have to type it back in after.

      Does anyone have a fix for this one?

    Thanks.

    Wednesday, April 19, 2006 8:21 PM
  • Hi there,

    I have successfully set up a Report Subscription and it sends the report to our internal users at a given time each day.

    I recently added an external email address in the 'CC' & 'BCC' boxes but i got an error saying the address was invalid (i've tried with just the 'To' box as well). There's nothing special about the external address, i've tried with gmail, BT, and Yahoo.

    So it would seem that any address outside of my local domain is invalid.

    Is there some config setting that i'm overlooking? Has anyone had this problem?

    I'm using SQL Server 2005 Standard Edition.

    Any help would be great.

    Thanks,
    Elracorey

    Monday, April 7, 2008 2:38 PM
  • @theinspector

     

    I am not able to reproduce this using RS 2005 SP2.  What version are you using?

     

    -Daniel

     

    Monday, April 7, 2008 4:42 PM
  • @Elracorey

     

    Report Server does very little validation of the email address.  Generally we just construct the email message and pass it on to the SMTP to validate.  So most likely you will need to look there for possible problems.

     

    That being said, there is one setting that we check.  In the RSReportServer.config file there is an element called PermittedHosts.  If there are no values in this element then Report Server just passes the email address along.  If there are then the Report Server ensures that the domain names for all email address are one of the values in this element.

     

    I hope this helps.

    -Daniel

     

    Monday, April 7, 2008 4:56 PM
  •  Elracorey wrote:

    Hi there,

    I have successfully set up a Report Subscription and it sends the report to our internal users at a given time each day.

    I recently added an external email address in the 'CC' & 'BCC' boxes but i got an error saying the address was invalid (i've tried with just the 'To' box as well). There's nothing special about the external address, i've tried with gmail, BT, and Yahoo.

    So it would seem that any address outside of my local domain is invalid.

    Is there some config setting that i'm overlooking? Has anyone had this problem?

    I'm using SQL Server 2005 Standard Edition.

    Any help would be great.

    Thanks,
    Elracorey

     

    I think we're getting the exact same error on a newly installed instance of SSRS  - "The e-mail address of one or more recipients is not valid.". As far as we can tell, we've got everything set up the same as an existing SSRS server which is sending emails out without any trouble (apart from having a seperate database).

    Friday, April 11, 2008 8:36 AM
  • My issue was just resolved after plowing through another twenty odd pages - the new server was added to the permitted server list on our SMTP box.

     

    Friday, April 11, 2008 9:05 AM
  • Thanks for everyone's feedback.

     

    The thing that's puzzling me is the difference in how Database Mail (sent directly from the Management Console) and SSRS e-mail are handled.

     

    I can successfully send test mails using Database Mail, but not with SSRS. Why would I need to do anything with the SMTP server at all?

     

    It's worth adding that the SMTP options has the box ticked that says allow any computer that authenticates.

     

    Thanks.

    Friday, April 11, 2008 6:02 PM
  • Report Server does not use the same mechanism for delivering mail that the database mail system uses.  RS uses the servers local CDO objects to send mail to the server.  Having one work does not mean the other will.

     

    -Daniel

    Monday, April 14, 2008 9:41 PM
  • Thanks for the pointer Daniel. I looked up an article on CDO at http://technet.microsoft.com/en-us/library/ms159155.aspx

     

    It basically talks about the RSConfiguration file which i've checked and the settings seem pretty standard. My SMTP server is listed correctly, the port is default 25.

     

    I'm afraid still no luck!

     

    Regards

     

    Tuesday, April 15, 2008 9:49 AM
  • If you have nothing in the PermittedHost section of the config file, then I am not sure what would be causing this issue.  I would double check the SMTP server settings to see if there is something there that might be causing this issue.

     

    -Daniel

     

    Tuesday, April 15, 2008 4:15 PM
  •  

    Elracorey, are ryou sure that the reporting services server has been given access on the SMTP server itself?

    When I installed it on a new webserver, I wasn't aware of the need to give the box permission on the mail server (thanks to lack of documentation from the lad who set up our old servers) and spent a couple of days headbutting the desk til I found it mentioned as an aside somewhere. Once that was done, a fresh out of the box bog standard install with no permitted hosts specified in the config file started working perfectly.

     

    (apologies if you've already been through this before, trying to answer on the fly between users screaming at me about their reports being too blue)
    Tuesday, April 15, 2008 5:37 PM
  • The SMTP server has the "allow alll computers that authenticate" box checked in the Relay restrictions. There's nothing else of any significance in there.

     

    What exactly do I need to set? We're using an exchange server and I'm worried that I might do something to bring the e-mail system down. The SMTP server is a grey area for me. 

     

    Thanks.

     

    Thursday, April 17, 2008 10:27 AM
  • Ok, I was brave enough to attempt what you guys said and it worked!

     

    I am extremely puzzled about what the check boxes are specifying.

     

    As I said earlier the Relay Restrictions dialog has both "Only the list below" and "Allow all computers ....." checked, plus

    I now have my IP address in the list box with granted access. This seems a contradiction in terms as far as I'm concerened.

     

    Regards,

    Elracorey

     

    Thursday, April 17, 2008 2:41 PM